From 3539b401b13270f28bbfb6dd1250c568cede7cad Mon Sep 17 00:00:00 2001
From: "David E. O'Brien" <obrien@FreeBSD.org>
Date: Mon, 6 Jan 2003 19:48:31 +0000
Subject: Reduce the sed exec'ing an order of magnitude.  Minor code
 repositioning also.

---
 net/rdesktop/Makefile | 25 ++++++++++++-------------
 1 file changed, 12 insertions(+), 13 deletions(-)

(limited to 'net')

diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index a87545161f3a..6bf83cb8e3ed 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -19,14 +19,7 @@ PATCH_DIST_STRIP=	-p2
 
 MAINTAINER=	chris@aims.com.au
 
-USE_XLIB=	yes
 USE_BZIP2=	yes
-USE_GMAKE=	yes
-USE_OPENSSL=	yes
-USE_REINPLACE=	yes
-
-MAN1=		rdesktop.1
-ALL_TARGET=
 
 .include <bsd.port.pre.mk>
 
@@ -34,22 +27,28 @@ ALL_TARGET=
 LIB_DEPENDS=	gmp.6:${PORTSDIR}/math/libgmp4
 .endif
 
+USE_XLIB=	yes
+USE_GMAKE=	yes
+USE_OPENSSL=	yes
+USE_REINPLACE=	yes
+ALL_TARGET=
+MAN1=		rdesktop.1
+
 do-patch:
 	@${EXTRACT_CMD} -dc ${_DISTDIR}/${PATCHFILES} | \
 		${PATCH} ${PATCH_DIST_ARGS}
 .if ${OSVERSION} > 500023
 	@${REINPLACE_CMD} -e 's:-O2.*-Wall:${CFLAGS} -I${LOCALBASE}/include:g' \
-		${WRKSRC}/Makefile
-	@${REINPLACE_CMD} -e 's:-lgmp:-L${LOCALBASE}/lib -lgmp:g' \
+			  -e 's:-lgmp:-L${LOCALBASE}/lib -lgmp:g' \
 		${WRKSRC}/Makefile
 .else
 	@${REINPLACE_CMD} -e 's:-O2.*-Wall:${CFLAGS}:g' ${WRKSRC}/Makefile
 .endif
-	@${REINPLACE_CMD} -e 's:/usr/X11R6/:${X11BASE}/:g' ${WRKSRC}/Makefile
-	@${REINPLACE_CMD} -e 's:^PREFIX.*:PREFIX=${PREFIX}:g' ${WRKSRC}/Makefile
-	@${REINPLACE_CMD} -e 's:^install.*:install\: rdesktop:g' \
+	@${REINPLACE_CMD} -e 's:/usr/X11R6/:${X11BASE}/:g' \
+			  -e 's:^PREFIX.*:PREFIX=${PREFIX}:g' \
+			  -e 's:^install.*:install\: rdesktop:g' \
+			  -e 's:^.*(INSTALL) rdp-srvr.*::g' \
 		${WRKSRC}/Makefile
-	@${REINPLACE_CMD} -e 's:^.*(INSTALL) rdp-srvr.*::g' ${WRKSRC}/Makefile
 	@${REINPLACE_CMD} -e 's:<endian.h>:<machine/endian.h>:g' \
 		${WRKSRC}/rdesktop.h
 
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0