From f62ba38aa4859ce7cc9c4841853b415d9ed93488 Mon Sep 17 00:00:00 2001
From: Jean Milanez Melo <jmelo@FreeBSD.org>
Date: Wed, 31 May 2006 17:50:06 +0000
Subject: - Update to 0.3.4. - Unbreak on 4.X. - Update to use new USE_RC_SUBR
 style.

PR:		ports/96266
Submitted by:	Olivier Beyssac <obld@r14.freenix.org> (maintainer)
Reworked by:	mnag, jmelo
Approved by:	mnag (mentor)
---
 net/bld/Makefile       | 20 +++++---------------
 net/bld/distinfo       |  6 +++---
 net/bld/files/bld.in   | 30 ++++++++++++++++++++++++++++++
 net/bld/files/bld.sh   | 30 ------------------------------
 net/bld/files/patch-aa |  8 ++++----
 net/bld/files/patch-ab |  4 ++--
 net/bld/files/patch-ac | 20 ++++++++++++++++++++
 net/bld/pkg-plist      |  6 ++----
 8 files changed, 66 insertions(+), 58 deletions(-)
 create mode 100644 net/bld/files/bld.in
 delete mode 100644 net/bld/files/bld.sh
 create mode 100644 net/bld/files/patch-ac

(limited to 'net/bld')

diff --git a/net/bld/Makefile b/net/bld/Makefile
index af0f2c8d8739..62db7566e4b5 100644
--- a/net/bld/Makefile
+++ b/net/bld/Makefile
@@ -6,16 +6,17 @@
 #
 
 PORTNAME=	bld
-PORTVERSION=	0.3.3
+PORTVERSION=	0.3.4
 CATEGORIES=	net
 MASTER_SITES=	http://www.online.redhate.org/bld/
 
 MAINTAINER=	obld@r14.freenix.org
 COMMENT=	A blacklisting daemon
 
-USE_RC_SUBR=	yes
+USE_RC_SUBR=	bld
 MANCOMPRESSED=	yes
 GNU_CONFIGURE=	yes
+USE_GCC=	3.2+
 
 CONFIGURE_ARGS=	--sysconfdir=${PREFIX}/etc/bld
 PORTDOCS=	README README.postfix
@@ -24,16 +25,7 @@ MAN8=		bldsubmit.8 bld.8 bldquery.8 bldread.8 bldinsert.8 blddecr.8 \
 		bld-pf_policy.8 bld-pf_log.pl.8 bld-mrtg.pl.8 \
 		bld-will_spam_for_food.pl.8
 
-SED_SCRIPT=	-e 's|%%PREFIX%%|${PREFIX}|g'
-RC_DIR=		${PREFIX}/etc/rc.d
-RC_SUFX=	.sh
-SED_SCRIPT+=	-e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
-		-e 's|%%RC_DIR%%|${RC_DIR}|g' \
-		-e 's|%%RC_SUFX%%|${RC_SUFX}|g'
-
-post-build:
-		${SED} ${SED_SCRIPT} ${FILESDIR}/bld.sh \
-			>${WRKDIR}/bld.sh
+.include <bsd.port.pre.mk>
 
 post-install:
 .if !defined(NOPORTDOCS)
@@ -42,8 +34,6 @@ post-install:
 	${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
 .endfor
 .endif
-	@${INSTALL_SCRIPT} ${WRKDIR}/bld.sh \
-		${RC_DIR}/bld${RC_SUFX}
 	${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
 
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/bld/distinfo b/net/bld/distinfo
index f643ac6bf5ff..44ba3afc0beb 100644
--- a/net/bld/distinfo
+++ b/net/bld/distinfo
@@ -1,3 +1,3 @@
-MD5 (bld-0.3.3.tar.gz) = 7799f612d42ecfa08f6942eb400a3a36
-SHA256 (bld-0.3.3.tar.gz) = 4a5e9ae6ff6cb84348de080d2208c0b364bdfc15f49a2f707c5f8bd727d74f24
-SIZE (bld-0.3.3.tar.gz) = 73338
+MD5 (bld-0.3.4.tar.gz) = 743e794c286f1b72070478cedfc68da3
+SHA256 (bld-0.3.4.tar.gz) = 7a9726768ab0b75ce4b899ab8012f61bdf9926af741aafdc46876fbf496aa4a9
+SIZE (bld-0.3.4.tar.gz) = 74270
diff --git a/net/bld/files/bld.in b/net/bld/files/bld.in
new file mode 100644
index 000000000000..49eeb83341c0
--- /dev/null
+++ b/net/bld/files/bld.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+# PROVIDE: bld
+# REQUIRE: LOGIN
+# BEFORE: mail
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable bld:
+#
+#bld_enable="YES"
+#
+# See bld(8) for flags
+#
+
+. %%RC_SUBR%%
+
+name="bld"
+rcvar=${name}_enable
+
+load_rc_config $name
+
+: ${bld_enable:-"NO"}
+: ${bld_flags:-"-u bld -g bld"}
+
+command="%%PREFIX%%/sbin/bld"
+extra_commands="reload"
+required_dirs=/var/run/bld
+
+run_rc_command "$1"
diff --git a/net/bld/files/bld.sh b/net/bld/files/bld.sh
deleted file mode 100644
index f0852d982d24..000000000000
--- a/net/bld/files/bld.sh
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-
-# PROVIDE: bld
-# REQUIRE: LOGIN
-# BEFORE: mail
-# KEYWORD: shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable bld:
-#
-#bld_enable="YES"
-#
-# See bld(8) for flags
-#
-
-. %%RC_SUBR%%
-
-name=bld
-rcvar=`set_rcvar`
-
-command=%%PREFIX%%/sbin/bld
-required_dirs=/var/run/bld
-
-# set defaults
-
-bld_enable=${bld_enable:-"NO"}
-bld_flags=${bld_flags:-"-u bld -g bld"}
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/net/bld/files/patch-aa b/net/bld/files/patch-aa
index 738ccf3ef2e5..a1d4c0d8336b 100644
--- a/net/bld/files/patch-aa
+++ b/net/bld/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.in.orig	Thu Oct 28 11:44:20 2004
-+++ Makefile.in	Thu Oct 28 11:44:43 2004
-@@ -49,6 +49,10 @@
+--- Makefile.in.orig	Thu May 18 17:31:03 2006
++++ Makefile.in	Thu May 18 17:31:45 2006
+@@ -52,6 +52,10 @@
  	    && (cd $(DESTDIR)$(sbindir) && ln -s $(SUBMITNAME) $(INSERTNAME)) \
  	    && (cd $(DESTDIR)$(sbindir) && ln -s $(SUBMITNAME) $(DECRNAME))
  	strip $(DESTDIR)$(sbindir)/$(SUBMITNAME)
@@ -8,6 +8,6 @@
 +	cp utils/bld-pf_log.pl $(DESTDIR)/$(sbindir)
 +	[ -d $(DESTDIR)$(sysconfdir) ] || mkdir -p $(DESTDIR)$(sysconfdir)
 +	cp bld.conf.sample $(DESTDIR)/$(sysconfdir)
- 	[ -d $(DESTDIR)$(mandir) ] || mkdir -p $(DESTDIR)$(mandir)/man8
+ 	[ -d $(DESTDIR)$(mandir)/man8 ] || mkdir -p $(DESTDIR)$(mandir)/man8
  	$(GZIP) -c bld.8 > $(DESTDIR)$(mandir)/man8/bld.8.gz
  	$(GZIP) -c bldread.8 > $(DESTDIR)$(mandir)/man8/bldread.8.gz
diff --git a/net/bld/files/patch-ab b/net/bld/files/patch-ab
index 00f3069fff0d..4f18a4d2cb46 100644
--- a/net/bld/files/patch-ab
+++ b/net/bld/files/patch-ab
@@ -1,5 +1,5 @@
---- bld.conf.sample.orig	Thu Oct 28 12:52:25 2004
-+++ bld.conf.sample	Thu Oct 28 12:52:37 2004
+--- bld.conf.sample.orig	Thu May 18 17:32:56 2006
++++ bld.conf.sample	Thu May 18 17:33:33 2006
 @@ -26,10 +26,10 @@
  #log_level=1
  
diff --git a/net/bld/files/patch-ac b/net/bld/files/patch-ac
new file mode 100644
index 000000000000..65667ad83db2
--- /dev/null
+++ b/net/bld/files/patch-ac
@@ -0,0 +1,20 @@
+#
+# Fix build on 4.x reorganizing #include headers
+#
+
+--- client.c.orig	Wed May 31 14:23:30 2006
++++ client.c	Wed May 31 14:23:45 2006
+@@ -24,11 +24,12 @@
+  * SUCH DAMAGE.
+  *
+  */
++#include <stdio.h>
++#include <unistd.h>
+ #include <ctype.h>
+ #include <sys/select.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
+-#include <unistd.h>
+ #include <string.h>
+ #include <errno.h>
+ #include "options.h"
diff --git a/net/bld/pkg-plist b/net/bld/pkg-plist
index 80106aead170..1558e19c0a8b 100644
--- a/net/bld/pkg-plist
+++ b/net/bld/pkg-plist
@@ -9,8 +9,6 @@ sbin/bld-pf_policy
 sbin/bld-pf_policy.pl
 sbin/bld-pf_log.pl
 sbin/bld-will_spam_for_food.pl
-etc/rc.d/bld.sh
 etc/bld/bld.conf.sample
-@unexec rmdir %D/etc/bld 2>/dev/null || (echo ; echo "Keeping homemade configuration files in %D/etc/bld" ; echo) || true
-%%PORTDOCS%%@unexec %D/%%DOCSDIR%% 2>/dev/null || true
-@unexec rmdir /var/run/bld 2>/dev/null || (echo ; echo "Remove dumps from /var/run/bld/* if you don't want to keep them" ; echo) && true
+@dirrmtry etc/bld
+@dirrmtry /var/run/bld
-- 
cgit v1.2.3