From 135b9bec7f19f162ba4a6c74cbc4e643e3225602 Mon Sep 17 00:00:00 2001
From: Maxime Henrion <mux@FreeBSD.org>
Date: Wed, 11 Apr 2007 16:20:53 +0000
Subject: Add a patch taken from CVS to fix EXEC actions handling with
 monitoring thresholds, and bump PORTREVISION.

---
 net-mgmt/cricket/Makefile                   |  2 +-
 net-mgmt/cricket/files/patch-lib-Monitor.pm | 19 +++++++++++++++++++
 2 files changed, 20 insertions(+), 1 deletion(-)
 create mode 100644 net-mgmt/cricket/files/patch-lib-Monitor.pm

(limited to 'net-mgmt')

diff --git a/net-mgmt/cricket/Makefile b/net-mgmt/cricket/Makefile
index 2dc953e3b76f..d941dea259a8 100644
--- a/net-mgmt/cricket/Makefile
+++ b/net-mgmt/cricket/Makefile
@@ -7,7 +7,7 @@
 
 PORTNAME=	cricket
 PORTVERSION=	1.0.5
-PORTREVISION=	3
+PORTREVISION=	4
 CATEGORIES=	net-mgmt
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	${PORTNAME}
diff --git a/net-mgmt/cricket/files/patch-lib-Monitor.pm b/net-mgmt/cricket/files/patch-lib-Monitor.pm
new file mode 100644
index 000000000000..71e006604aa9
--- /dev/null
+++ b/net-mgmt/cricket/files/patch-lib-Monitor.pm
@@ -0,0 +1,19 @@
+--- lib/Monitor.pm.orig	2004/02/19 15:58:07	1.31
++++ lib/Monitor.pm	2007/01/21 04:17:22	1.32
+@@ -526,14 +526,15 @@
+ sub alarmExec {
+     my ($args, $action) = @_;
+     my $alarmArgs       = $$args[7];
+-    system($alarmArgs->[0]);
+ 
+     if ($action eq 'ADD') {
++        system($alarmArgs->[0]);
+         Info("Monitor: Triggered event with system command '".
+              $alarmArgs->[0]."' .");
+     }
+ 
+     else {
++        system($alarmArgs->[1]);
+         Info("Monitor: Cleared event with shell command '".
+              $alarmArgs->[1]."' .");
+     }
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0