From 27be599386e4df13f9d8237ddbf3228189cabbd8 Mon Sep 17 00:00:00 2001
From: Pav Lucistnik <pav@FreeBSD.org>
Date: Fri, 20 Aug 2004 22:34:03 +0000
Subject: - Use OPTIONS for extra dependencies

PR:		ports/70724
Submitted by:	Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw>
---
 multimedia/fxtv/Makefile | 20 ++++++++++++--------
 1 file changed, 12 insertions(+), 8 deletions(-)

(limited to 'multimedia/fxtv')

diff --git a/multimedia/fxtv/Makefile b/multimedia/fxtv/Makefile
index d55dadfc45db..299dbecf5b04 100644
--- a/multimedia/fxtv/Makefile
+++ b/multimedia/fxtv/Makefile
@@ -19,22 +19,26 @@ COMMENT=	X-based TV Display and Capture Application (for use with bt848 driver)
 LIB_DEPENDS=	tiff.4:${PORTSDIR}/graphics/tiff \
 		Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
 
-# This program does not actually require the programs below unless you
-#   use audio/video recording and/or playback and save to a non-raw format.
-#RUN_DEPENDS=	sox:${PORTSDIR}/audio/sox \
-#		mpg123:${PORTSDIR}/audio/mpg123 \
-#		mpeg_musicin:${PORTSDIR}/audio/mpegaudio \
-#		mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
-#		mplex:${PORTSDIR}/multimedia/mplex
-
 USE_X_PREFIX=	yes
 USE_XPM=	yes
 USE_GMAKE=	yes
 MAKE_FLAGS=	-e
 MAN1=		fxtv.1
 
+OPTIONS=	EXTRA "Extra programs required to record/playback/save" off
+
 .include <bsd.port.pre.mk>
 
+# This program does not actually require the programs below unless you
+#   use audio/video recording and/or playback and save to a non-raw format.
+.if defined(WITH_EXTRA)
+RUN_DEPENDS+=	sox:${PORTSDIR}/audio/sox \
+		mpg123:${PORTSDIR}/audio/mpg123 \
+		mpeg_musicin:${PORTSDIR}/audio/mpegaudio \
+		mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
+		mplex:${PORTSDIR}/multimedia/mplex
+.endif
+
 pre-everything::
 .if ${OSVERSION} < 500000
 ONLY_FOR_ARCHS=	i386
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0