From 981420fb43bfedddd64342ab613cdfb85f60eefc Mon Sep 17 00:00:00 2001
From: Alejandro Pulver <alepulver@FreeBSD.org>
Date: Tue, 31 Oct 2006 03:03:42 +0000
Subject: Plots data on map projections (with continental and political
 boundaries).

WWW: http://matplotlib.sourceforge.net/matplotlib.toolkits.basemap.basemap.html

PR:		ports/104316
Submitted by:	mainland at apeiron.net
---
 math/Makefile                                      |  1 +
 math/py-basemap/Makefile                           | 59 ++++++++++++++++++++++
 math/py-basemap/distinfo                           |  3 ++
 ...-lib__matplotlib__toolkits__basemap__basemap.py | 11 ++++
 math/py-basemap/pkg-descr                          |  3 ++
 5 files changed, 77 insertions(+)
 create mode 100644 math/py-basemap/Makefile
 create mode 100644 math/py-basemap/distinfo
 create mode 100644 math/py-basemap/files/patch-lib__matplotlib__toolkits__basemap__basemap.py
 create mode 100644 math/py-basemap/pkg-descr

(limited to 'math')

diff --git a/math/Makefile b/math/Makefile
index 7742984ae46b..1816684014b0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -272,6 +272,7 @@
     SUBDIR += polymake
     SUBDIR += proofgeneral
     SUBDIR += pspp
+    SUBDIR += py-basemap
     SUBDIR += py-fpconst
     SUBDIR += py-gato
     SUBDIR += py-gnuplot
diff --git a/math/py-basemap/Makefile b/math/py-basemap/Makefile
new file mode 100644
index 000000000000..e609b07c5f8a
--- /dev/null
+++ b/math/py-basemap/Makefile
@@ -0,0 +1,59 @@
+# ex:ts=8
+# Ports collection makefile for:	py-basemap
+# Date created:			April 21, 2006
+# Whom:				mainland@apeiron.net
+#
+# $FreeBSD$
+#
+
+PORTNAME=	basemap
+PORTVERSION=	0.9.2
+CATEGORIES=	math python
+MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=	matplotlib
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER=	mainland@apeiron.net
+COMMENT=	Plots data on map projections (with continental and political boundaries)
+
+RUN_DEPENDS=	${PYTHON_SITELIBDIR}/matplotlib/:${PORTSDIR}/math/py-matplotlib
+
+USE_PYTHON=	2.2+
+USE_PYDISTUTILS=	yes
+
+DATADIR=	${PREFIX}/share/py-${PORTNAME}-data
+EXAMPLESDIR=	${PREFIX}/share/examples/py-${PORTNAME}
+
+MAKE_ENV=	BASEMAP_DATA_PATH=${DATADIR}
+
+PLISTDIR=	${PYTHON_SITELIBDIR}/matplotlib/toolkits/basemap \
+		${PYTHON_SITELIBDIR}/shapelib \
+		${PYTHON_SITELIBDIR}/dbflib \
+		${PYTHON_SITELIBDIR}/dbflibc.so \
+		${PYTHON_SITELIBDIR}/shptree.so \
+		${PYTHON_SITELIBDIR}/shapelibc.so \
+		${PYTHON_SITELIBDIR}/pyproj.so \
+		${PYTHON_SITELIBDIR}/basemap-0.9.2-py2.5.egg-info \
+		${DATADIR}
+.if !defined(NOPORTDOCS)
+PLISTDIR+=	${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+post-patch:
+	@${GREP} -lR "share/basemap" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+		-e "s,share/basemap,share/py-basemap-data,g"
+
+post-install:
+.if !defined(NOPORTDOCS)
+	@${MKDIR} ${EXAMPLESDIR}
+	${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+.endif
+.for dir in ${PLISTDIR}
+	@${FIND} ${dir} ! -type d | \
+		${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+	@${FIND} ${dir} -type d | ${SORT} -r | \
+		${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/math/py-basemap/distinfo b/math/py-basemap/distinfo
new file mode 100644
index 000000000000..ee2fb388cc7f
--- /dev/null
+++ b/math/py-basemap/distinfo
@@ -0,0 +1,3 @@
+MD5 (basemap-0.9.2.tar.gz) = 1b2f7f654c007ca5cd98fcd18b85df61
+SHA256 (basemap-0.9.2.tar.gz) = 602c73cda3f657b49f7cabc5a60bd203a42f8cb7694c3e4fbcb6dc27389fbf0c
+SIZE (basemap-0.9.2.tar.gz) = 7348431
diff --git a/math/py-basemap/files/patch-lib__matplotlib__toolkits__basemap__basemap.py b/math/py-basemap/files/patch-lib__matplotlib__toolkits__basemap__basemap.py
new file mode 100644
index 000000000000..c10d7d53dd71
--- /dev/null
+++ b/math/py-basemap/files/patch-lib__matplotlib__toolkits__basemap__basemap.py
@@ -0,0 +1,11 @@
+--- lib/matplotlib/toolkits/basemap/basemap.py.orig     Wed Oct 11 12:46:53 2006
++++ lib/matplotlib/toolkits/basemap/basemap.py  Wed Oct 11 12:47:16 2006
+@@ -22,7 +22,7 @@
+ # BASEMAP_DATA_PATH env var not set.
+ _datadir = os.environ.get('BASEMAP_DATA_PATH')
+ if not _datadir:
+-   _datadir = os.path.join(sys.prefix,'share','basemap')
++   _datadir = os.path.join(sys.prefix,'share','py-basemap-data')
+
+ __version__ = '0.9.2'
+ __revision__ = '20060831'
diff --git a/math/py-basemap/pkg-descr b/math/py-basemap/pkg-descr
new file mode 100644
index 000000000000..9b89f1476f8e
--- /dev/null
+++ b/math/py-basemap/pkg-descr
@@ -0,0 +1,3 @@
+Plots data on map projections (with continental and political boundaries).
+
+WWW: http://matplotlib.sourceforge.net/matplotlib.toolkits.basemap.basemap.html
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0