From 7e9f8896a80af76cde08d5f589f27e860363a866 Mon Sep 17 00:00:00 2001
From: Anton Berezin <tobez@FreeBSD.org>
Date: Mon, 24 Oct 2005 08:28:28 +0000
Subject: Add math/p5-Math-ConvexHull 1.00, a Perl module to calculate convex
 hulls using Graham's scan (n*log(n)).

---
 math/Makefile                     |  1 +
 math/p5-Math-ConvexHull/Makefile  | 28 ++++++++++++++++++++++++++++
 math/p5-Math-ConvexHull/distinfo  |  2 ++
 math/p5-Math-ConvexHull/pkg-descr |  9 +++++++++
 math/p5-Math-ConvexHull/pkg-plist |  5 +++++
 5 files changed, 45 insertions(+)
 create mode 100644 math/p5-Math-ConvexHull/Makefile
 create mode 100644 math/p5-Math-ConvexHull/distinfo
 create mode 100644 math/p5-Math-ConvexHull/pkg-descr
 create mode 100644 math/p5-Math-ConvexHull/pkg-plist

(limited to 'math')

diff --git a/math/Makefile b/math/Makefile
index 023fff5a7fed..20b5b373f266 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -160,6 +160,7 @@
     SUBDIR += p5-Math-BigRat
     SUBDIR += p5-Math-Calc-Units
     SUBDIR += p5-Math-Combinatorics
+    SUBDIR += p5-Math-ConvexHull
     SUBDIR += p5-Math-Currency
     SUBDIR += p5-Math-Derivative
     SUBDIR += p5-Math-Expr
diff --git a/math/p5-Math-ConvexHull/Makefile b/math/p5-Math-ConvexHull/Makefile
new file mode 100644
index 000000000000..2193bbbb0e02
--- /dev/null
+++ b/math/p5-Math-ConvexHull/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for:	math/p5-Math-ConvexHull
+# Date created:				24 October 2005
+# Whom:					Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	Math-ConvexHull
+PORTVERSION=	1.00
+CATEGORIES=	math perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=	Math
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	tobez@FreeBSD.org
+COMMENT=	Calculate convex hulls using Graham's scan (n*log(n))
+
+PERL_CONFIGURE=	yes
+
+MAN3=	Math::ConvexHull.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE=		requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-ConvexHull/distinfo b/math/p5-Math-ConvexHull/distinfo
new file mode 100644
index 000000000000..47564de14654
--- /dev/null
+++ b/math/p5-Math-ConvexHull/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-ConvexHull-1.00.tar.gz) = b3b5ccbdbf3094ac7ae96dd763981636
+SIZE (Math-ConvexHull-1.00.tar.gz) = 3124
diff --git a/math/p5-Math-ConvexHull/pkg-descr b/math/p5-Math-ConvexHull/pkg-descr
new file mode 100644
index 000000000000..05a3a5b4bab6
--- /dev/null
+++ b/math/p5-Math-ConvexHull/pkg-descr
@@ -0,0 +1,9 @@
+Math::ConvexHull is a simple module that calculates convex hulls from a
+set of points in 2D space. It is a straightforward implementation of the
+algorithm known as Graham's scan which, with complexity of O(n*log(n)),
+is the fastest known method of finding the convex hull of an arbitrary
+set of points.  There are some methods of eliminating points that cannot
+be part of the convex hull. These may or may not be implemented in a
+future version.
+
+WWW: http://search.cpan.org/dist/Math-ConvexHull/
diff --git a/math/p5-Math-ConvexHull/pkg-plist b/math/p5-Math-ConvexHull/pkg-plist
new file mode 100644
index 000000000000..ff11bfdaa509
--- /dev/null
+++ b/math/p5-Math-ConvexHull/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/ConvexHull.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/ConvexHull/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/ConvexHull 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Math 2>/dev/null || true
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0