From ff608940ccf7f0b4790cce78c8a95c0887fe6b2b Mon Sep 17 00:00:00 2001
From: Edwin Groothuis <edwin@FreeBSD.org>
Date: Thu, 16 Jan 2003 04:55:24 +0000
Subject: New port: mail/hotway, a POP3 gateway for Hotmail/MSN mail

PR:		ports/44593
Submitted by:	John Nielsen <john@jnielsen.net>
---
 mail/hotwayd/Makefile                | 28 ++++++++++++++++++++++++++++
 mail/hotwayd/distinfo                |  1 +
 mail/hotwayd/files/patch-Makefile.in | 11 +++++++++++
 mail/hotwayd/files/patch-inet.c      | 10 ++++++++++
 mail/hotwayd/pkg-comment             |  1 +
 mail/hotwayd/pkg-descr               |  6 ++++++
 mail/hotwayd/pkg-message             | 20 ++++++++++++++++++++
 mail/hotwayd/pkg-plist               |  5 +++++
 8 files changed, 82 insertions(+)
 create mode 100644 mail/hotwayd/Makefile
 create mode 100644 mail/hotwayd/distinfo
 create mode 100644 mail/hotwayd/files/patch-Makefile.in
 create mode 100644 mail/hotwayd/files/patch-inet.c
 create mode 100644 mail/hotwayd/pkg-comment
 create mode 100644 mail/hotwayd/pkg-descr
 create mode 100644 mail/hotwayd/pkg-message
 create mode 100644 mail/hotwayd/pkg-plist

(limited to 'mail/hotwayd')

diff --git a/mail/hotwayd/Makefile b/mail/hotwayd/Makefile
new file mode 100644
index 000000000000..6259ca3c68c5
--- /dev/null
+++ b/mail/hotwayd/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for:	hotwayd
+# Date created:				29 October 2002
+# Whom:					John Nielsen <john@jnielsen.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	hotwayd
+PORTVERSION=	0.51
+CATEGORIES=	mail
+#MASTER_SITES=	http://people.freenet.de/courierdave/
+MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=	hotwayd
+DISTNAME=	hotway-0.51
+
+MAINTAINER=	john@jnielsen.net
+
+LIB_DEPENDS=	xml2.5:${PORTSDIR}/textproc/libxml2 \
+		iconv.3:${PORTSDIR}/converters/libiconv
+
+USE_BZIP2=	yes
+GNU_CONFIGURE=	yes
+USE_GMAKE=	yes
+
+post-install:
+	@${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/hotwayd/distinfo b/mail/hotwayd/distinfo
new file mode 100644
index 000000000000..8e244c78fd22
--- /dev/null
+++ b/mail/hotwayd/distinfo
@@ -0,0 +1 @@
+MD5 (hotway-0.51.tar.bz2) = b221348a725b87f915f1a215f15f5919
diff --git a/mail/hotwayd/files/patch-Makefile.in b/mail/hotwayd/files/patch-Makefile.in
new file mode 100644
index 000000000000..e072833ed6e3
--- /dev/null
+++ b/mail/hotwayd/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig	Tue Oct 29 08:13:59 2002
++++ Makefile.in	Tue Oct 29 08:14:43 2002
+@@ -101,7 +101,7 @@
+ DEFS = @DEFS@ -I. -I$(srcdir) 
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@
++LIBS = -L ${LOCALBASE}/lib -lm -lz -lxml2 -liconv
+ hotwayd_OBJECTS =  hotwayd.o commands.o xmlstuff.o inet.o
+ hotwayd_DEPENDENCIES =  libghttp-1.0.9-mod/ghttp.c \
+ libghttp-1.0.9-mod/http_date.c libghttp-1.0.9-mod/http_hdrs.c \
diff --git a/mail/hotwayd/files/patch-inet.c b/mail/hotwayd/files/patch-inet.c
new file mode 100644
index 000000000000..c4bb1ba9c580
--- /dev/null
+++ b/mail/hotwayd/files/patch-inet.c
@@ -0,0 +1,10 @@
+--- inet.c.orig	Tue Oct 29 08:09:14 2002
++++ inet.c	Tue Oct 29 08:09:27 2002
+@@ -24,6 +24,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <stdlib.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
+ 
diff --git a/mail/hotwayd/pkg-comment b/mail/hotwayd/pkg-comment
new file mode 100644
index 000000000000..6b4a7f810f65
--- /dev/null
+++ b/mail/hotwayd/pkg-comment
@@ -0,0 +1 @@
+A Hotmail -> POP3 gateway
diff --git a/mail/hotwayd/pkg-descr b/mail/hotwayd/pkg-descr
new file mode 100644
index 000000000000..35d5cf48fd2e
--- /dev/null
+++ b/mail/hotwayd/pkg-descr
@@ -0,0 +1,6 @@
+Hotway uses HTTPMail (the same protocol that Outlook Express uses) to access
+Microsoft's Hotmail servers.  The software acts as a proxy mail server,
+allowing you to access hotmail and MSN accounts using a standard POP3 mail
+client.
+
+WWW: http://people.freenet.de/courierdave
diff --git a/mail/hotwayd/pkg-message b/mail/hotwayd/pkg-message
new file mode 100644
index 000000000000..3358560068e0
--- /dev/null
+++ b/mail/hotwayd/pkg-message
@@ -0,0 +1,20 @@
+
+To run hotwayd you need to add it to inetd.conf.
+To use the standard pop3 port for hotwayd, add the following
+line to /etc/inetd.conf:
+
+pop3	stream	tcp	nowait	root	/usr/local/sbin/hotwayd	hotwayd
+
+You may also specify an arbitrary port for hotwayd.  Define it
+in /etc/services, and then use a line like this in /etc/inetd.conf:
+
+hotwayd	stream	tcp	nowait	root	/usr/local/sbin/hotwayd	hotwayd
+
+After making your changes, restart inetd. e.g.:
+
+killall -HUP inetd
+
+You can now use fetchmail or any pop3 mail client to read your e-mail.
+The POP username should be your full hotmail or msn e-mail address,
+and the password is your hotmail/msn password.
+
diff --git a/mail/hotwayd/pkg-plist b/mail/hotwayd/pkg-plist
new file mode 100644
index 000000000000..e57508da8503
--- /dev/null
+++ b/mail/hotwayd/pkg-plist
@@ -0,0 +1,5 @@
+sbin/hotwayd
+include/hotwayd.h
+include/httpmail.h
+include/ghttp.h
+include/ghttp_constants.h
-- 
cgit v1.2.3