From d5e8709021f9b9f41a63ae86ca774d2fdb9fcd94 Mon Sep 17 00:00:00 2001
From: "Andrey A. Chernov" <ache@FreeBSD.org>
Date: Mon, 26 Feb 1996 00:57:32 +0000
Subject: Switch to new Elm maintainer

---
 mail/elm/Makefile              | 24 +++++++++++++-----------
 mail/elm/distinfo              |  3 +--
 mail/elm/pkg-plist             |  3 ++-
 mail/elm/scripts/pre-configure | 19 +++++++++++--------
 4 files changed, 27 insertions(+), 22 deletions(-)

(limited to 'mail/elm')

diff --git a/mail/elm/Makefile b/mail/elm/Makefile
index d669ce0f87fe..d24a71c33c5d 100644
--- a/mail/elm/Makefile
+++ b/mail/elm/Makefile
@@ -1,25 +1,27 @@
 # New ports collection makefile for:    elm
-# Version required:     2.4 pl25 ME8b
+# Version required:     2.4.25.ME+.9
 # Date created:         26 June 1995
 # Whom:                 ache
 #
-# $Id: Makefile,v 1.13 1995/12/21 10:47:59 ache Exp $
+# $Id: Makefile,v 1.14 1996/02/20 04:18:46 ache Exp $
 #
 
-DISTNAME=       elm-2.4pl24me8b
-VERSION=        2.4.25m8b          # allows to not edit elm+* Makefiles
-PKGNAME=        elm-${VERSION}
+DISTNAME=       elm-2.4ME+9
 CATEGORIES+=	mail
-MASTER_SITES=   ftp://ftp.kiae.su/unix/mail/ ftp://ftp.myxa.com/pub/elm/
-DISTFILES=      ${DISTNAME}${EXTRACT_SUFX} elm2.4.p25
-EXTRACT_ONLY=   ${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES=   ftp://dionysos.fmi.fi/KEH/ \
+		ftp://ftp.kiae.su/unix/mail/
+WRKSRC=         ${WRKDIR}/elm2.4.ME+.9
 
 MAINTAINER=	ache@FreeBSD.ORG
 
-pre-patch:
-	-patch -d ${WRKSRC} -s -p -N -S + < ${PORTSDIR}/distfiles/elm2.4.p25
-
 post-install:
 	cd ${WRKSRC}/nls; ${MAKE} install
+	if [ -f ${PREFIX}/lib/elm.mimetypes ] ; then \
+		${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 \
+			${FILESDIR}/elm.mimetypes ${PREFIX}/lib/elm.mimetypes-dist; \
+	else \
+		${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 \
+			${FILESDIR}/elm.mimetypes ${PREFIX}/lib; \
+	fi
 
 .include <bsd.port.mk>
diff --git a/mail/elm/distinfo b/mail/elm/distinfo
index 5a47081bee3e..1940422766d4 100644
--- a/mail/elm/distinfo
+++ b/mail/elm/distinfo
@@ -1,2 +1 @@
-MD5 (elm-2.4pl24me8b.tar.gz) = aebac2163443b8f7f7d9714bdfedeade
-MD5 (elm2.4.p25) = 5ec93595c7573be4d0cb4ce7097b6e83
+MD5 (elm-2.4ME+9.tar.gz) = 06717f60bc24a275f9574c5d142d0951
diff --git a/mail/elm/pkg-plist b/mail/elm/pkg-plist
index 2b5b0d12769d..5d7b87ad4528 100644
--- a/mail/elm/pkg-plist
+++ b/mail/elm/pkg-plist
@@ -4,6 +4,7 @@ bin/answer
 bin/checkalias
 bin/elmalias
 bin/fastmail
+bin/filter
 bin/frm
 @exec ln -f %D/%F %D/bin/nfrm
 bin/listalias
@@ -14,7 +15,7 @@ bin/newmail
 bin/printmail
 bin/readmsg
 lib/prlong
-bin/filter
+lib/elm.mimetypes
 lib/elmrc-info
 lib/elm-help.0
 lib/elm-help.1
diff --git a/mail/elm/scripts/pre-configure b/mail/elm/scripts/pre-configure
index 41b807c40b10..51fafb1fff96 100644
--- a/mail/elm/scripts/pre-configure
+++ b/mail/elm/scripts/pre-configure
@@ -1,7 +1,7 @@
 #!/bin/sh -
 #
 #	pre-configure script for Elm port to FreeBSD 2.0
-#	$Id: pre-configure,v 1.8 1996/01/12 01:54:50 ache Exp $
+#	$Id: pre-configure,v 1.9 1996/02/23 01:45:05 ache Exp $
 
 PortsDir=$PORTSDIR
   CurDir=$CURDIR
@@ -24,6 +24,7 @@ d_mkdir='define'
 d_rename='define'
 d_symlink='define'
 d_whoami='undef'
+d_poll='undef'
 n='-n'
 c=''
 orderlib='false'
@@ -80,6 +81,7 @@ lint
 lp
 lpr
 mailx
+metamail
 mips
 more
 nroff
@@ -146,7 +148,7 @@ pack='pack'
 compress='/usr/bin/compress'
 execmail=''
 libswanted='intl nls'
-c_date='Tue Jul  4 04:52:32 MSD 1995'
+c_date='Mon Feb 26 02:39:33 MSK 1996'
 d_ascii='undef'
 d_broke_ctype='undef'
 d_calendar='define'
@@ -154,7 +156,7 @@ calendar='calendar'
 d_chown_neg1='define'
 d_content='undef'
 d_crypt='define'
-cryptlib='/usr/lib/libcrypt.a'
+cryptlib='-lcrypt'
 d_cuserid='undef'
 d_disphost='undef'
 d_domname='define'
@@ -184,12 +186,13 @@ d_msgcat='define'
 d_usenls='undef'
 d_mallocvoid='define'
 d_mboxedit='define'
-d_mime='undef'
+d_mime='define'
+metamail_path='none'
 defencoding=''
-d_8bitmime='undef'
+d_8bitmime='define'
 d_binarymime='undef'
-defcharset='US-ASCII'
-defdispcharset='US-ASCII'
+defcharset='ISO-8859-1'
+defdispcharset='ISO-8859-1'
 d_mmdf='undef'
 d_newauto='define'
 d_noaddfrom='define'
@@ -247,7 +250,7 @@ i_unistd='define'
 i_utime='define'
 i_sysutime='undef'
 lib='/usr/local/lib'
-libc='/usr/lib/libc.so.2.2'
+libc='/usr/lib/libc.so.3.0'
 linepr='/usr/bin/lp'
 maildir='/var/mail'
 mailer='/usr/sbin/sendmail'
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0