From baa573cc0f3c67d02f961def5da5d4b3fccc5e54 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dag-Erling=20Sm=C3=B8rgrav?= <des@FreeBSD.org>
Date: Thu, 5 Feb 2004 00:26:17 +0000
Subject: Remove a test which was meant to fail, but succeeds when run as root.

---
 lang/sbcl/Makefile                                       |  4 +---
 .../sbcl/files/patch-contrib::sb-posix::posix-tests.lisp | 16 ++++++++++++++++
 2 files changed, 17 insertions(+), 3 deletions(-)
 create mode 100644 lang/sbcl/files/patch-contrib::sb-posix::posix-tests.lisp

(limited to 'lang/sbcl')

diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index 28083dc5aed5..3ae98e9c58d8 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -7,7 +7,7 @@
 
 PORTNAME=	sbcl
 PORTVERSION=	0.8.7
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	lang
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	sbcl
@@ -19,8 +19,6 @@ DISTFILES+=	${DISTNAME}-html${EXTRACT_SUFX}
 MAINTAINER=	des@FreeBSD.org
 COMMENT=	A Common Lisp development system derived from the CMU CL system
 
-FORBIDDEN=	"Creates /almost-certainly-does-not-exist"
-
 # If you have a previous version of SBCL installed, you can use it
 # instead of CMUCL to build the port, then deinstall it before
 # installing the new version.
diff --git a/lang/sbcl/files/patch-contrib::sb-posix::posix-tests.lisp b/lang/sbcl/files/patch-contrib::sb-posix::posix-tests.lisp
new file mode 100644
index 000000000000..13491f3f7b85
--- /dev/null
+++ b/lang/sbcl/files/patch-contrib::sb-posix::posix-tests.lisp
@@ -0,0 +1,16 @@
+--- contrib/sb-posix/posix-tests.lisp.orig	Thu Feb  5 01:22:59 2004
++++ contrib/sb-posix/posix-tests.lisp	Thu Feb  5 01:23:31 2004
+@@ -82,13 +82,6 @@
+     (sb-posix:syscall-error (c)
+       (sb-posix:syscall-errno c)))
+   #.sb-posix::eexist)
+-
+-(deftest mkdir.error.3
+-  (handler-case
+-      (sb-posix:mkdir "/almost-certainly-does-not-exist" 0)
+-    (sb-posix:syscall-error (c)
+-      (sb-posix:syscall-errno c)))
+-  #.sb-posix::eacces)
+ 
+ (deftest rmdir.1
+   (let ((dne (make-pathname :directory '(:relative "rmdir.does-not-exist.1"))))
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0