From cbed6ff02dce7f2f2ee6b1227a5a9196efa351f9 Mon Sep 17 00:00:00 2001
From: Maho Nakata <maho@FreeBSD.org>
Date: Sat, 31 Jan 2004 23:47:03 +0000
Subject: [1] ${IGNORE} in the Makefile did not work properly    and ${ECHO}
 was misused. ${DISTFILES} should be defined before    it is used.

[2] fix build (cxa_finalize.c is gone for now)

Submitted by:	hrs [1]
---
 lang/ifc/Makefile | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

(limited to 'lang/ifc')

diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index 06b46b99b158..59a2344cd79d 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -15,9 +15,9 @@ MAINTAINER=	maho@FreeBSD.org
 COMMENT=	Intel's Fortran compiler, set up to produce native FreeBSD binaries
 
 PATCHLEVEL=	${PORTVERSION:C/(.+p)(.+)$/pe\2/}
+DISTFILES=	${DISTNAME}${EXTRACT_SUFX}
 .if ${PORTVERSION} != ${PATCHLEVEL}
-DISTFILES=	${DISTNAME}${EXTRACT_SUFX} \
-		${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
+DISTFILES+=	${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
 .endif
 
 EXTRACT_DEPENDS=	rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
@@ -115,11 +115,11 @@ post-patch:
 		${WRKSRC}/opt/${COMPILERDIR}/doc/fsupport
 .endif
 .for i in ifc.orig ifort.orig
-	@${RM} ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
+	@${RM} -f ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
 .endfor
 # Provide a more FreeBSD'ish compile environment
 .for i in ifc.cfg ifort.cfg
-	@${ECHO} -e "-no-gcc\n-Qlocation,ld,${PREFIX}/${COMPILERDIR}/bin/ldwrapper\n-nothreads\n\n-D__FreeBSD__=${IFCCFGVAL}\n\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
+	@${ECHO_CMD} -e "-no-gcc\n-Qlocation,ld,${PREFIX}/${COMPILERDIR}/bin/ldwrapper\n-nothreads\n\n-D__FreeBSD__=${IFCCFGVAL}\n\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
 	@${CHMOD} a-x,g-w ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
 .endfor
 	@cd ${WRKSRC}/opt/${COMPILERDIR}/bin/ && ${LN} -s ifc.cfg ifcbin.cfg \
@@ -150,8 +150,7 @@ do-build:
 		${FILESDIR}/sysconf.c    \
 		${FILESDIR}/errno_location.c ${FILESDIR}/mcount.S
 .if ( ${OSVERSION} < 502101 )
-	@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c \
-		${FILESDIR}/cxa_finalize.c
+	@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c
 .endif
 .if ( ${OSVERSION} < 470101 ) || \
 	( ${OSVERSION} >= 500000 && ${OSVERSION} < 500042 )
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0