From 1e3322fef29865ce2011441906dec129469ddc66 Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Mon, 26 May 2014 12:19:32 +0000
Subject: - Covert gmake, xz to USES

Approved by:	portmgr
---
 java/eclipse/Makefile    | 4 +---
 java/jc/Makefile         | 2 +-
 java/jode/Makefile       | 2 +-
 java/mmake/Makefile      | 3 +--
 java/sablevm/Makefile    | 3 +--
 java/sqlitejdbc/Makefile | 2 +-
 6 files changed, 6 insertions(+), 10 deletions(-)

(limited to 'java')

diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index cd0a0a0a812d..2c738f955816 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -40,13 +40,11 @@ TESTS_DESC=	Build SDK test suite
 
 ONLY_FOR_ARCHS=	i386 amd64
 
-USES=		pkgconfig
+USES=		pkgconfig gmake tar:xz
 USE_ANT=	yes
 USE_GL=		glu
-USE_GMAKE=	yes
 USE_GNOME=	desktopfileutils gconf2 gtk20 gnomevfs2 libgnome libgnomeui
 USE_JAVA=	yes
-USE_XZ=		yes
 BZIP2_SUFX=	.tar.bz2
 ZIP_CMD?=	${LOCALBASE}/bin/zip
 
diff --git a/java/jc/Makefile b/java/jc/Makefile
index b8823161b3be..36d2da5519dc 100644
--- a/java/jc/Makefile
+++ b/java/jc/Makefile
@@ -19,8 +19,8 @@ NO_PACKAGE=	Takes too many resources to build
 
 MAN1=		jc.1
 
+USES=		gmake
 USE_JAVA=	yes
-USE_GMAKE=	yes
 JAVA_BUILD=	jre
 USE_LDCONFIG=	yes
 GNU_CONFIGURE=	yes
diff --git a/java/jode/Makefile b/java/jode/Makefile
index 6d3537c6e61e..5419b5d451ac 100644
--- a/java/jode/Makefile
+++ b/java/jode/Makefile
@@ -19,7 +19,7 @@ USE_JAVA=	yes
 JAVA_VERSION=	1.6+
 NEED_JAVAC=	yes
 GNU_CONFIGURE=	yes
-USE_GMAKE=	yes
+USES=		gmake
 MAKE_JOBS_UNSAFE=	yes
 
 GETOPT_JAR=	${JAVALIBDIR}/java-getopt.jar
diff --git a/java/mmake/Makefile b/java/mmake/Makefile
index 4468d98585bf..95012be99c8a 100644
--- a/java/mmake/Makefile
+++ b/java/mmake/Makefile
@@ -13,9 +13,8 @@ COMMENT=	Create a Makefile for Your Java files, ready to compile
 BUILD_DEPENDS=	jikes:${PORTSDIR}/java/jikes
 RUN_DEPENDS:=	${BUILD_DEPENDS}
 
-USES=		perl5
+USES=		perl5 gmake
 GNU_CONFIGURE=	yes
-USE_GMAKE=	yes
 NO_BUILD=	yes
 
 MAN1=		mmake.1
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index d90e221c8903..e84e5c54a034 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS=	fastjar:${PORTSDIR}/archivers/fastjar
 
 GNU_CONFIGURE=	yes
 USE_AUTOTOOLS=	libltdl
-USE_GMAKE=	yes
 USE_LDCONFIG=	yes
-USES=		pkgconfig gettext iconv
+USES=		pkgconfig gettext iconv gmake
 
 CPPFLAGS+=	-I${LOCALBASE}/include
 LDFLAGS+=	-L${LOCALBASE}/lib
diff --git a/java/sqlitejdbc/Makefile b/java/sqlitejdbc/Makefile
index 852c7f3d2d18..32401ae6247e 100644
--- a/java/sqlitejdbc/Makefile
+++ b/java/sqlitejdbc/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS=	libsqlite3.so:${PORTSDIR}/databases/sqlite3
 WRKSRC=		${WRKDIR}/${PORTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}
 USE_JAVA=	yes
 JAVA_VERSION=	1.6+
-USE_GMAKE=	yes
+USES=		gmake
 MAKE_ENV=	JAVA_HOME="${JAVA_HOME}"
 ALL_TARGET=	native
 
-- 
cgit v1.2.3