From 7d69b0994fcdd3dcebc64e3317d513428f4161da Mon Sep 17 00:00:00 2001
From: Erwin Lansing <erwin@FreeBSD.org>
Date: Sun, 4 Jul 2004 09:53:46 +0000
Subject: Unclutter my previous attempt to on the fly patching by using
 EXTRA_PATCHES and putting it in WRKDIR instead of the assumed read-only
 FILES-DIR.

Noticed by:	dosirak (via kris)
Pointy hat to:	erwin
---
 irc/ircd-hybrid/Makefile | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

(limited to 'irc/ircd-hybrid')

diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index dbc301d73812..3405dd1c93c2 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -22,6 +22,7 @@ GNU_CONFIGURE=	yes
 USE_REINPLACE=	yes
 
 PLIST_SUB+=	PORTVERSION=${PORTVERSION}
+EXTRA_PATCHES=	${WRKDIR}/patch-include-config.h
 
 #
 # User Configurable Variables
@@ -85,7 +86,7 @@ CONFIGURE_ARGS+=	--sysconfdir=${PREFIX}/etc/ircd-hybrid \
 	--messagedir=${PREFIX}/share/${PORTNAME}-${PORTVERSION}/messages \
 
 pre-patch:
-	@${SED} -e "s#%%PORTVERSION%%#${PORTVERSION}#" ${FILESDIR}/include-config.h.pre-patch > ${FILESDIR}/patch-include-config.h
+	@${SED} -e "s#%%PORTVERSION%%#${PORTVERSION}#" ${FILESDIR}/include-config.h.pre-patch > ${WRKDIR}/patch-include-config.h
 
 post-patch:
 	@${REINPLACE_CMD} -e "s#man8#man/man8#" ${WRKSRC}/doc/Makefile.in
@@ -103,7 +104,4 @@ post-install:
 	@${INSTALL_SCRIPT} ${WRKDIR}/ircd-hybrid.sh ${PREFIX}/etc/rc.d
 	@${SED} -e "s#/usr/local/#${PREFIX}/#" ${PKGMESSAGE}
 
-pre-clean:
-	@${RM} -f ${FILESDIR}/patch-include-config.h
-
 .include <bsd.port.mk>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0