From 89e386319650b4997bc46d68e724eb6c80fc989d Mon Sep 17 00:00:00 2001
From: Emanuel Haupt <ehaupt@FreeBSD.org>
Date: Tue, 18 Feb 2014 12:07:27 +0000
Subject: Support staging

---
 irc/ii/Makefile | 25 ++++++++-----------------
 1 file changed, 8 insertions(+), 17 deletions(-)

(limited to 'irc/ii')

diff --git a/irc/ii/Makefile b/irc/ii/Makefile
index c4d6d2a03a53..4a413306933c 100644
--- a/irc/ii/Makefile
+++ b/irc/ii/Makefile
@@ -12,30 +12,21 @@ COMMENT=	Minimalist FIFO and filesystem-based IRC client
 
 LICENSE=	MIT
 
-MAN1=		${PORTNAME}.1
-PLIST_FILES=	bin/${PORTNAME}
+PLIST_FILES=	bin/ii man/man1/ii.1.gz
 PORTDOCS=	CHANGES FAQ README
 PORTEXAMPLES=	query.sh
 .if !defined(.PARSEDIR)
 MAKE_ARGS=	-E CC
 .endif
 
-NO_STAGE=	yes
-
-OPTIONS_DEFINE=	DOCS EXAMPLES 
-
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE=	DOCS EXAMPLES
 
 do-install:
-	@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-	@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
-	@${MKDIR} ${DOCSDIR}
-	@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
-	@${MKDIR} ${EXAMPLESDIR}
-	@${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${EXAMPLESDIR}
-.endif
+	@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+	@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+	@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+	@${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
 
 .include <bsd.port.mk>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0