From b8f78bb14bee0e294625701bcf4123894bd4a1ad Mon Sep 17 00:00:00 2001
From: "Vanilla I. Shu" <vanilla@FreeBSD.org>
Date: Sat, 17 Mar 2001 16:35:37 +0000
Subject: GLiv is an image viewer that uses Imlib2 and OpenGL.

PR:		ports/25861
Submitted by:	Jeremy Norris <ishmael27@home.com>
---
 graphics/Makefile                   |  1 +
 graphics/gliv/Makefile              | 29 ++++++++++++++++++++++
 graphics/gliv/distinfo              |  1 +
 graphics/gliv/files/patch-configure | 49 +++++++++++++++++++++++++++++++++++++
 graphics/gliv/pkg-comment           |  1 +
 graphics/gliv/pkg-descr             |  3 +++
 graphics/gliv/pkg-plist             |  1 +
 7 files changed, 85 insertions(+)
 create mode 100644 graphics/gliv/Makefile
 create mode 100644 graphics/gliv/distinfo
 create mode 100644 graphics/gliv/files/patch-configure
 create mode 100644 graphics/gliv/pkg-comment
 create mode 100644 graphics/gliv/pkg-descr
 create mode 100644 graphics/gliv/pkg-plist

(limited to 'graphics')

diff --git a/graphics/Makefile b/graphics/Makefile
index c7e095509f48..b7d789f2bbe5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -61,6 +61,7 @@
     SUBDIR += gimp1
     SUBDIR += giram
     SUBDIR += gle
+    SUBDIR += gliv
     SUBDIR += gltk
     SUBDIR += gnofract4d
     SUBDIR += gnomeiconedit
diff --git a/graphics/gliv/Makefile b/graphics/gliv/Makefile
new file mode 100644
index 000000000000..bdf111b58e03
--- /dev/null
+++ b/graphics/gliv/Makefile
@@ -0,0 +1,29 @@
+# ports collection makefile for:	gliv
+# Date created:				16 March 2001
+# Whom:					Jeremy Norris <ishmael27@home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	gliv
+PORTVERSION=	1.0b6
+CATEGORIES=	graphics
+MASTER_SITES=	http://gliv.tuxfamily.org/
+DISTNAME=	GLiv-1.0beta6
+
+MAINTAINER=	ishmael27@home.com
+
+LIB_DEPENDS=	Imlib2.1:${PORTSDIR}/graphics/imlib2 \
+		gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_BZIP2=	yes
+USE_GMAKE=	yes
+USE_MESA=	yes
+GNU_CONFIGURE=	yes
+USE_X_PREFIX=	yes
+CONFIGURE_ENV=	LIBS="-L${LOCALBASE}/lib -lgnugetopt" \
+		CFLAGS="-I${LOCALBASE}/include"
+
+MAN1=		GLiv.1
+
+.include <bsd.port.mk>
diff --git a/graphics/gliv/distinfo b/graphics/gliv/distinfo
new file mode 100644
index 000000000000..5ed163341e82
--- /dev/null
+++ b/graphics/gliv/distinfo
@@ -0,0 +1 @@
+MD5 (GLiv-1.0beta6.tar.bz2) = e4ce6703f70b7d41e1eb42ee7f206424
diff --git a/graphics/gliv/files/patch-configure b/graphics/gliv/files/patch-configure
new file mode 100644
index 000000000000..5cf2db3d9675
--- /dev/null
+++ b/graphics/gliv/files/patch-configure
@@ -0,0 +1,49 @@
+--- configure.orig	Thu Mar 15 14:09:08 2001
++++ configure	Fri Mar 16 07:44:44 2001
+@@ -1067,8 +1067,8 @@
+ 
+ echo -n checking for Imlib2...
+ if imlib2-config --version &> /dev/null;then
+-CFLAGS="-pipe -O3 -funroll-loops -fforce-addr -fomit-frame-pointer -Wall $CFLAGS `imlib2-config --cflags`"
+-LDFLAGS="-Wl,-O1 $LDFLAGS `imlib2-config --libs`"
++CFLAGS="$CFLAGS `imlib2-config --cflags`"
++LDFLAGS="$LDFLAGS `imlib2-config --libs`"
+ echo " found (version `imlib2-config --version`)"
+ else
+ echo " not found"
+@@ -1081,14 +1081,14 @@
+ exit 1
+ fi
+ 
+-echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
+-echo "configure:1086: checking for pthread_create in -lpthread" >&5
++echo $ac_n "checking for pthread_create in -pthread""... $ac_c" 1>&6
++echo "configure:1086: checking for pthread_create in -pthread" >&5
+ ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+   echo $ac_n "(cached) $ac_c" 1>&6
+ else
+   ac_save_LIBS="$LIBS"
+-LIBS="-lpthread  $LIBS"
++LIBS="-pthread  $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1094 "configure"
+ #include "confdefs.h"
+@@ -1122,7 +1122,7 @@
+ #define $ac_tr_lib 1
+ EOF
+ 
+-  LIBS="-lpthread $LIBS"
++  LIBS="-pthread $LIBS"
+ 
+ else
+   echo "$ac_t""no" 1>&6
+@@ -1132,7 +1132,7 @@
+ echo It seems you do not have libpthread or it does not work.
+ exit 1
+ fi
+-LDFLAGS="$LDFLAGS -lpthread"
++LDFLAGS="$LDFLAGS -pthread"
+ 
+ unset mdl_cv_have_OpenGL
+ echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
diff --git a/graphics/gliv/pkg-comment b/graphics/gliv/pkg-comment
new file mode 100644
index 000000000000..0d0bf8668aa0
--- /dev/null
+++ b/graphics/gliv/pkg-comment
@@ -0,0 +1 @@
+An image viewer that uses Imlib2 and OpenGL
diff --git a/graphics/gliv/pkg-descr b/graphics/gliv/pkg-descr
new file mode 100644
index 000000000000..c7eee940c209
--- /dev/null
+++ b/graphics/gliv/pkg-descr
@@ -0,0 +1,3 @@
+An Image viewer that uses Imlib2 to load images, and OpenGL to render them.
+
+WWW: http://glive.tuxfamily.org/
diff --git a/graphics/gliv/pkg-plist b/graphics/gliv/pkg-plist
new file mode 100644
index 000000000000..26f0dd5dafe4
--- /dev/null
+++ b/graphics/gliv/pkg-plist
@@ -0,0 +1 @@
+bin/GLiv
-- 
cgit v1.2.3