From 783c59d9c96f31480884af2c90556327307d7991 Mon Sep 17 00:00:00 2001
From: Pav Lucistnik <pav@FreeBSD.org>
Date: Sun, 23 Jan 2005 00:04:37 +0000
Subject: - Update to 2.6.3 - Move graphics/gthumb2 to graphics/gthumb

---
 graphics/gthumb/Makefile                           |  40 +++++
 graphics/gthumb/distinfo                           |   2 +
 .../gthumb/files/patch-libgthumb_image-loader.c    |  14 ++
 .../gthumb/files/patch-libgthumb_image-viewer.c    |  10 ++
 graphics/gthumb/pkg-descr                          |   5 +
 graphics/gthumb/pkg-plist                          | 192 +++++++++++++++++++++
 6 files changed, 263 insertions(+)
 create mode 100644 graphics/gthumb/Makefile
 create mode 100644 graphics/gthumb/distinfo
 create mode 100644 graphics/gthumb/files/patch-libgthumb_image-loader.c
 create mode 100644 graphics/gthumb/files/patch-libgthumb_image-viewer.c
 create mode 100644 graphics/gthumb/pkg-descr
 create mode 100644 graphics/gthumb/pkg-plist

(limited to 'graphics/gthumb')

diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
new file mode 100644
index 000000000000..a56a9b1e286e
--- /dev/null
+++ b/graphics/gthumb/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for:	gThumb2
+# Date created:				17 Aug 2002
+# Whom:					Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	gthumb
+PORTVERSION=	2.6.3
+CATEGORIES=	graphics
+MASTER_SITES=	${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR=	sources/${PORTNAME:S/2$//}/2.6
+DISTNAME=	${PORTNAME:S/2$//}-${PORTVERSION}
+DIST_SUBDIR=	gnome2
+
+MAINTAINER=	pav@FreeBSD.org
+COMMENT=	An image viewer and browser for the GNOME 2 environment
+
+LIB_DEPENDS=	exif.10:${PORTSDIR}/graphics/libexif
+
+USE_BZIP2=	yes
+USE_X_PREFIX=	yes
+USE_GMAKE=	yes
+USE_GNOME=	gnomeprefix gnomehack intlhack libgnomeui libgnomeprintui
+USE_LIBTOOL_VER=15
+INSTALLS_OMF=	yes
+INSTALLS_SHLIB=	yes
+CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
+		LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS=	gthumb.schemas
+MAN1=		gthumb.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GPHOTO2) || exists(${LOCALBASE}/lib/libgphoto2.so.2)
+LIB_DEPENDS+=	gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/gthumb/distinfo b/graphics/gthumb/distinfo
new file mode 100644
index 000000000000..a6f2f8313a49
--- /dev/null
+++ b/graphics/gthumb/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/gthumb-2.6.3.tar.bz2) = 6c5553beb22c1025547a9726243b08e3
+SIZE (gnome2/gthumb-2.6.3.tar.bz2) = 2186161
diff --git a/graphics/gthumb/files/patch-libgthumb_image-loader.c b/graphics/gthumb/files/patch-libgthumb_image-loader.c
new file mode 100644
index 000000000000..461a0048fa61
--- /dev/null
+++ b/graphics/gthumb/files/patch-libgthumb_image-loader.c
@@ -0,0 +1,14 @@
+--- libgthumb/image-loader.c.orig	Mon Mar  3 15:45:30 2003
++++ libgthumb/image-loader.c	Mon Mar  3 15:45:32 2003
+@@ -534,8 +534,10 @@
+ 		image_loader_sync_pixbuf (il);
+ 	
+ 	priv->done_func = NULL;
+-	if (done_func != NULL)
++	if (done_func != NULL) {
+ 		(*done_func) (priv->done_func_data);
++		return;
++        }
+ 	
+ 	if (! priv->emit_signal)
+ 		return;
diff --git a/graphics/gthumb/files/patch-libgthumb_image-viewer.c b/graphics/gthumb/files/patch-libgthumb_image-viewer.c
new file mode 100644
index 000000000000..d01b73b9e054
--- /dev/null
+++ b/graphics/gthumb/files/patch-libgthumb_image-viewer.c
@@ -0,0 +1,10 @@
+--- libgthumb/image-viewer.c.orig	Sun Aug 18 00:36:59 2002
++++ libgthumb/image-viewer.c	Sun Aug 18 00:37:08 2002
+@@ -21,6 +21,7 @@
+  */
+ 
+ #include <math.h>
++#include <sys/types.h>
+ #include <gdk/gdkkeysyms.h>
+ #include <gtk/gtkadjustment.h>
+ #include <gtk/gtkhscrollbar.h>
diff --git a/graphics/gthumb/pkg-descr b/graphics/gthumb/pkg-descr
new file mode 100644
index 000000000000..4d1d8cc31d28
--- /dev/null
+++ b/graphics/gthumb/pkg-descr
@@ -0,0 +1,5 @@
+This is a port of gThumb for GNOME 2, a fast and small image browser and viewer.
+It creates thumbnailes, caches them and has support for most popular
+image formats.
+
+WWW: http://gthumb.sourceforge.net/
diff --git a/graphics/gthumb/pkg-plist b/graphics/gthumb/pkg-plist
new file mode 100644
index 000000000000..509b9ca45f53
--- /dev/null
+++ b/graphics/gthumb/pkg-plist
@@ -0,0 +1,192 @@
+bin/gthumb
+lib/gthumb/libgthumb.a
+lib/gthumb/libgthumb.so
+lib/gthumb/modules/libduplicates.so
+lib/gthumb/modules/libjpegtran.so
+lib/gthumb/modules/libphotoimporter.so
+lib/gthumb/modules/libpngexporter.so
+lib/gthumb/modules/libsearch.so
+lib/gthumb/modules/libwebexporter.so
+libdata/bonobo/servers/GNOME_GThumb_CatalogView.server
+libdata/bonobo/servers/GNOME_GThumb_Viewer.server
+libexec/gthumb-catalog-view
+libexec/gthumb-image-viewer
+share/gnome/application-registry/gthumb.applications
+share/gnome/applications/gthumb.desktop
+share/gnome/gnome-2.0/ui/GNOME_GThumb_CatalogView.xml
+share/gnome/gnome-2.0/ui/GNOME_GThumb_Viewer.xml
+share/gnome/gthumb/albumthemes/BlueStripes/back.png
+share/gnome/gthumb/albumthemes/BlueStripes/background.png
+share/gnome/gthumb/albumthemes/BlueStripes/bottom.png
+share/gnome/gthumb/albumthemes/BlueStripes/image.gthtml
+share/gnome/gthumb/albumthemes/BlueStripes/index.gthtml
+share/gnome/gthumb/albumthemes/BlueStripes/left.png
+share/gnome/gthumb/albumthemes/BlueStripes/next.png
+share/gnome/gthumb/albumthemes/BlueStripes/prev.png
+share/gnome/gthumb/albumthemes/BlueStripes/preview.png
+share/gnome/gthumb/albumthemes/BlueStripes/right.png
+share/gnome/gthumb/albumthemes/BlueStripes/thumbnail.gthtml
+share/gnome/gthumb/albumthemes/BlueStripes/top.png
+share/gnome/gthumb/albumthemes/BlueStripes/transparent.png
+share/gnome/gthumb/albumthemes/BlueStripes/white-dot.png
+share/gnome/gthumb/albumthemes/Classic/1.gif
+share/gnome/gthumb/albumthemes/Classic/back.png
+share/gnome/gthumb/albumthemes/Classic/background.gif
+share/gnome/gthumb/albumthemes/Classic/bot.png
+share/gnome/gthumb/albumthemes/Classic/image.gthtml
+share/gnome/gthumb/albumthemes/Classic/index.gthtml
+share/gnome/gthumb/albumthemes/Classic/layout.css
+share/gnome/gthumb/albumthemes/Classic/left.png
+share/gnome/gthumb/albumthemes/Classic/next.png
+share/gnome/gthumb/albumthemes/Classic/prev.png
+share/gnome/gthumb/albumthemes/Classic/preview.png
+share/gnome/gthumb/albumthemes/Classic/right.png
+share/gnome/gthumb/albumthemes/Classic/style.css
+share/gnome/gthumb/albumthemes/Classic/thumbnail.gthtml
+share/gnome/gthumb/albumthemes/Classic/top.png
+share/gnome/gthumb/albumthemes/ClassicClips/1.gif
+share/gnome/gthumb/albumthemes/ClassicClips/back.png
+share/gnome/gthumb/albumthemes/ClassicClips/background.gif
+share/gnome/gthumb/albumthemes/ClassicClips/bot.png
+share/gnome/gthumb/albumthemes/ClassicClips/image.gthtml
+share/gnome/gthumb/albumthemes/ClassicClips/index.gthtml
+share/gnome/gthumb/albumthemes/ClassicClips/layout.css
+share/gnome/gthumb/albumthemes/ClassicClips/left.png
+share/gnome/gthumb/albumthemes/ClassicClips/next.png
+share/gnome/gthumb/albumthemes/ClassicClips/prev.png
+share/gnome/gthumb/albumthemes/ClassicClips/preview.png
+share/gnome/gthumb/albumthemes/ClassicClips/right.png
+share/gnome/gthumb/albumthemes/ClassicClips/style.css
+share/gnome/gthumb/albumthemes/ClassicClips/thumbnail.gthtml
+share/gnome/gthumb/albumthemes/ClassicClips/top.png
+share/gnome/gthumb/albumthemes/Clean/1.gif
+share/gnome/gthumb/albumthemes/Clean/back.png
+share/gnome/gthumb/albumthemes/Clean/background.gif
+share/gnome/gthumb/albumthemes/Clean/bot.png
+share/gnome/gthumb/albumthemes/Clean/image.gthtml
+share/gnome/gthumb/albumthemes/Clean/index.gthtml
+share/gnome/gthumb/albumthemes/Clean/left.png
+share/gnome/gthumb/albumthemes/Clean/left_arrow.png
+share/gnome/gthumb/albumthemes/Clean/preview.png
+share/gnome/gthumb/albumthemes/Clean/right.png
+share/gnome/gthumb/albumthemes/Clean/right_arrow.png
+share/gnome/gthumb/albumthemes/Clean/thumbnail.gthtml
+share/gnome/gthumb/albumthemes/Clean/top.png
+share/gnome/gthumb/albumthemes/Clean/up_arrow.png
+share/gnome/gthumb/albumthemes/NeatRound/1.gif
+share/gnome/gthumb/albumthemes/NeatRound/back.png
+share/gnome/gthumb/albumthemes/NeatRound/background.gif
+share/gnome/gthumb/albumthemes/NeatRound/bot.png
+share/gnome/gthumb/albumthemes/NeatRound/image.gthtml
+share/gnome/gthumb/albumthemes/NeatRound/index.gthtml
+share/gnome/gthumb/albumthemes/NeatRound/left.png
+share/gnome/gthumb/albumthemes/NeatRound/next.png
+share/gnome/gthumb/albumthemes/NeatRound/prev.png
+share/gnome/gthumb/albumthemes/NeatRound/preview.png
+share/gnome/gthumb/albumthemes/NeatRound/right.png
+share/gnome/gthumb/albumthemes/NeatRound/thumbnail.gthtml
+share/gnome/gthumb/albumthemes/NeatRound/top.png
+share/gnome/gthumb/albumthemes/NeatSquare/1.gif
+share/gnome/gthumb/albumthemes/NeatSquare/back.png
+share/gnome/gthumb/albumthemes/NeatSquare/background.gif
+share/gnome/gthumb/albumthemes/NeatSquare/bot.png
+share/gnome/gthumb/albumthemes/NeatSquare/image.gthtml
+share/gnome/gthumb/albumthemes/NeatSquare/index.gthtml
+share/gnome/gthumb/albumthemes/NeatSquare/left.png
+share/gnome/gthumb/albumthemes/NeatSquare/next.png
+share/gnome/gthumb/albumthemes/NeatSquare/prev.png
+share/gnome/gthumb/albumthemes/NeatSquare/preview.png
+share/gnome/gthumb/albumthemes/NeatSquare/right.png
+share/gnome/gthumb/albumthemes/NeatSquare/thumbnail.gthtml
+share/gnome/gthumb/albumthemes/NeatSquare/top.png
+share/gnome/gthumb/glade/ftp-client-48.png
+share/gnome/gthumb/glade/gphoto-48.png
+share/gnome/gthumb/glade/gthumb.glade
+share/gnome/gthumb/glade/gthumb_camera.glade
+share/gnome/gthumb/glade/gthumb_comments.glade
+share/gnome/gthumb/glade/gthumb_convert.glade
+share/gnome/gthumb/glade/gthumb_crop.glade
+share/gnome/gthumb/glade/gthumb_edit.glade
+share/gnome/gthumb/glade/gthumb_png_exporter.glade
+share/gnome/gthumb/glade/gthumb_preferences.glade
+share/gnome/gthumb/glade/gthumb_print.glade
+share/gnome/gthumb/glade/gthumb_search.glade
+share/gnome/gthumb/glade/gthumb_tools.glade
+share/gnome/gthumb/glade/gthumb_web_exporter.glade
+share/gnome/gthumb/glade/volume-mute.png
+share/gnome/gthumb/icons/black-white.png
+share/gnome/gthumb/icons/flip.png
+share/gnome/gthumb/icons/flip.xpm
+share/gnome/gthumb/icons/mirror.png
+share/gnome/gthumb/icons/mirror.xpm
+share/gnome/gthumb/icons/rotate.png
+share/gnome/gthumb/icons/rotate.xpm
+share/gnome/help/gthumb/C/figures/comment.png
+share/gnome/help/gthumb/C/figures/main-win.png
+share/gnome/help/gthumb/C/figures/nav-button.png
+share/gnome/help/gthumb/C/figures/preferences.png
+share/gnome/help/gthumb/C/gthumb.xml
+share/gnome/help/gthumb/C/legal.xml
+share/gnome/omf/gthumb/gthumb-C.omf
+share/gnome/pixmaps/gthumb.png
+share/gnome/pixmaps/gthumb-logo.png
+share/locale/am/LC_MESSAGES/gthumb.mo
+share/locale/az/LC_MESSAGES/gthumb.mo
+share/locale/be/LC_MESSAGES/gthumb.mo
+share/locale/bg/LC_MESSAGES/gthumb.mo
+share/locale/ca/LC_MESSAGES/gthumb.mo
+share/locale/cs/LC_MESSAGES/gthumb.mo
+share/locale/da/LC_MESSAGES/gthumb.mo
+share/locale/de/LC_MESSAGES/gthumb.mo
+share/locale/en_CA/LC_MESSAGES/gthumb.mo
+share/locale/en_GB/LC_MESSAGES/gthumb.mo
+share/locale/es/LC_MESSAGES/gthumb.mo
+share/locale/eu/LC_MESSAGES/gthumb.mo
+share/locale/fi/LC_MESSAGES/gthumb.mo
+share/locale/fr/LC_MESSAGES/gthumb.mo
+share/locale/ga/LC_MESSAGES/gthumb.mo
+share/locale/gu/LC_MESSAGES/gthumb.mo
+share/locale/hr/LC_MESSAGES/gthumb.mo
+share/locale/hu/LC_MESSAGES/gthumb.mo
+share/locale/id/LC_MESSAGES/gthumb.mo
+share/locale/it/LC_MESSAGES/gthumb.mo
+share/locale/ja/LC_MESSAGES/gthumb.mo
+share/locale/ko/LC_MESSAGES/gthumb.mo
+share/locale/lt/LC_MESSAGES/gthumb.mo
+share/locale/lv/LC_MESSAGES/gthumb.mo
+share/locale/mk/LC_MESSAGES/gthumb.mo
+share/locale/ml/LC_MESSAGES/gthumb.mo
+share/locale/ms/LC_MESSAGES/gthumb.mo
+share/locale/nb/LC_MESSAGES/gthumb.mo
+share/locale/nl/LC_MESSAGES/gthumb.mo
+share/locale/nn/LC_MESSAGES/gthumb.mo
+share/locale/no/LC_MESSAGES/gthumb.mo
+share/locale/pa/LC_MESSAGES/gthumb.mo
+share/locale/pl/LC_MESSAGES/gthumb.mo
+share/locale/pt/LC_MESSAGES/gthumb.mo
+share/locale/pt_BR/LC_MESSAGES/gthumb.mo
+share/locale/ru/LC_MESSAGES/gthumb.mo
+share/locale/sk/LC_MESSAGES/gthumb.mo
+share/locale/sq/LC_MESSAGES/gthumb.mo
+share/locale/sr/LC_MESSAGES/gthumb.mo
+share/locale/sr@Latn/LC_MESSAGES/gthumb.mo
+share/locale/sv/LC_MESSAGES/gthumb.mo
+share/locale/uk/LC_MESSAGES/gthumb.mo
+share/locale/zh_CN/LC_MESSAGES/gthumb.mo
+share/locale/zh_TW/LC_MESSAGES/gthumb.mo
+@dirrm share/gnome/omf/gthumb
+@dirrm share/gnome/help/gthumb/C/figures
+@dirrm share/gnome/help/gthumb/C
+@dirrm share/gnome/help/gthumb
+@dirrm share/gnome/gthumb/icons
+@dirrm share/gnome/gthumb/glade
+@dirrm share/gnome/gthumb/albumthemes/NeatSquare
+@dirrm share/gnome/gthumb/albumthemes/NeatRound
+@dirrm share/gnome/gthumb/albumthemes/Clean
+@dirrm share/gnome/gthumb/albumthemes/ClassicClips
+@dirrm share/gnome/gthumb/albumthemes/Classic
+@dirrm share/gnome/gthumb/albumthemes/BlueStripes
+@dirrm share/gnome/gthumb/albumthemes
+@dirrm share/gnome/gthumb
+@dirrm lib/gthumb/modules
+@dirrm lib/gthumb
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0