From 6145c395a10ce114cfdd52a896aa05cf6d9d3ecd Mon Sep 17 00:00:00 2001
From: Chris Piazza <cpiazza@FreeBSD.org>
Date: Thu, 17 Feb 2000 01:04:30 +0000
Subject: Update to 0.53

PR:		16694
Submitted by:	Will Andrews <andrews@technologist.com>
---
 games/gltron/Makefile       | 17 +++++++++++------
 games/gltron/distinfo       |  2 +-
 games/gltron/files/patch-ac | 44 ++++++++++++++++++++++++++++++++++++++++++++
 games/gltron/pkg-plist      | 12 ++++++++++++
 4 files changed, 68 insertions(+), 7 deletions(-)
 create mode 100644 games/gltron/files/patch-ac

(limited to 'games/gltron')

diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index deadd4746e93..c1427f5704e4 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -1,13 +1,12 @@
 # New ports collection makefile for:	gltron
-# Version required:			0.46
+# Version required:			0.53
 # Date created:				24 July 1999
 # Whom:					Andrey Zakhvatov
 #
 # $FreeBSD$
 #
 
-DISTNAME=	glTron-0.46
-PKGNAME=	gltron-0.46
+DISTNAME=	gltron-0.53
 CATEGORIES=	games
 MASTER_SITES=	http://www.ards.net/Andreas/gltron/
 
@@ -18,15 +17,21 @@ LIB_DEPENDS=	MesaGL.14:${PORTSDIR}/graphics/Mesa3 \
 		glut.3:${PORTSDIR}/graphics/Mesa3
 
 USE_X_PREFIX=	yes
+USE_GMAKE=	yes
+MAKE_ENV+=	OPT="${CFLAGS}"
 
 do-install:
-	@ ${INSTALL_PROGRAM} ${WRKSRC}/gltron ${PREFIX}/bin
+	@${MKDIR} ${PREFIX}/share/gltron/
+.for FILE in *.sgi *.txt t-u-low.obj tron.mtl xenotron.ftx
+	@${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/share/gltron/
+.endfor
+	@${INSTALL_PROGRAM} ${WRKSRC}/gltron ${PREFIX}/bin
 
 post-install:
 .if !defined(NOPORTDOCS)
-	@ ${MKDIR} ${PREFIX}/share/doc/gltron
+	@${MKDIR} ${PREFIX}/share/doc/gltron
 .for file in CHANGELOG CREDITS README
-	@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gltron
+	@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gltron
 .endfor
 .endif
 
diff --git a/games/gltron/distinfo b/games/gltron/distinfo
index 62c216bb64e7..7f46f7425025 100644
--- a/games/gltron/distinfo
+++ b/games/gltron/distinfo
@@ -1 +1 @@
-MD5 (glTron-0.46.tar.gz) = faeaddeba285a46c8773a8307f60392a
+MD5 (gltron-0.53.tar.gz) = 596aaa813c2c11411939e89a6d40d059
diff --git a/games/gltron/files/patch-ac b/games/gltron/files/patch-ac
new file mode 100644
index 000000000000..47198d2ee6bb
--- /dev/null
+++ b/games/gltron/files/patch-ac
@@ -0,0 +1,44 @@
+--- file.c	Mon Jan  3 19:05:10 2000
++++ file.c.new	Sun Feb 13 02:22:14 2000
+@@ -1,13 +1,16 @@
+ #include "gltron.h"
++#ifndef SHARE1
++#define SHARE1 "\"/usr/local/share/gltron\""
++#endif
++#ifndef SHARE2
++#define SHARE2 "\"/usr/X11R6/share/gltron\""
++#endif
+ 
+ char* getFullPath(char *filename) {
+   char *path;
+   FILE *fp = NULL;
+   char *base;
+ 
+-  char *share1 = "/usr/share/games/gltron";
+-  char *share2 = "/usr/local/share/games/gltron";
+-
+   /* check a few directories for the files and */
+   /* return the full path. */
+   
+@@ -43,8 +46,8 @@
+     printf("unsuccessful\n");
+   }
+ 
+-  path = malloc(strlen(share1) + 1 + strlen(filename) + 1);
+-  sprintf(path, "%s%c%s", share1, SEPERATOR, filename);
++  path = malloc(strlen(SHARE1) + 1 + strlen(filename) + 1);
++  sprintf(path, "%s%c%s", SHARE1, SEPERATOR, filename);
+ 
+   printf("checking '%s'", path);
+   fp = fopen(path, "r");
+@@ -56,8 +59,8 @@
+   free(path);
+   printf("unsuccessful\n");
+ 
+-  path = malloc(strlen(share2) + 1 + strlen(filename) + 1);
+-  sprintf(path, "%s%c%s", share2, SEPERATOR, filename);
++  path = malloc(strlen(SHARE2) + 1 + strlen(filename) + 1);
++  sprintf(path, "%s%c%s", SHARE2, SEPERATOR, filename);
+   
+   printf("checking '%s'", path);
+   fp = fopen(path, "r");
diff --git a/games/gltron/pkg-plist b/games/gltron/pkg-plist
index 31a00428209a..bf1c7904e0f5 100644
--- a/games/gltron/pkg-plist
+++ b/games/gltron/pkg-plist
@@ -2,4 +2,16 @@ bin/gltron
 share/doc/gltron/CHANGELOG
 share/doc/gltron/CREDITS
 share/doc/gltron/README
+share/gltron/gltron.sgi
+share/gltron/gltron_crash.sgi
+share/gltron/gltron_floor.sgi
+share/gltron/gltron_wall.sgi
+share/gltron/menu.txt
+share/gltron/settings.txt
+share/gltron/t-u-low.obj
+share/gltron/tron.mtl
+share/gltron/xenotron.0.sgi
+share/gltron/xenotron.1.sgi
+share/gltron/xenotron.ftx
 @dirrm share/doc/gltron
+@dirrm share/gltron
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0