From f21390c01db917ea1f6c2fb0bd0f4dbcdb37357b Mon Sep 17 00:00:00 2001
From: Kirill Ponomarev <krion@FreeBSD.org>
Date: Fri, 28 May 2004 18:34:03 +0000
Subject: - Update to version 1.1

PR:		ports/67289
Submitted by:	Ports Fury
---
 ftp/yafc/Makefile                      | 12 +++++-
 ftp/yafc/distinfo                      |  4 +-
 ftp/yafc/files/patch-src::ftp::rfile.c | 74 ++++++++++++++++++++++++++++++++++
 ftp/yafc/files/patch-src::get.c        | 11 -----
 ftp/yafc/files/patch-src::put.c        | 11 -----
 ftp/yafc/pkg-plist                     |  3 ++
 6 files changed, 89 insertions(+), 26 deletions(-)
 create mode 100644 ftp/yafc/files/patch-src::ftp::rfile.c
 delete mode 100644 ftp/yafc/files/patch-src::get.c
 delete mode 100644 ftp/yafc/files/patch-src::put.c

(limited to 'ftp/yafc')

diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index e055fa8a361d..2689ab664545 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -6,8 +6,7 @@
 #
 
 PORTNAME=	yafc
-PORTVERSION=	1.0
-PORTREVISION=	1
+PORTVERSION=	1.1
 CATEGORIES=	ftp
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	${PORTNAME}
@@ -16,10 +15,19 @@ MAINTAINER=	ports@FreeBSD.org
 COMMENT=	Yet another ftp client. Similar to ftp(1)
 
 USE_BZIP2=	yes
+USE_GETOPT_LONG=	yes
 GNU_CONFIGURE=	yes
 CONFIGURE_TARGET=	--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS=	--with-socks4=no --with-socks5=no --with-krb4=no \
+		--with-krb5=no --with-gssapi=no
 
 MAN1=		yafc.1
 INFO=		yafc
 
+post-install:
+.if !defined(NOPORTDOCS)
+	@${MKDIR} ${EXAMPLESDIR}
+	${INSTALL_DATA} ${WRKSRC}/*.sample ${EXAMPLESDIR}
+.endif
+
 .include <bsd.port.mk>
diff --git a/ftp/yafc/distinfo b/ftp/yafc/distinfo
index 475d940de928..81b936636ca4 100644
--- a/ftp/yafc/distinfo
+++ b/ftp/yafc/distinfo
@@ -1,2 +1,2 @@
-MD5 (yafc-1.0.tar.bz2) = c9d23600a263ac29505ca0084581a8f7
-SIZE (yafc-1.0.tar.bz2) = 441536
+MD5 (yafc-1.1.tar.bz2) = 877c21d9b70d89474d1a6478a21c1e51
+SIZE (yafc-1.1.tar.bz2) = 463528
diff --git a/ftp/yafc/files/patch-src::ftp::rfile.c b/ftp/yafc/files/patch-src::ftp::rfile.c
new file mode 100644
index 000000000000..7d18c5b23d3f
--- /dev/null
+++ b/ftp/yafc/files/patch-src::ftp::rfile.c
@@ -0,0 +1,74 @@
+--- src/ftp/rfile.c.orig	Thu May 20 20:10:52 2004
++++ src/ftp/rfile.c	Sun May 23 21:49:54 2004
+@@ -439,7 +439,11 @@
+         free(saved_field[0]);
+         f->owner = saved_field[1];
+         f->group = saved_field[2];
++#if 0
+         f->size = atoll(saved_field[3]);
++#else
++        f->size = strtoll(saved_field[3], NULL, 10);
++#endif
+         free(saved_field[3]);
+         m = saved_field[4];
+         NEXT_FIELD2;
+@@ -453,7 +457,11 @@
+         free(saved_field[0]);
+         f->owner = saved_field[1];
+         f->group = xstrdup("group");
++#if 0
+         f->size = atoll(saved_field[2]);
++#else
++        f->size = strtoll(saved_field[2], NULL, 10);
++#endif
+         free(saved_field[2]);
+         m = saved_field[3];
+         d = saved_field[4];
+@@ -465,7 +473,11 @@
+         f->nhl = 0;
+         f->owner = xstrdup("owner");;
+         f->group = xstrdup("group");
++#if 0
+         f->size = atoll(saved_field[1]);
++#else
++        f->size = strtoll(saved_field[1], NULL, 10);
++#endif
+         free(saved_field[1]);
+         m = saved_field[2];
+         d = saved_field[3];
+@@ -480,7 +492,11 @@
+             free(saved_field[0]);
+             f->owner = saved_field[1];
+             f->group = saved_field[2];
++#if 0
+             f->size = atoll(saved_field[3]);
++#else
++            f->size = strtoll(saved_field[3], NULL, 10);
++#endif
+             free(saved_field[3]);
+             free(saved_field[4]);
+ 
+@@ -624,7 +640,11 @@
+         f->perm[0] = 'd';
+         f->size = 0L;
+     } else {
++#if 0
+         f->size = (unsigned long long)atoll(e);
++#else
++        f->size = (unsigned long long)strtoll(e, NULL, 10);
++#endif
+     }
+ 
+     f->nhl = 1;
+@@ -686,7 +706,11 @@
+              * FTP" Internet draft, but PureFTPd uses it for some
+              * reason for size of directories
+              */
++#if 0
+             f->size = atoll(value);
++#else
++            f->size = strtoll(value, NULL, 10);
++#endif
+         else if(strcasecmp(factname, "type") == 0) {
+             if(strcasecmp(value, "file") == 0)
+                 isdir = false;
diff --git a/ftp/yafc/files/patch-src::get.c b/ftp/yafc/files/patch-src::get.c
deleted file mode 100644
index 7015a58c4796..000000000000
--- a/ftp/yafc/files/patch-src::get.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/get.c.orig	Mon May 10 17:24:10 2004
-+++ src/get.c	Mon May 10 17:25:04 2004
-@@ -279,7 +279,7 @@
- 				e = xstrdup(ctime(&sb.st_mtime));
- 				a = ask(ASKYES|ASKNO|ASKUNIQUE|ASKCANCEL|ASKALL|ASKRESUME,
- 						ASKRESUME,
--						_("Local file '%s' exists\nLocal: %ld bytes, %sRemote: %ld bytes, %sOverwrite?"),
-+						_("Local file '%s' exists\nLocal: %lld bytes, %sRemote: %ld bytes, %sOverwrite?"),
- 						shortpath(dest, 42, gvLocalHomeDir),
- 						sb.st_size, e ? e : "unknown date",
- 						ftp_filesize(fi->path), ctime(&ft));
diff --git a/ftp/yafc/files/patch-src::put.c b/ftp/yafc/files/patch-src::put.c
deleted file mode 100644
index ab99f5f22c92..000000000000
--- a/ftp/yafc/files/patch-src::put.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/put.c.orig	Mon May 10 17:25:01 2004
-+++ src/put.c	Mon May 10 17:25:36 2004
-@@ -217,7 +217,7 @@
- 				e = xstrdup(ctime(&sb->st_mtime));
- 				a = ask(ASKYES|ASKNO|ASKUNIQUE|ASKCANCEL|ASKALL|ASKRESUME,
- 						ASKRESUME,
--						_("Remote file '%s' exists\nLocal: %ld bytes, %sRemote: %ld bytes, %sOverwrite?"),
-+						_("Remote file '%s' exists\nLocal: %lld bytes, %sRemote: %ld bytes, %sOverwrite?"),
- 						shortpath(dest, 42, ftp->homedir),
- 						sb->st_size, e ? e : "unknown date",
- 						ftp_filesize(f->path), ctime(&ft));
diff --git a/ftp/yafc/pkg-plist b/ftp/yafc/pkg-plist
index f0dd7c2cca1f..4574e4ece7d7 100644
--- a/ftp/yafc/pkg-plist
+++ b/ftp/yafc/pkg-plist
@@ -1 +1,4 @@
 bin/yafc
+%%PORTDOCS%%%%EXAMPLESDIR%%/inputrc.sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/yafcrc.sample
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
-- 
cgit v1.2.3