From df8066cafcfa16f6e9a481684991c64cb6d0ee35 Mon Sep 17 00:00:00 2001
From: Jeremy Messenger <mezz@FreeBSD.org>
Date: Mon, 10 May 2004 22:45:50 +0000
Subject: Fix the crash of resume and use INFO.

PR:		ports/66457
Submitted by:	Fredrik Lindberg <fliREMOVEME@shapeshifter.se>
Approved by:	adamw (mentor)
---
 ftp/yafc/Makefile               |  2 ++
 ftp/yafc/files/patch-src::get.c | 11 +++++++++++
 ftp/yafc/files/patch-src::put.c | 11 +++++++++++
 ftp/yafc/pkg-plist              |  3 ---
 4 files changed, 24 insertions(+), 3 deletions(-)
 create mode 100644 ftp/yafc/files/patch-src::get.c
 create mode 100644 ftp/yafc/files/patch-src::put.c

(limited to 'ftp/yafc')

diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index fbfff482dabc..e055fa8a361d 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -7,6 +7,7 @@
 
 PORTNAME=	yafc
 PORTVERSION=	1.0
+PORTREVISION=	1
 CATEGORIES=	ftp
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	${PORTNAME}
@@ -19,5 +20,6 @@ GNU_CONFIGURE=	yes
 CONFIGURE_TARGET=	--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
 
 MAN1=		yafc.1
+INFO=		yafc
 
 .include <bsd.port.mk>
diff --git a/ftp/yafc/files/patch-src::get.c b/ftp/yafc/files/patch-src::get.c
new file mode 100644
index 000000000000..7015a58c4796
--- /dev/null
+++ b/ftp/yafc/files/patch-src::get.c
@@ -0,0 +1,11 @@
+--- src/get.c.orig	Mon May 10 17:24:10 2004
++++ src/get.c	Mon May 10 17:25:04 2004
+@@ -279,7 +279,7 @@
+ 				e = xstrdup(ctime(&sb.st_mtime));
+ 				a = ask(ASKYES|ASKNO|ASKUNIQUE|ASKCANCEL|ASKALL|ASKRESUME,
+ 						ASKRESUME,
+-						_("Local file '%s' exists\nLocal: %ld bytes, %sRemote: %ld bytes, %sOverwrite?"),
++						_("Local file '%s' exists\nLocal: %lld bytes, %sRemote: %ld bytes, %sOverwrite?"),
+ 						shortpath(dest, 42, gvLocalHomeDir),
+ 						sb.st_size, e ? e : "unknown date",
+ 						ftp_filesize(fi->path), ctime(&ft));
diff --git a/ftp/yafc/files/patch-src::put.c b/ftp/yafc/files/patch-src::put.c
new file mode 100644
index 000000000000..ab99f5f22c92
--- /dev/null
+++ b/ftp/yafc/files/patch-src::put.c
@@ -0,0 +1,11 @@
+--- src/put.c.orig	Mon May 10 17:25:01 2004
++++ src/put.c	Mon May 10 17:25:36 2004
+@@ -217,7 +217,7 @@
+ 				e = xstrdup(ctime(&sb->st_mtime));
+ 				a = ask(ASKYES|ASKNO|ASKUNIQUE|ASKCANCEL|ASKALL|ASKRESUME,
+ 						ASKRESUME,
+-						_("Remote file '%s' exists\nLocal: %ld bytes, %sRemote: %ld bytes, %sOverwrite?"),
++						_("Remote file '%s' exists\nLocal: %lld bytes, %sRemote: %ld bytes, %sOverwrite?"),
+ 						shortpath(dest, 42, ftp->homedir),
+ 						sb->st_size, e ? e : "unknown date",
+ 						ftp_filesize(f->path), ctime(&ft));
diff --git a/ftp/yafc/pkg-plist b/ftp/yafc/pkg-plist
index b6c2a9676e5e..f0dd7c2cca1f 100644
--- a/ftp/yafc/pkg-plist
+++ b/ftp/yafc/pkg-plist
@@ -1,4 +1 @@
 bin/yafc
-@unexec install-info --delete %D/info/yafc.info %D/info/dir
-info/yafc.info
-@exec install-info %D/info/yafc.info %D/info/dir
-- 
cgit v1.2.3