From d27fbad2d1f7d3b594944515da28ef67a0b89d1a Mon Sep 17 00:00:00 2001
From: Martin Wilke <miwi@FreeBSD.org>
Date: Tue, 17 Nov 2009 09:12:42 +0000
Subject: With the goal of staying out of your way while writing creatively,
 PyRoom has a very specialized featureset. In fact, most features are hidden
 from your main interface, not cluttering your workspace with buttons and
 menus and statistics.

Features of PyRoom:
 * no visual clutter
 * work on multiple documents at once (main text, outline, etc)
 * control PyRoom via keyboard shortcuts
 * autosave your work
 * check wordcounts on keypress
 * choose from preconfigured designs or create your own color scheme
 * further customize visual appearance and whitespace (line spacing, border,
   padding...)

WWW:	http://www.pyroom.org

PR:		ports/140537
Submitted by:	Alexander Best
---
 editors/Makefile                                  |  1 +
 editors/py-room/Makefile                          | 33 +++++++++
 editors/py-room/distinfo                          |  3 +
 editors/py-room/files/patch-PyRoom-gui.py         | 11 +++
 editors/py-room/files/patch-PyRoom-preferences.py | 11 +++
 editors/py-room/files/patch-setup.py              | 15 ++++
 editors/py-room/pkg-descr                         | 15 ++++
 editors/py-room/pkg-plist                         | 86 +++++++++++++++++++++++
 8 files changed, 175 insertions(+)
 create mode 100644 editors/py-room/Makefile
 create mode 100644 editors/py-room/distinfo
 create mode 100644 editors/py-room/files/patch-PyRoom-gui.py
 create mode 100644 editors/py-room/files/patch-PyRoom-preferences.py
 create mode 100644 editors/py-room/files/patch-setup.py
 create mode 100644 editors/py-room/pkg-descr
 create mode 100644 editors/py-room/pkg-plist

(limited to 'editors')

diff --git a/editors/Makefile b/editors/Makefile
index 0e13182f9bd5..b06b0bda46e3 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -178,6 +178,7 @@
     SUBDIR += poedit
     SUBDIR += psgml
     SUBDIR += puff
+    SUBDIR += py-room
     SUBDIR += qemacs
     SUBDIR += richtext
     SUBDIR += rospell
diff --git a/editors/py-room/Makefile b/editors/py-room/Makefile
new file mode 100644
index 000000000000..faa244fae77f
--- /dev/null
+++ b/editors/py-room/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for:	py-room
+# Date created:		2009-11-11
+# Whom:			Alexander Best
+#
+# $FreeBSD$
+#
+
+PORTNAME=	room
+PORTVERSION=	0.4.1
+CATEGORIES=	editors python
+MASTER_SITES=	https://launchpad.net/pyroom/${PORTVERSION:R}/${PORTVERSION}/+download/
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+DISTNAME=	py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER=	alexbestms@wwu.de
+COMMENT=	PyRoom is a clone of WriteRoom and features "distraction-free writing"
+
+RUN_DEPENDS=	${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
+
+FETCH_ARGS=
+USE_GETTEXT=	yes
+USE_PYTHON=	yes
+USE_GNOME=	pygtk
+USE_PYDISTUTILS=	yes
+PYDISTUTILS_PKGNAME=	PyRoom
+
+post-patch:
+	@${REINPLACE_CMD} -e \
+		's|%%LOCALBASE%%|${LOCALBASE}|g' \
+			${WRKSRC}/setup.py ${WRKSRC}/PyRoom/preferences.py \
+				${WRKSRC}/PyRoom/gui.py
+
+.include <bsd.port.mk>
diff --git a/editors/py-room/distinfo b/editors/py-room/distinfo
new file mode 100644
index 000000000000..d8137a488422
--- /dev/null
+++ b/editors/py-room/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyroom-0.4.1.tar.gz) = 35e6dfb611b2732471a78f88465ebf7f
+SHA256 (pyroom-0.4.1.tar.gz) = 5a885010a7d207c90384c48869cc2be863df5b1bca561750ffd483a8969c9bf3
+SIZE (pyroom-0.4.1.tar.gz) = 85918
diff --git a/editors/py-room/files/patch-PyRoom-gui.py b/editors/py-room/files/patch-PyRoom-gui.py
new file mode 100644
index 000000000000..641a84a69041
--- /dev/null
+++ b/editors/py-room/files/patch-PyRoom-gui.py
@@ -0,0 +1,11 @@
+--- PyRoom/gui.py.orig	2009-11-13 04:07:00.000000000 +0100
++++ PyRoom/gui.py	2009-11-13 04:07:12.000000000 +0100
+@@ -53,7 +53,7 @@
+ 
+         order of preference is homedir, global dir, source dir (if available)"""
+         local_directory = os.path.join(data_home, 'pyroom', 'themes')
+-        global_directory = '/usr/share/pyroom/themes' # FIXME: platform
++        global_directory = '%%LOCALBASE%%/share/pyroom/themes' # FIXME: platform
+         # in case PyRoom is run without installation
+         fallback_directory = os.path.join(
+             os.path.dirname(os.path.abspath(__file__)),
diff --git a/editors/py-room/files/patch-PyRoom-preferences.py b/editors/py-room/files/patch-PyRoom-preferences.py
new file mode 100644
index 000000000000..c7bb321cabed
--- /dev/null
+++ b/editors/py-room/files/patch-PyRoom-preferences.py
@@ -0,0 +1,11 @@
+--- PyRoom/preferences.py	2009-11-13 03:57:27.000000000 +0100
++++ PyRoom/preferences.py	2009-11-13 03:57:44.000000000 +0100
+@@ -95,7 +95,7 @@
+         self.conf_dir = os.path.join(config_home, 'pyroom')
+         self.data_dir = os.path.join(data_home, 'pyroom')
+         self.themes_dir  = os.path.join(self.data_dir, 'themes')
+-        self.global_themes_dir = '/usr/share/pyroom/themes'
++        self.global_themes_dir = '%%LOCALBASE%%/share/pyroom/themes'
+         # if we are not using a global installation,
+         # take the themes directly from sources
+         if not os.path.isdir(self.global_themes_dir) :
diff --git a/editors/py-room/files/patch-setup.py b/editors/py-room/files/patch-setup.py
new file mode 100644
index 000000000000..93d4646bd2f0
--- /dev/null
+++ b/editors/py-room/files/patch-setup.py
@@ -0,0 +1,15 @@
+--- setup.py	2009-11-13 03:32:53.000000000 +0100
++++ setup.py	2009-11-13 03:35:25.000000000 +0100
+@@ -52,9 +52,9 @@
+   packages = ['PyRoom',],
+   package_data = {'PyRoom':['interface.glade']},
+   data_files = [
+-    ('/usr/share/pyroom/themes', glob.glob('themes/*.theme')),
+-    ('/usr/share/pyroom', ['pyroom.png']),
+-    ('/usr/share/applications', ['pyroom.desktop'])
++    ('%%LOCALBASE%%/share/pyroom/themes', glob.glob('themes/*.theme')),
++    ('%%LOCALBASE%%/share/pyroom', ['pyroom.png']),
++    ('%%LOCALBASE%%/share/applications', ['pyroom.desktop'])
+     ],
+   scripts=['pyroom',],
+   cmdclass={'install_data': InstallData},
diff --git a/editors/py-room/pkg-descr b/editors/py-room/pkg-descr
new file mode 100644
index 000000000000..f996dd1cbb27
--- /dev/null
+++ b/editors/py-room/pkg-descr
@@ -0,0 +1,15 @@
+With the goal of staying out of your way while writing creatively, PyRoom has a
+very specialized featureset. In fact, most features are hidden from your main
+interface, not cluttering your workspace with buttons and menus and statistics.
+
+Features of PyRoom:
+ * no visual clutter
+ * work on multiple documents at once (main text, outline, etc)
+ * control PyRoom via keyboard shortcuts
+ * autosave your work
+ * check wordcounts on keypress
+ * choose from preconfigured designs or create your own color scheme
+ * further customize visual appearance and whitespace (line spacing, border,
+   padding...)
+
+WWW:	http://www.pyroom.org
diff --git a/editors/py-room/pkg-plist b/editors/py-room/pkg-plist
new file mode 100644
index 000000000000..df8cdb22b2dc
--- /dev/null
+++ b/editors/py-room/pkg-plist
@@ -0,0 +1,86 @@
+bin/pyroom
+%%PYTHON_SITELIBDIR%%/PyRoom/__init__.py
+%%PYTHON_SITELIBDIR%%/PyRoom/__init__.pyc
+%%PYTHON_SITELIBDIR%%/PyRoom/__init__.pyo
+%%PYTHON_SITELIBDIR%%/PyRoom/autosave.py
+%%PYTHON_SITELIBDIR%%/PyRoom/autosave.pyc
+%%PYTHON_SITELIBDIR%%/PyRoom/autosave.pyo
+%%PYTHON_SITELIBDIR%%/PyRoom/basic_edit.py
+%%PYTHON_SITELIBDIR%%/PyRoom/basic_edit.pyc
+%%PYTHON_SITELIBDIR%%/PyRoom/basic_edit.pyo
+%%PYTHON_SITELIBDIR%%/PyRoom/cmdline.py
+%%PYTHON_SITELIBDIR%%/PyRoom/cmdline.pyc
+%%PYTHON_SITELIBDIR%%/PyRoom/cmdline.pyo
+%%PYTHON_SITELIBDIR%%/PyRoom/gui.py
+%%PYTHON_SITELIBDIR%%/PyRoom/gui.pyc
+%%PYTHON_SITELIBDIR%%/PyRoom/gui.pyo
+%%PYTHON_SITELIBDIR%%/PyRoom/interface.glade
+%%PYTHON_SITELIBDIR%%/PyRoom/preferences.py
+%%PYTHON_SITELIBDIR%%/PyRoom/preferences.pyc
+%%PYTHON_SITELIBDIR%%/PyRoom/preferences.pyo
+%%PYTHON_SITELIBDIR%%/PyRoom/pyroom_error.py
+%%PYTHON_SITELIBDIR%%/PyRoom/pyroom_error.pyc
+%%PYTHON_SITELIBDIR%%/PyRoom/pyroom_error.pyo
+share/pyroom/themes/amber.theme
+share/pyroom/themes/banker.theme
+share/pyroom/themes/blue.theme
+share/pyroom/themes/c64.theme
+share/pyroom/themes/cupid.theme
+share/pyroom/themes/custom.theme
+share/pyroom/themes/darkgreen.theme
+share/pyroom/themes/green.theme
+share/pyroom/themes/grey.theme
+share/pyroom/themes/locontrast.theme
+share/pyroom/themes/soft_letterpaper.theme
+share/pyroom/themes/website.theme
+share/pyroom/pyroom.png
+share/applications/pyroom.desktop
+share/locale/ar/LC_MESSAGES/pyroom.mo
+share/locale/bg/LC_MESSAGES/pyroom.mo
+share/locale/br/LC_MESSAGES/pyroom.mo
+share/locale/ca/LC_MESSAGES/pyroom.mo
+share/locale/cy/LC_MESSAGES/pyroom.mo
+share/locale/da/LC_MESSAGES/pyroom.mo
+share/locale/de/LC_MESSAGES/pyroom.mo
+share/locale/el/LC_MESSAGES/pyroom.mo
+share/locale/en_GB/LC_MESSAGES/pyroom.mo
+share/locale/eo/LC_MESSAGES/pyroom.mo
+share/locale/es/LC_MESSAGES/pyroom.mo
+share/locale/eu/LC_MESSAGES/pyroom.mo
+share/locale/fi/LC_MESSAGES/pyroom.mo
+share/locale/fr/LC_MESSAGES/pyroom.mo
+share/locale/ga/LC_MESSAGES/pyroom.mo
+share/locale/gu/LC_MESSAGES/pyroom.mo
+share/locale/hr/LC_MESSAGES/pyroom.mo
+share/locale/hu/LC_MESSAGES/pyroom.mo
+share/locale/id/LC_MESSAGES/pyroom.mo
+share/locale/it/LC_MESSAGES/pyroom.mo
+share/locale/ja/LC_MESSAGES/pyroom.mo
+share/locale/lt/LC_MESSAGES/pyroom.mo
+share/locale/lv/LC_MESSAGES/pyroom.mo
+share/locale/mk/LC_MESSAGES/pyroom.mo
+share/locale/nb/LC_MESSAGES/pyroom.mo
+share/locale/nl/LC_MESSAGES/pyroom.mo
+share/locale/nn/LC_MESSAGES/pyroom.mo
+share/locale/pl/LC_MESSAGES/pyroom.mo
+share/locale/pt/LC_MESSAGES/pyroom.mo
+share/locale/pt_BR/LC_MESSAGES/pyroom.mo
+share/locale/ro/LC_MESSAGES/pyroom.mo
+share/locale/ru/LC_MESSAGES/pyroom.mo
+share/locale/sk/LC_MESSAGES/pyroom.mo
+share/locale/sl/LC_MESSAGES/pyroom.mo
+share/locale/sr/LC_MESSAGES/pyroom.mo
+share/locale/sv/LC_MESSAGES/pyroom.mo
+share/locale/tr/LC_MESSAGES/pyroom.mo
+share/locale/zh_CN/LC_MESSAGES/pyroom.mo
+share/locale/ku/LC_MESSAGES/pyroom.mo
+share/locale/sco/LC_MESSAGES/pyroom.mo
+@dirrmtry share/applications
+@dirrmtry share/locale/sco/LC_MESSAGES
+@dirrmtry share/locale/sco
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrm %%PYTHON_SITELIBDIR%%/PyRoom
+@dirrm %%PYTHON_SITELIBDIR%%
+@dirrm share/pyroom/themes
+@dirrm share/pyroom
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0