From 9594f3f8939f5178057c6a588135f0bab6d52511 Mon Sep 17 00:00:00 2001
From: Ade Lovett <ade@FreeBSD.org>
Date: Fri, 4 Aug 2000 01:34:38 +0000
Subject: Extensive patchfile cleanups using sobomax's wonderful post-extract
 rule

---
 editors/ghex/Makefile | 7 +++++++
 1 file changed, 7 insertions(+)

(limited to 'editors/ghex')

diff --git a/editors/ghex/Makefile b/editors/ghex/Makefile
index faaf6a50149a..c399504f634f 100644
--- a/editors/ghex/Makefile
+++ b/editors/ghex/Makefile
@@ -29,4 +29,11 @@ CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
 		GTK_CONFIG="${GTK_CONFIG}" \
 		LIBS="-L${LOCALBASE}/lib"
 
+post-extract:
+	@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+		 s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+	@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+		's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+		 s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
 .include <bsd.port.mk>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0