From bba34eac04c6357737fc8e792b1402b357726457 Mon Sep 17 00:00:00 2001
From: Stephen Hurd <shurd@FreeBSD.org>
Date: Wed, 19 Jun 2019 06:39:05 +0000
Subject: Fix issue where if the height of the slider is greater than the
 height of the text, the slider isn't displayed.

---
 comms/quisk/Makefile                      |  2 +-
 comms/quisk/files/patch-quisk__widgets.py | 20 ++++++++++++++++++++
 2 files changed, 21 insertions(+), 1 deletion(-)
 create mode 100644 comms/quisk/files/patch-quisk__widgets.py

(limited to 'comms')

diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index 734e4b1d20be..522ef53825a6 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -3,7 +3,7 @@
 
 PORTNAME=	quisk
 DISTVERSION=	4.1.40
-PORTREVISION=	2
+PORTREVISION=	3
 CATEGORIES=	comms hamradio
 MASTER_SITES=	CHEESESHOP
 
diff --git a/comms/quisk/files/patch-quisk__widgets.py b/comms/quisk/files/patch-quisk__widgets.py
new file mode 100644
index 000000000000..26379d6eaf8c
--- /dev/null
+++ b/comms/quisk/files/patch-quisk__widgets.py
@@ -0,0 +1,20 @@
+--- quisk_widgets.py.orig	2019-06-19 06:35:39 UTC
++++ quisk_widgets.py
+@@ -248,7 +248,16 @@ class SliderBoxH:
+     else:
+       self.text_ctrl = wx.StaticText(parent, -1, t, pos=pos)
+       w2, h2 = self.text_ctrl.GetSize()
+-      self.slider = wx.Slider(parent, -1, init, themin, themax, (pos[0] + w2, pos[1]), (width - w2, h2))
++      self.slider = wx.Slider(parent, -1, init, themin, themax)
++      w3, h3 = self.slider.GetSize()
++      p2 = pos[1]
++      if h3 > h2:
++        p2 -= (h3 - h2) / 2
++        h2 = h3
++      else:
++        p2 += (h2 - h3) / 2
++      self.slider.SetSize((width - w2, h2))
++      self.slider.SetPosition((pos[0] + w2, p2))
+     self.slider.Bind(wx.EVT_SCROLL, self.OnScroll)
+     self.text_ctrl.SetForegroundColour(parent.GetForegroundColour())
+     self.OnScroll()
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0