From 9d7eaa9c4cb53988352b0fe17f5482eba6916a75 Mon Sep 17 00:00:00 2001
From: Piotr Kubaj <pkubaj@FreeBSD.org>
Date: Fri, 10 May 2019 11:16:15 +0000
Subject: comms/flrig: fix build on powerpc64

Add -mminimal-toc to CFLAGS on powerpc64 to fix linking:
/usr/bin/ld: rigs/flrig-TS950.o(.text+0x1c40): sibling call optimization to `_ZN7rigbaseD2Ev' does not allow automatic multiple TOCs; recompile with -mminimal-toc or -fno-optimize-sibling-calls, or make `_ZN7rigbaseD2Ev' extern

PR:		237816
Approved by:	tcberner (mentor), db (maintainer, via email)
Differential Revision:	https://reviews.freebsd.org/D20217
---
 comms/flrig/Makefile | 2 ++
 1 file changed, 2 insertions(+)

(limited to 'comms')

diff --git a/comms/flrig/Makefile b/comms/flrig/Makefile
index 207d410912db..ffd631c4890e 100644
--- a/comms/flrig/Makefile
+++ b/comms/flrig/Makefile
@@ -26,4 +26,6 @@ NATIVE_OPT_DESC=	Enable Native Optimizations
 NATIVE_OPT_CONFIGURE_ON+=	--enable-optimizations=native
 NATIVE_OPT_CONFIGURE_OFF+=	--enable-optimizations=none
 
+CFLAGS_powerpc64=	-mminimal-toc
+
 .include <bsd.port.mk>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0