From 151b250bdccf491ba5526a07475aaf5eaeb95fe0 Mon Sep 17 00:00:00 2001
From: Oliver Lehmann <oliver@FreeBSD.org>
Date: Wed, 13 Aug 2003 14:34:12 +0000
Subject: unbreaking on Alpha (and maybe on other 64bit platforms (untested))
 bump PORTREVISION

Submitted by:	Thierry Thomas <thierry@pompo.net>
PR:		ports/55544
---
 cad/metis-edf/Makefile                       | 15 ++++++++++++++-
 cad/metis-edf/files/patch-CONFIG::configure  | 20 +++++++++++++++-----
 cad/metis-edf/files/patch-Lib::proto.h       | 12 ++++++++++++
 cad/metis-edf/files/patch-Programs::Makefile | 16 ++++++++--------
 4 files changed, 49 insertions(+), 14 deletions(-)
 create mode 100644 cad/metis-edf/files/patch-Lib::proto.h

(limited to 'cad')

diff --git a/cad/metis-edf/Makefile b/cad/metis-edf/Makefile
index 1023e154728e..ca2be7eab09b 100644
--- a/cad/metis-edf/Makefile
+++ b/cad/metis-edf/Makefile
@@ -7,6 +7,7 @@
 
 PORTNAME=	metis-edf
 PORTVERSION=	3
+PORTREVISION=	1
 CATEGORIES=	cad
 MASTER_SITES=	http://www.code-aster.org/FICHIERS/metis/
 
@@ -16,10 +17,22 @@ COMMENT=	Meshes partionning tool used by Code_Aster
 CONFLICTS=	metis-[0-9]*
 
 ALL_TARGET=	default
-MAKE_ENV+=	CC="${CC}" AR="${AR}" LD="${LD}" F77="${F77}"
+MAKE_ENV+=	CC="${CC}" AR="${AR}" F77="${F77}" FFLAGS="${FFLAGS}"
 USE_REINPLACE=	yes
+REINPLACE_ARGS=	-i ""
 
 F77?=		f77
+FFLAGS?=	-O2
+
+post-patch:
+.if ${MACHINE_ARCH} != "i386"
+	@${FIND} ${WRKSRC} -type f -name "*.c" -o -name "*.h" | ${XARGS}	\
+		${REINPLACE_CMD} -e "s|long int|int|g"				\
+			-e "s|long|int|g"					\
+			-e "s|\(%[[:digit:]]\)ld|\1d|g"				\
+			-e "s|\(%[[:digit:]]\.[[:digit:]]\)le|\1e|g"		\
+			-e "s|%ld|%d|g"
+.endif
 
 do-install:
 	@${CP} ${WRKSRC}/CONFIG/onmetis.in ${WRKSRC}/onmetis
diff --git a/cad/metis-edf/files/patch-CONFIG::configure b/cad/metis-edf/files/patch-CONFIG::configure
index d361908d84f0..72bc1f1c3d14 100644
--- a/cad/metis-edf/files/patch-CONFIG::configure
+++ b/cad/metis-edf/files/patch-CONFIG::configure
@@ -1,6 +1,14 @@
 --- CONFIG/configure.orig	Mon Dec 16 18:11:44 2002
-+++ CONFIG/configure	Sun Jun 29 14:58:48 2003
-@@ -18,7 +18,7 @@
++++ CONFIG/configure	Tue Aug 12 22:47:59 2003
+@@ -4,6 +4,7 @@
+ # SHELL defined by make (sh)
+ 
+ OS_TYPE=`uname -s`
++ARCHI=`uname -p`
+ if [ $OS_TYPE = "SunOS" ]; then
+  	OS_LEVEL=`uname -r`
+    OS_NIV=`echo $OS_LEVEL | awk -F'.' '{print $2}'`
+@@ -18,7 +19,7 @@
     if [ -z "$rtn" ] || [ "$rtn" = "y" -o "$rtn" = "Y" ]; then
        OS_TYPE=SunOS64
     fi
@@ -9,7 +17,7 @@
  	echo " Operating system $OS_TYPE unknown on this distribution"
  	echo " Installation failed !"
     exit 8
-@@ -30,14 +30,23 @@
+@@ -30,14 +31,25 @@
  # FOPTIONS : Fortran compiler options,
  # LDOPTIONS : link options, AR : archiver
  
@@ -24,9 +32,11 @@
 +if [ $OS_TYPE = "FreeBSD" ]; then
 +   CC="$CC"
 +   F90="$F77"
-+   LD="$LD"
++   LD="$CC -v"
 +   COPTIONS="$CFLAGS"
-+   LDOPTIONS="$LDFLAGS -lc -lg2c -L. -L.."
++   OPTFLAGS=""
++   FOPTIONS="$FFLAGS"
++   LDOPTIONS="$LDFLAGS -L. -L.."
 +   AR="$AR rv"
 +else
 +   CC="cc"
diff --git a/cad/metis-edf/files/patch-Lib::proto.h b/cad/metis-edf/files/patch-Lib::proto.h
new file mode 100644
index 000000000000..3b423fff5ae3
--- /dev/null
+++ b/cad/metis-edf/files/patch-Lib::proto.h
@@ -0,0 +1,12 @@
+--- Lib/proto.h.orig	Thu Dec 12 13:47:59 2002
++++ Lib/proto.h	Tue Aug 12 22:53:22 2003
+@@ -456,7 +456,9 @@
+  void saxpy(long, float, float *, long, float *, long); 
+  void RandomPermute(long, idxtype *, long); 
+  double drand48(); 
++#if !defined(__FreeBSD__)
+  void srand48(long); 
++#endif
+  long ispow2(long); 
+  void InitRandom(long); 
+  long log2(long); 
diff --git a/cad/metis-edf/files/patch-Programs::Makefile b/cad/metis-edf/files/patch-Programs::Makefile
index f50d7d73bce3..fccd5479424e 100644
--- a/cad/metis-edf/files/patch-Programs::Makefile
+++ b/cad/metis-edf/files/patch-Programs::Makefile
@@ -1,11 +1,11 @@
 --- Programs/Makefile.orig	Thu Dec 12 13:47:59 2002
-+++ Programs/Makefile	Sun Jun 29 15:39:26 2003
-@@ -11,7 +11,7 @@
++++ Programs/Makefile	Wed Aug 13 15:10:19 2003
+@@ -5,7 +5,7 @@
+ INCLUDES = -I../Lib 
+ CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+ FFLAGS = $(FOPTIONS) $(OPTFLAGS) $(INCLUDES)
+-LIBS = -lmetis -lm
++LIBS = -lmetis -lm  -lg2c
+ METISLIB = ../libmetis.a
  
  
- 
--ONMETISOBJS = onmetis.o io.o smbfactor.o ecri11.o lect11.o lect00.o
-+ONMETISOBJS = onmetis.o io.o smbfactor.o ecri11.o lect11.o lect00.o /usr/lib/crt1.o
- 
-  
- 
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0