From f2dd42fd29eef6849dc00326d62f612bc4feb7ee Mon Sep 17 00:00:00 2001
From: Will Andrews <will@FreeBSD.org>
Date: Thu, 21 Dec 2000 07:07:39 +0000
Subject: Make id3lib use libtool correctly.  Use automake/autoconf along with
 a patch to configure.in instead of configure.  Sort plist.  Remove redundate
 GNU_CONFIGURE.  Use LOCALBASE in CONFIGURE_ENV rather than PREFIX.

PR:		22584
Submitted by:	Espen Skoglund <esk@ira.uka.de>
---
 audio/id3lib/Makefile       |  7 ++++--
 audio/id3lib/files/patch-aa | 59 +++++++++++++++------------------------------
 audio/id3lib/pkg-plist      | 11 ++++-----
 3 files changed, 29 insertions(+), 48 deletions(-)

(limited to 'audio')

diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index 88fe86145e4e..ec784810fcd6 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -16,8 +16,11 @@ MAINTAINER=	roman@xpert.com
 LIB_DEPENDS=	popt.0:${PORTSDIR}/devel/popt
 
 INSTALLS_SHLIB=	yes
-GNU_CONFIGURE=	yes
-CONFIGURE_ENV=	LDFLAGS="-L${PREFIX}/lib" CPPFLAGS="-I${PREFIX}/include"
+USE_LIBTOOL=	yes
+USE_AUTOMAKE=	yes
+USE_GMAKE=	yes
+CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
+		LIBS="-L${LOCALBASE}/lib"
 
 post-extract:
 .for i in zlib popt
diff --git a/audio/id3lib/files/patch-aa b/audio/id3lib/files/patch-aa
index 05f8de3ec76e..fa6124e4ae51 100644
--- a/audio/id3lib/files/patch-aa
+++ b/audio/id3lib/files/patch-aa
@@ -1,43 +1,22 @@
---- configure.orig	Fri Sep 15 03:14:06 2000
-+++ configure	Thu Oct 26 03:26:10 2000
-@@ -2200,7 +2200,7 @@
+--- configure.in.orig	Fri Nov  3 19:29:51 2000
++++ configure.in	Fri Nov  3 19:29:28 2000
+@@ -143,7 +143,7 @@
+ )
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+-AC_CHECK_HEADER(iostream.h iomanip.h)
++AC_CHECK_HEADERS(iostream.h iomanip.h)
  
- fi
+ dnl Check for functions.
+ AC_FUNC_MEMCMP
+--- Makefile.am.orig	Fri Nov  3 19:29:40 2000
++++ Makefile.am	Fri Nov  3 19:30:12 2000
+@@ -32,7 +32,7 @@
+ popt_subdir = 
+ endif
  
--for ac_hdr in zlib.h wchar.h sys/param.h popt.h
-+for ac_hdr in zlib.h sys/param.h popt.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -2296,16 +2296,18 @@
- ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
- cross_compiling=$ac_cv_prog_cxx_cross
+-SUBDIRS =  . m4 $(popt_subdir) $(zlib_subdir) doc include src examples
++SUBDIRS =  . m4 doc include src examples
+ DIST_SUBDIRS = . m4 popt zlib doc include src examples
  
--ac_safe=`echo "iostream.h iomanip.h" | sed 'y%./+-%__p_%'`
--echo $ac_n "checking for iostream.h iomanip.h""... $ac_c" 1>&6
--echo "configure:2302: checking for iostream.h iomanip.h" >&5
-+for ac_hdr in iostream.h iomanip.h
-+do
-+ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
-+echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-+echo "configure:2302: checking for $ac_hdr" >&5
- if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
-   echo $ac_n "(cached) $ac_c" 1>&6
- else
-   cat > conftest.$ac_ext <<EOF
- #line 2307 "configure"
- #include "confdefs.h"
--#include <iostream.h iomanip.h>
-+#include <$ac_hdr>
- EOF
- ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
- { (eval echo configure:2312: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
-@@ -2328,7 +2330,7 @@
- else
-   echo "$ac_t""no" 1>&6
- fi
--
-+done
- 
- echo $ac_n "checking for 8-bit clean memcmp""... $ac_c" 1>&6
- echo "configure:2335: checking for 8-bit clean memcmp" >&5
+ INCLUDES = @ID3LIB_DEBUG_FLAGS@
diff --git a/audio/id3lib/pkg-plist b/audio/id3lib/pkg-plist
index dc7edba45f41..98401520e128 100644
--- a/audio/id3lib/pkg-plist
+++ b/audio/id3lib/pkg-plist
@@ -1,7 +1,8 @@
-bin/id3info
 bin/id3convert
-bin/id3tag
 bin/id3cp
+bin/id3info
+bin/id3tag
+include/id3.h
 include/id3/error.h
 include/id3/field.h
 include/id3/flags.h
@@ -14,10 +15,8 @@ include/id3/misc_support.h
 include/id3/sized_types.h
 include/id3/spec.h
 include/id3/tag.h
-include/id3.h
-lib/libid3-3.7.so.13
 lib/libid3-3.7.so
-lib/libid3.so
-lib/libid3.la
+lib/libid3-3.7.so.13
 lib/libid3.a
+lib/libid3.so
 @dirrm include/id3
-- 
cgit v1.2.3