From 851df9f93ed3aacb94524851b5e77aa8f8689980 Mon Sep 17 00:00:00 2001
From: Will Andrews <will@FreeBSD.org>
Date: Fri, 9 Jun 2000 05:40:09 +0000
Subject: Add pimp3, a python script that's supposed to make random play much
 nicer when using mpg123.

PR:		16949
Submitted by:	Rod Taylor <rbt@zort.on.ca>
---
 audio/Makefile          |  1 +
 audio/pimp3/Makefile    | 35 +++++++++++++++++++++++++++++++++++
 audio/pimp3/distinfo    |  1 +
 audio/pimp3/pkg-comment |  1 +
 audio/pimp3/pkg-descr   |  8 ++++++++
 audio/pimp3/pkg-plist   |  5 +++++
 6 files changed, 51 insertions(+)
 create mode 100644 audio/pimp3/Makefile
 create mode 100644 audio/pimp3/distinfo
 create mode 100644 audio/pimp3/pkg-comment
 create mode 100644 audio/pimp3/pkg-descr
 create mode 100644 audio/pimp3/pkg-plist

(limited to 'audio')

diff --git a/audio/Makefile b/audio/Makefile
index ba5feb13d65f..7bbed0795022 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -61,6 +61,7 @@
     SUBDIR += napster
     SUBDIR += nas
     SUBDIR += nspmod
+    SUBDIR += pimp3
     SUBDIR += play
     SUBDIR += playmidi
     SUBDIR += pysol-sound-server
diff --git a/audio/pimp3/Makefile b/audio/pimp3/Makefile
new file mode 100644
index 000000000000..974220df5680
--- /dev/null
+++ b/audio/pimp3/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for:	pimp
+# Date created:				23 February 2000
+# Whom:					rbt
+#
+# $FreeBSD$
+#
+
+PORTNAME=	pimp3
+PORTVERSION=	0.5.7
+CATEGORIES=	audio
+MASTER_SITES=	http://pimp3.sourceforge.net/files/
+
+MAINTAINER=	rbt@zort.on.ca
+
+BUILD_DEPENDS=	python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS=	mpg123:${PORTSDIR}/audio/mpg123
+
+WRKSRC=		${WRKDIR}/pimp3
+
+NO_BUILD=	yes
+
+do-install:
+	${INSTALL_SCRIPT} ${WRKSRC}/*.py ${PREFIX}/bin/
+	${INSTALL_SCRIPT} ${WRKSRC}/*.pyc ${PREFIX}/bin/
+
+post-install:
+	@${ECHO_MSG}
+	@${ECHO_MSG} "Take a look at the README to see how to install"
+	@${ECHO_MSG} "and configure an audio database, among other"
+	@${ECHO_MSG} "details that should be known."
+	@${ECHO_MSG} ""
+	@${ECHO_MSG} "Location: ${WRKDIR}/pimp3/README"
+	@${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/audio/pimp3/distinfo b/audio/pimp3/distinfo
new file mode 100644
index 000000000000..0efa67e58cf1
--- /dev/null
+++ b/audio/pimp3/distinfo
@@ -0,0 +1 @@
+MD5 (pimp3-0.5.7.tar.gz) = ed76d7323d5685fa23b8aadea824ea8f
diff --git a/audio/pimp3/pkg-comment b/audio/pimp3/pkg-comment
new file mode 100644
index 000000000000..b7ec4374c38e
--- /dev/null
+++ b/audio/pimp3/pkg-comment
@@ -0,0 +1 @@
+Rate your mp3s for a randomized playlist you will actually like
diff --git a/audio/pimp3/pkg-descr b/audio/pimp3/pkg-descr
new file mode 100644
index 000000000000..54f83d2c383a
--- /dev/null
+++ b/audio/pimp3/pkg-descr
@@ -0,0 +1,8 @@
+The python intelligent mp3 player can be used to make your mp3 listening
+experience above what you currently recieve with random play.  By using its
+ability to track and rank mp3s based on listener approval or dissaproval
+it will tend to play the songs you like more than the ones you don't.
+
+Finally everything can be tossed into a bitbucket of a random playlist.
+
+WWW: http://pimp3.sourceforge.net
diff --git a/audio/pimp3/pkg-plist b/audio/pimp3/pkg-plist
new file mode 100644
index 000000000000..2e3e80621fab
--- /dev/null
+++ b/audio/pimp3/pkg-plist
@@ -0,0 +1,5 @@
+bin/database.py
+bin/pimp3.py
+bin/play.py
+bin/play.pyc
+bin/database.pyc
-- 
cgit v1.2.3