From ebef627b53a7014a46d95e592dff93905fbc71ed Mon Sep 17 00:00:00 2001
From: Mathieu Arnold <mat@FreeBSD.org>
Date: Fri, 9 May 2014 17:55:08 +0000
Subject: Add Monitoring::Plugin, a Nagios::Plugin fork.

Sponsored by:	Absolight
---
 net-mgmt/Makefile                       |  1 +
 net-mgmt/p5-Monitoring-Plugin/Makefile  | 32 ++++++++++++++++++++++++++++++++
 net-mgmt/p5-Monitoring-Plugin/distinfo  |  2 ++
 net-mgmt/p5-Monitoring-Plugin/pkg-descr |  7 +++++++
 net-mgmt/p5-Monitoring-Plugin/pkg-plist | 21 +++++++++++++++++++++
 5 files changed, 63 insertions(+)
 create mode 100644 net-mgmt/p5-Monitoring-Plugin/Makefile
 create mode 100644 net-mgmt/p5-Monitoring-Plugin/distinfo
 create mode 100644 net-mgmt/p5-Monitoring-Plugin/pkg-descr
 create mode 100644 net-mgmt/p5-Monitoring-Plugin/pkg-plist

diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 9c1877bebada..a39a4c2b62e7 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -206,6 +206,7 @@
     SUBDIR += p5-GRNOC-TL1
     SUBDIR += p5-MRTG-Parse
     SUBDIR += p5-Mon
+    SUBDIR += p5-Monitoring-Plugin
     SUBDIR += p5-NSNMP
     SUBDIR += p5-Nagios-Object
     SUBDIR += p5-Nagios-Plugin
diff --git a/net-mgmt/p5-Monitoring-Plugin/Makefile b/net-mgmt/p5-Monitoring-Plugin/Makefile
new file mode 100644
index 000000000000..eb1255e6a0b1
--- /dev/null
+++ b/net-mgmt/p5-Monitoring-Plugin/Makefile
@@ -0,0 +1,32 @@
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
+# $FreeBSD$
+
+PORTNAME=	Monitoring-Plugin
+PORTVERSION=	0.37
+CATEGORIES=	net-mgmt perl5
+MASTER_SITES=	CPAN
+MASTER_SITE_SUBDIR=	CPAN:NIERLEIN
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	mat@FreeBSD.org
+COMMENT=	Modules to streamline writing Monitoring plugins
+
+LICENSE=	ART10 GPLv1
+LICENSE_COMB=	dual
+
+BUILD_DEPENDS=	p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+		p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
+		p5-Math-Calc-Units>=0:${PORTSDIR}/math/p5-Math-Calc-Units \
+		p5-Config-Tiny>=0:${PORTSDIR}/devel/p5-Config-Tiny
+RUN_DEPENDS:=	${BUILD_DEPENDS}
+
+USES=		perl5
+USE_PERL5=	configure
+
+PORTDOCS=	Changes README
+
+post-install:
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Monitoring-Plugin/distinfo b/net-mgmt/p5-Monitoring-Plugin/distinfo
new file mode 100644
index 000000000000..55b10ecea438
--- /dev/null
+++ b/net-mgmt/p5-Monitoring-Plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Monitoring-Plugin-0.37.tar.gz) = 786c08a28435e3d004ea51f44dba6432e58da5c93def39bb68d3b028072e00bd
+SIZE (Monitoring-Plugin-0.37.tar.gz) = 62278
diff --git a/net-mgmt/p5-Monitoring-Plugin/pkg-descr b/net-mgmt/p5-Monitoring-Plugin/pkg-descr
new file mode 100644
index 000000000000..9eae0198fe7c
--- /dev/null
+++ b/net-mgmt/p5-Monitoring-Plugin/pkg-descr
@@ -0,0 +1,7 @@
+Object oriented helper routines for your Nagios plugin:
+
+This is the place for common routines when writing Nagios plugins. The idea is
+to make it as easy as possible for developers to conform to the plugin
+guidelines (http://nagiosplug.sourceforge.net/developer-guidelines.html).
+
+WWW: http://search.cpan.org/dist/Nagios-Plugin/
diff --git a/net-mgmt/p5-Monitoring-Plugin/pkg-plist b/net-mgmt/p5-Monitoring-Plugin/pkg-plist
new file mode 100644
index 000000000000..2661f1e84781
--- /dev/null
+++ b/net-mgmt/p5-Monitoring-Plugin/pkg-plist
@@ -0,0 +1,21 @@
+%%SITE_PERL%%/Monitoring/Plugin.pm
+%%SITE_PERL%%/Monitoring/Plugin/Config.pm
+%%SITE_PERL%%/Monitoring/Plugin/ExitResult.pm
+%%SITE_PERL%%/Monitoring/Plugin/Functions.pm
+%%SITE_PERL%%/Monitoring/Plugin/Getopt.pm
+%%SITE_PERL%%/Monitoring/Plugin/Performance.pm
+%%SITE_PERL%%/Monitoring/Plugin/Range.pm
+%%SITE_PERL%%/Monitoring/Plugin/Threshold.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Monitoring/Plugin/.packlist
+%%PERL5_MAN3%%/Monitoring::Plugin.3.gz
+%%PERL5_MAN3%%/Monitoring::Plugin::Config.3.gz
+%%PERL5_MAN3%%/Monitoring::Plugin::ExitResult.3.gz
+%%PERL5_MAN3%%/Monitoring::Plugin::Functions.3.gz
+%%PERL5_MAN3%%/Monitoring::Plugin::Getopt.3.gz
+%%PERL5_MAN3%%/Monitoring::Plugin::Performance.3.gz
+%%PERL5_MAN3%%/Monitoring::Plugin::Range.3.gz
+%%PERL5_MAN3%%/Monitoring::Plugin::Threshold.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Monitoring/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Monitoring
+@dirrm %%SITE_PERL%%/Monitoring/Plugin
+@dirrmtry %%SITE_PERL%%/Monitoring
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0