From e74db4a6d97b241c1d4653867d2fe26d432ddada Mon Sep 17 00:00:00 2001
From: Jean-Yves Lefort <jylefort@FreeBSD.org>
Date: Tue, 21 Mar 2006 16:28:29 +0000
Subject: Add libzip.

libzip is a C library for reading, creating, and modifying zip archives. Files
can be added from data buffers, files, or compressed data copied directly from
other zip archives. Changes made without closing the archive can be reverted.
The API is documented by man pages.

WWW: http://www.nih.at/libzip/

PR:		ports/94710
Submitted by:	Alexander Zhuravlev <zaa@ulstu.ru>
---
 archivers/Makefile                           |  1 +
 archivers/libzip/Makefile                    | 64 ++++++++++++++++++++++++++++
 archivers/libzip/distinfo                    |  3 ++
 archivers/libzip/files/patch-man_Makefile.in | 13 ++++++
 archivers/libzip/pkg-descr                   |  6 +++
 5 files changed, 87 insertions(+)
 create mode 100644 archivers/libzip/Makefile
 create mode 100644 archivers/libzip/distinfo
 create mode 100644 archivers/libzip/files/patch-man_Makefile.in
 create mode 100644 archivers/libzip/pkg-descr

diff --git a/archivers/Makefile b/archivers/Makefile
index e9d8ed7d93d0..65fd45de6428 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -42,6 +42,7 @@
     SUBDIR += liblzxcomp
     SUBDIR += libmspack
     SUBDIR += libunrar
+    SUBDIR += libzip
     SUBDIR += linux-unace
     SUBDIR += lzma
     SUBDIR += lzo
diff --git a/archivers/libzip/Makefile b/archivers/libzip/Makefile
new file mode 100644
index 000000000000..5aa216181c87
--- /dev/null
+++ b/archivers/libzip/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for:	libzip
+# Date created:		2006-03-20
+# Whom:			Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	libzip
+PORTVERSION=	0.6.1
+CATEGORIES=	archivers devel
+MASTER_SITES=	http://www.nih.at/libzip/
+
+MAINTAINER=	zaa@zaa.pp.ru
+COMMENT=	A C library for reading, creating, and modifying zip archives
+
+GNU_CONFIGURE=	yes
+INSTALLS_SHLIB=	yes
+USE_GNOME=	gnomehack pkgconfig
+
+PLIST_FILES=	bin/zipcmp \
+		bin/zipmerge \
+		include/zip.h \
+		lib/libzip.a \
+		lib/libzip.la \
+		lib/libzip.so \
+		lib/libzip.so.0 \
+		libdata/pkgconfig/libzip.pc
+
+MAN1=		zipcmp.1 \
+		zipmerge.1
+
+MAN3=		libzip.3 \
+		zip_add.3 \
+		zip_close.3 \
+		zip_delete.3 \
+		zip_error_get.3 \
+		zip_error_get_sys_type.3 \
+		zip_error_to_str.3 \
+		zip_errors.3 \
+		zip_fclose.3 \
+		zip_file_error_get.3 \
+		zip_file_strerror.3 \
+		zip_fopen.3 \
+		zip_fopen_index.3 \
+		zip_fread.3 \
+		zip_get_name.3 \
+		zip_get_num_files.3 \
+		zip_name_locate.3 \
+		zip_open.3 \
+		zip_rename.3 \
+		zip_replace.3 \
+		zip_source_buffer.3 \
+		zip_source_file.3 \
+		zip_source_filep.3 \
+		zip_source_free.3 \
+		zip_source_function.3 \
+		zip_source_zip.3 \
+		zip_stat.3 \
+		zip_stat_index.3 \
+		zip_strerror.3 \
+		zip_unchange.3 \
+		zip_unchange_all.3
+
+.include <bsd.port.mk>
diff --git a/archivers/libzip/distinfo b/archivers/libzip/distinfo
new file mode 100644
index 000000000000..de2adf767af5
--- /dev/null
+++ b/archivers/libzip/distinfo
@@ -0,0 +1,3 @@
+MD5 (libzip-0.6.1.tar.gz) = 06b0d48a20a09125085e0856d8f14cff
+SHA256 (libzip-0.6.1.tar.gz) = 5b83539da91db285de99b650f41d9a6c0f298858184f7fcdf6cec1c8f5b995e6
+SIZE (libzip-0.6.1.tar.gz) = 383716
diff --git a/archivers/libzip/files/patch-man_Makefile.in b/archivers/libzip/files/patch-man_Makefile.in
new file mode 100644
index 000000000000..c550e6674a72
--- /dev/null
+++ b/archivers/libzip/files/patch-man_Makefile.in
@@ -0,0 +1,13 @@
+--- man/Makefile.in.orig	Tue Mar 21 17:21:15 2006
++++ man/Makefile.in	Tue Mar 21 17:21:45 2006
+@@ -149,8 +149,8 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-man1_MANS = ${MAN1:.mdoc=.${MANFMT}}
+-man3_MANS = ${MAN3:.mdoc=.${MANFMT}}
++man1_MANS = ${MAN1}
++man3_MANS = ${MAN3}
+ DISTCLEANFILES = ${HTML}
+ EXTRA_DIST = ${MANDOC} ${MAN}
+ MAN1 = zipcmp.mdoc zipmerge.mdoc
diff --git a/archivers/libzip/pkg-descr b/archivers/libzip/pkg-descr
new file mode 100644
index 000000000000..6925f7b1c6e5
--- /dev/null
+++ b/archivers/libzip/pkg-descr
@@ -0,0 +1,6 @@
+libzip is a C library for reading, creating, and modifying zip archives. Files
+can be added from data buffers, files, or compressed data copied directly from
+other zip archives. Changes made without closing the archive can be reverted.
+The API is documented by man pages.
+
+WWW: http://www.nih.at/libzip/
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0