From e3523c8b9990b2ac6007fe63307f54b2811dd552 Mon Sep 17 00:00:00 2001
From: Cheng-Lung Sung <clsung@FreeBSD.org>
Date: Wed, 15 Aug 2007 02:59:26 +0000
Subject: Handling messages to users can be a hassle, certainly when the same
 module is used for command-line and in a graphical interfaces, and has to
 cope with internationalization at the same time; this set of modules tries to
 simplify this. Log::Report combines gettext features with Log::Dispatch-like
 features. However, you can also use this module to do only translations or
 only message dispatching.

WWW:	http://search.cpan.org/dist/Log-Report/

PR:		ports/115504
Submitted by:	Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
---
 devel/Makefile                |  1 +
 devel/p5-Log-Report/Makefile  | 34 ++++++++++++++++++++++++++
 devel/p5-Log-Report/distinfo  |  3 +++
 devel/p5-Log-Report/pkg-descr |  8 +++++++
 devel/p5-Log-Report/pkg-plist | 55 +++++++++++++++++++++++++++++++++++++++++++
 5 files changed, 101 insertions(+)
 create mode 100644 devel/p5-Log-Report/Makefile
 create mode 100644 devel/p5-Log-Report/distinfo
 create mode 100644 devel/p5-Log-Report/pkg-descr
 create mode 100644 devel/p5-Log-Report/pkg-plist

diff --git a/devel/Makefile b/devel/Makefile
index d4f0025b5a21..0b481c7b37a8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1309,6 +1309,7 @@
     SUBDIR += p5-Log-Log4perl
     SUBDIR += p5-Log-Message
     SUBDIR += p5-Log-Message-Simple
+    SUBDIR += p5-Log-Report
     SUBDIR += p5-Log-Simple
     SUBDIR += p5-Log-Trace
     SUBDIR += p5-Log-TraceMessages
diff --git a/devel/p5-Log-Report/Makefile b/devel/p5-Log-Report/Makefile
new file mode 100644
index 000000000000..458eb4a5df65
--- /dev/null
+++ b/devel/p5-Log-Report/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for:	p5-Log-Report
+# Date created:		2007-08-14
+# Whom:			Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	Log-Report
+PORTVERSION=	0.09
+CATEGORIES=	devel perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=	../by-authors/id/M/MA/MARKOV
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	tjs@cdpa.nsysu.edu.tw
+COMMENT=	Report a problem, pluggable handlers and language support
+
+PERL_CONFIGURE=	yes
+
+MAN3=	Log::Report.3 Log::Report::Die.3 \
+	Log::Report::Dispatcher.3 Log::Report::Dispatcher::File.3 \
+	Log::Report::Dispatcher::Log4perl.3 \
+	Log::Report::Dispatcher::LogDispatch.3 \
+	Log::Report::Dispatcher::Perl.3 \
+	Log::Report::Dispatcher::Syslog.3 \
+	Log::Report::Dispatcher::Try.3 \
+	Log::Report::Exception.3 Log::Report::Extract::PerlPPI.3 \
+	Log::Report::Lexicon::Index.3 Log::Report::Lexicon::PO.3 \
+	Log::Report::Lexicon::POT.3 Log::Report::Lexicon::POTcompact.3 \
+	Log::Report::Message.3 Log::Report::Translator.3 \
+	Log::Report::Translator::Gettext.3 \
+	Log::Report::Translator::POT.3 Log::Report::Util.3 \
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Report/distinfo b/devel/p5-Log-Report/distinfo
new file mode 100644
index 000000000000..2d512a25c4f0
--- /dev/null
+++ b/devel/p5-Log-Report/distinfo
@@ -0,0 +1,3 @@
+MD5 (Log-Report-0.09.tar.gz) = f3760717fef97f2ff2be01f72c6c6817
+SHA256 (Log-Report-0.09.tar.gz) = 4a382f5bba0498491194ff0267f607fe5d7a351263824f665b25fb20296c0c2c
+SIZE (Log-Report-0.09.tar.gz) = 72295
diff --git a/devel/p5-Log-Report/pkg-descr b/devel/p5-Log-Report/pkg-descr
new file mode 100644
index 000000000000..867d463d1cf5
--- /dev/null
+++ b/devel/p5-Log-Report/pkg-descr
@@ -0,0 +1,8 @@
+Handling messages to users can be a hassle, certainly when the same module is
+used for command-line and in a graphical interfaces, and has to cope with
+internationalization at the same time; this set of modules tries to simplify
+this. Log::Report combines gettext features with Log::Dispatch-like features.
+However, you can also use this module to do only translations or only message
+dispatching.
+
+WWW:	http://search.cpan.org/dist/Log-Report/
diff --git a/devel/p5-Log-Report/pkg-plist b/devel/p5-Log-Report/pkg-plist
new file mode 100644
index 000000000000..e8c263dd05df
--- /dev/null
+++ b/devel/p5-Log-Report/pkg-plist
@@ -0,0 +1,55 @@
+@comment $FreeBSD$
+bin/xgettext-perl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Report/.packlist
+%%SITE_PERL%%/Log/Report.pm
+%%SITE_PERL%%/Log/Report.pod
+%%SITE_PERL%%/Log/Report/Die.pm
+%%SITE_PERL%%/Log/Report/Die.pod
+%%SITE_PERL%%/Log/Report/Dispatcher.pm
+%%SITE_PERL%%/Log/Report/Dispatcher.pod
+%%SITE_PERL%%/Log/Report/Dispatcher/File.pm
+%%SITE_PERL%%/Log/Report/Dispatcher/File.pod
+%%SITE_PERL%%/Log/Report/Dispatcher/Log4perl.pm
+%%SITE_PERL%%/Log/Report/Dispatcher/Log4perl.pod
+%%SITE_PERL%%/Log/Report/Dispatcher/LogDispatch.pm
+%%SITE_PERL%%/Log/Report/Dispatcher/LogDispatch.pod
+%%SITE_PERL%%/Log/Report/Dispatcher/Perl.pm
+%%SITE_PERL%%/Log/Report/Dispatcher/Perl.pod
+%%SITE_PERL%%/Log/Report/Dispatcher/Syslog.pm
+%%SITE_PERL%%/Log/Report/Dispatcher/Syslog.pod
+%%SITE_PERL%%/Log/Report/Dispatcher/Try.pm
+%%SITE_PERL%%/Log/Report/Dispatcher/Try.pod
+%%SITE_PERL%%/Log/Report/Exception.pm
+%%SITE_PERL%%/Log/Report/Exception.pod
+%%SITE_PERL%%/Log/Report/Extract/PerlPPI.pm
+%%SITE_PERL%%/Log/Report/Extract/PerlPPI.pod
+%%SITE_PERL%%/Log/Report/Lexicon/Index.pm
+%%SITE_PERL%%/Log/Report/Lexicon/Index.pod
+%%SITE_PERL%%/Log/Report/Lexicon/PO.pm
+%%SITE_PERL%%/Log/Report/Lexicon/PO.pod
+%%SITE_PERL%%/Log/Report/Lexicon/POT.pm
+%%SITE_PERL%%/Log/Report/Lexicon/POT.pod
+%%SITE_PERL%%/Log/Report/Lexicon/POTcompact.pm
+%%SITE_PERL%%/Log/Report/Lexicon/POTcompact.pod
+%%SITE_PERL%%/Log/Report/Message.pm
+%%SITE_PERL%%/Log/Report/Message.pod
+%%SITE_PERL%%/Log/Report/Translator.pm
+%%SITE_PERL%%/Log/Report/Translator.pod
+%%SITE_PERL%%/Log/Report/Translator/Gettext.pm
+%%SITE_PERL%%/Log/Report/Translator/Gettext.pod
+%%SITE_PERL%%/Log/Report/Translator/POT.pm
+%%SITE_PERL%%/Log/Report/Translator/POT.pod
+%%SITE_PERL%%/Log/Report/Util.pm
+%%SITE_PERL%%/Log/Report/Util.pod
+%%SITE_PERL%%/Log/Report/messages/log-report.utf-8.po
+%%SITE_PERL%%/Log/Report/messages/log-report/nl_NL.po
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Report
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log
+@dirrmtry %%SITE_PERL%%/Log/Report/messages/log-report
+@dirrmtry %%SITE_PERL%%/Log/Report/messages
+@dirrmtry %%SITE_PERL%%/Log/Report/Translator
+@dirrmtry %%SITE_PERL%%/Log/Report/Lexicon
+@dirrmtry %%SITE_PERL%%/Log/Report/Extract
+@dirrmtry %%SITE_PERL%%/Log/Report/Dispatcher
+@dirrmtry %%SITE_PERL%%/Log/Report
+@dirrmtry %%SITE_PERL%%/Log
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0