From db8a62a578b122c1fcd376cf9f241a86c3e99c7f Mon Sep 17 00:00:00 2001
From: Brian Feldman <green@FreeBSD.org>
Date: Sat, 20 Nov 1999 03:55:29 +0000
Subject: ARGH! Remember the echo -n ' sshd'.

---
 security/openssh/Makefile  | 2 +-
 security/openssh/pkg-plist | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index d38dabf13a47..b8cba039697a 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -94,7 +94,7 @@ post-install:
 	fi
 .if !exists(${PREFIX}/etc/rc.d/sshd.sh)
 	@${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/sshd.sh
-	@${ECHO} "[ -x ${PREFIX}/sbin/sshd ] && exec ${PREFIX}/sbin/sshd" >> ${PREFIX}/etc/rc.d/sshd.sh
+	@${ECHO} "[ -x ${PREFIX}/sbin/sshd ] && ${PREFIX}/sbin/sshd && echo -n ' sshd'" >> ${PREFIX}/etc/rc.d/sshd.sh
 	@${CHMOD} 0555 ${PREFIX}/etc/rc.d/sshd.sh
 .endif
 
diff --git a/security/openssh/pkg-plist b/security/openssh/pkg-plist
index 4d10a5382c24..7b7bd3ce014a 100644
--- a/security/openssh/pkg-plist
+++ b/security/openssh/pkg-plist
@@ -16,4 +16,4 @@ man/man1/ssh.1.gz
 man/man8/sshd.8.gz
 sbin/sshd
 @exec if [ ! -f %D/etc/ssh_host_key ]; then echo ">> Generating a secret host key."; %D/bin/ssh-keygen -N "" -f %D/etc/ssh_host_key; fi
-@exec if [ ! -x %D/etc/rc.d/sshd.sh ]; then echo "#!/bin/sh" > %D/etc/rc.d/sshd.sh && exec echo "[ -x %D/sbin/sshd ] && exec %D/sbin/sshd" >> %D/etc/rc.d/sshd.sh && exec chmod 0555 %D/etc/rc.d/sshd.sh; fi
+@exec if [ ! -x %D/etc/rc.d/sshd.sh ]; then echo "#!/bin/sh" > %D/etc/rc.d/sshd.sh && exec echo "[ -x %D/sbin/sshd ] && %D/sbin/sshd && echo -n ' sshd'" >> %D/etc/rc.d/sshd.sh && exec chmod 0555 %D/etc/rc.d/sshd.sh; fi
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0