From d9d156e61da5e9223ca4794eb9ec7f68e5dc21dd Mon Sep 17 00:00:00 2001
From: Steve Price <steve@FreeBSD.org>
Date: Sun, 4 Jul 1999 21:16:07 +0000
Subject: Fix build for ELF.

---
 korean/pine/files/Makefile | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/korean/pine/files/Makefile b/korean/pine/files/Makefile
index 2874cc1f71e7..eed2de22fbc4 100644
--- a/korean/pine/files/Makefile
+++ b/korean/pine/files/Makefile
@@ -1,7 +1,14 @@
+.if ${PORTOBJFORMAT} == "elf"
+SHLIB=	libpico.so.1
+.else
+SHLIB=	libpico.so.1.3
+.endif
+
 all:
 	./build bsf
 install:
-	install -c -o ${LIBOWN} -g ${LIBGRP} -m ${LIBMODE} bin/libpico.so.1.3 ${PREFIX}/lib/libpico.so.1.3
+	install -c -o ${LIBOWN} -g ${LIBGRP} -m ${LIBMODE} pico/${SHLIB} ${PREFIX}/lib
+	ln -sf ${SHLIB} ${PREFIX}/lib/libpico.so
 	/sbin/ldconfig -m ${PREFIX}/lib
 	install -c -s -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} bin/pico ${PREFIX}/bin/pico
 	install -c -s -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} bin/pilot ${PREFIX}/bin/pilot
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0