From b678d6f47b8aa1284176cf8481443b105520b128 Mon Sep 17 00:00:00 2001
From: Will Andrews <will@FreeBSD.org>
Date: Thu, 4 Jan 2001 00:10:30 +0000
Subject: Add p5-Search-Binary 0.95, perl module that implements a generic
 binary search algorithm.

PR:		24029
Submitted by:	Anton Berezin <tobez@tobez.org>
---
 devel/Makefile                     |  1 +
 devel/p5-Search-Binary/Makefile    | 26 ++++++++++++++++++++++++++
 devel/p5-Search-Binary/distinfo    |  1 +
 devel/p5-Search-Binary/pkg-comment |  1 +
 devel/p5-Search-Binary/pkg-descr   |  9 +++++++++
 devel/p5-Search-Binary/pkg-plist   |  5 +++++
 6 files changed, 43 insertions(+)
 create mode 100644 devel/p5-Search-Binary/Makefile
 create mode 100644 devel/p5-Search-Binary/distinfo
 create mode 100644 devel/p5-Search-Binary/pkg-comment
 create mode 100644 devel/p5-Search-Binary/pkg-descr
 create mode 100644 devel/p5-Search-Binary/pkg-plist

diff --git a/devel/Makefile b/devel/Makefile
index 7cd5c5335d46..dc4ead798313 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -269,6 +269,7 @@
     SUBDIR += p5-ReadLine-Perl
     SUBDIR += p5-Religion
     SUBDIR += p5-Resources
+    SUBDIR += p5-Search-Binary
     SUBDIR += p5-Server-FastPL
     SUBDIR += p5-Set-NestedGroups
     SUBDIR += p5-Set-Object
diff --git a/devel/p5-Search-Binary/Makefile b/devel/p5-Search-Binary/Makefile
new file mode 100644
index 000000000000..766927c58402
--- /dev/null
+++ b/devel/p5-Search-Binary/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for:	devel/p5-Search-Binary
+# Date created:				03 January 2001
+# Whom:					Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	Search-Binary
+PORTVERSION=	0.95
+CATEGORIES=	devel perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=	Search
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	tobez@tobez.org
+
+USE_PERL5=	yes
+PERL_CONFIGURE=	yes
+
+MAN3=		Search::Binary.3
+MANPREFIX=	${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+	@${PERL} -pi -e 's|Seach|Search|' ${WRKSRC}/Binary.pm
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Search-Binary/distinfo b/devel/p5-Search-Binary/distinfo
new file mode 100644
index 000000000000..ddec90a6c2b6
--- /dev/null
+++ b/devel/p5-Search-Binary/distinfo
@@ -0,0 +1 @@
+MD5 (Search-Binary-0.95.tar.gz) = b75a99c0dedd05cb455686fc547cc78f
diff --git a/devel/p5-Search-Binary/pkg-comment b/devel/p5-Search-Binary/pkg-comment
new file mode 100644
index 000000000000..125b664ebf7e
--- /dev/null
+++ b/devel/p5-Search-Binary/pkg-comment
@@ -0,0 +1 @@
+Perl module that implements a generic binary search algorithm
diff --git a/devel/p5-Search-Binary/pkg-descr b/devel/p5-Search-Binary/pkg-descr
new file mode 100644
index 000000000000..3a8c2cb815d2
--- /dev/null
+++ b/devel/p5-Search-Binary/pkg-descr
@@ -0,0 +1,9 @@
+Binary_search implements a generic binary search algorithm returning the
+position of the first record whose index value is greater than or equal
+to $val. The search routine does not define any of the terms position,
+record or index value, but leaves their interpretation and
+implementation to the user supplied function &$read(). The only
+restriction is that positions must be integer scalars.
+
+-Anton
+<tobez@tobez.org>
diff --git a/devel/p5-Search-Binary/pkg-plist b/devel/p5-Search-Binary/pkg-plist
new file mode 100644
index 000000000000..6eff989a0ab6
--- /dev/null
+++ b/devel/p5-Search-Binary/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search/Binary/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Search/Binary.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search/Binary
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Search 2>/dev/null || true
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0