From 93e420afe5e0cb510cb65c366a750548a5871a21 Mon Sep 17 00:00:00 2001
From: Rong-En Fan <rafan@FreeBSD.org>
Date: Sun, 27 Nov 2011 11:40:25 +0000
Subject: - Added metrics for clapf and postscreen

PR:		ports/162679
Submitted by:	Geoffroy Desvernay <dgeo at centrale-marseille.fr>
Obtained from:	http://lists.ee.ethz.ch/mailgraph/msg00413.html
Feature safe:	yes
---
 mail/mailgraph/Makefile                 |  2 +-
 mail/mailgraph/files/patch-mailgraph.pl | 28 ++++++++++++++++++++++++++++
 2 files changed, 29 insertions(+), 1 deletion(-)
 create mode 100644 mail/mailgraph/files/patch-mailgraph.pl

diff --git a/mail/mailgraph/Makefile b/mail/mailgraph/Makefile
index 6d869aa71a7f..9f1a897242cb 100644
--- a/mail/mailgraph/Makefile
+++ b/mail/mailgraph/Makefile
@@ -7,7 +7,7 @@
 
 PORTNAME=	mailgraph
 PORTVERSION=	1.14
-PORTREVISION=	3
+PORTREVISION=	4
 CATEGORIES=	mail
 MASTER_SITES=	http://mailgraph.schweikert.ch/pub/ \
 		http://mailgraph.schweikert.ch/pub/old/
diff --git a/mail/mailgraph/files/patch-mailgraph.pl b/mail/mailgraph/files/patch-mailgraph.pl
new file mode 100644
index 000000000000..4aed38964513
--- /dev/null
+++ b/mail/mailgraph/files/patch-mailgraph.pl
@@ -0,0 +1,28 @@
+--- mailgraph.pl.orig	2011-11-19 17:58:21.000000000 +0100
++++ mailgraph.pl	2011-11-19 18:01:09.000000000 +0100
+@@ -632,6 +632,13 @@
+ 				event($time, 'rejected');
+ 			}
+ 		}
++		elsif($prog eq 'postscreen')
++		{
++			if($text =~ /NOQUEUE: reject:/)
++			{
++				event($time, 'rejected');
++			}
++		}
+ 	}
+ 	elsif($prog eq 'sendmail' or $prog eq 'sm-mta') {
+ 		if($text =~ /\bmailer=local\b/ ) {
+@@ -853,6 +860,11 @@
+ 			event($time, 'virus');
+ 		}
+ 	}
++	elsif($prog eq 'clapf') {
++		if($text =~ /SPAM/) {
++			event($time, 'spam');
++		}
++	}
+ }
+ 
+ sub event($$)
\ No newline at end of file
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0