From 8bc8bafa2c32e55e3be39e1fe1e8275a2233281c Mon Sep 17 00:00:00 2001
From: Dmitry Marakasov <amdmi3@FreeBSD.org>
Date: Thu, 3 Dec 2015 11:26:36 +0000
Subject: Python native client for the obelisk blockchain server.

WWW: https://github.com/darkwallet/python-obelisk

PR:		201392
Submitted by:	yuri@rawbw.com
---
 finance/Makefile                    |  1 +
 finance/py-python-obelisk/Makefile  | 24 ++++++++++++++++++++++++
 finance/py-python-obelisk/distinfo  |  2 ++
 finance/py-python-obelisk/pkg-descr |  3 +++
 4 files changed, 30 insertions(+)
 create mode 100644 finance/py-python-obelisk/Makefile
 create mode 100644 finance/py-python-obelisk/distinfo
 create mode 100644 finance/py-python-obelisk/pkg-descr

diff --git a/finance/Makefile b/finance/Makefile
index a9f74e385ef4..c33501b70ce2 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -93,6 +93,7 @@
     SUBDIR += php-tclink
     SUBDIR += prestashop
     SUBDIR += py-bitcoin
+    SUBDIR += py-python-obelisk
     SUBDIR += py-stripe
     SUBDIR += py-vatnumber
     SUBDIR += py-ystockquote
diff --git a/finance/py-python-obelisk/Makefile b/finance/py-python-obelisk/Makefile
new file mode 100644
index 000000000000..a5b951a4d019
--- /dev/null
+++ b/finance/py-python-obelisk/Makefile
@@ -0,0 +1,24 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME=	python-obelisk
+PORTVERSION=	0.1.3
+CATEGORIES=	finance python
+MASTER_SITES=	CHEESESHOP
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER=	yuri@rawbw.com
+COMMENT=	Python native client for the obelisk blockchain server
+
+LICENSE=	AGPLv3
+LICENSE_FILE=	${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}twistedCore>0:${PORTSDIR}/devel/py-twistedCore \
+		${PYTHON_PKGNAMEPREFIX}ecdsa>0:${PORTSDIR}/security/py-ecdsa \
+		${PYTHON_PKGNAMEPREFIX}pyzmq>=14.5.0:${PORTSDIR}/net/py-pyzmq
+
+USES=		python
+USE_PYTHON=	autoplist distutils
+NO_ARCH=	yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-python-obelisk/distinfo b/finance/py-python-obelisk/distinfo
new file mode 100644
index 000000000000..e4c6deb5a0ff
--- /dev/null
+++ b/finance/py-python-obelisk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-obelisk-0.1.3.tar.gz) = 892de2a53cdd64c8611c0ca9e7538f55c6a4492202f14a1c2650a55bdad449a9
+SIZE (python-obelisk-0.1.3.tar.gz) = 38716
diff --git a/finance/py-python-obelisk/pkg-descr b/finance/py-python-obelisk/pkg-descr
new file mode 100644
index 000000000000..36e3242a404a
--- /dev/null
+++ b/finance/py-python-obelisk/pkg-descr
@@ -0,0 +1,3 @@
+Python native client for the obelisk blockchain server.
+
+WWW: https://github.com/darkwallet/python-obelisk
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0