From 8af40027a956f5793e467a881e9420bb8b9b65eb Mon Sep 17 00:00:00 2001
From: Jan Beich <jbeich@FreeBSD.org>
Date: Tue, 24 Nov 2015 04:08:55 +0000
Subject: graphics/gtk-update-icon-cache: restore r297047 after r313633

- Invoke pkg-config(1) instead of checking manually [1]
- Convert to ECHO_MSG which can be silenced

PR:		166279
Reported by:	mi (via mail on gnome@ list)
Approved by:	gnome (kwm)
Submitted by:	John Hein <jh-fbml@snkmail.com> [1]
Differential Revision:	https://reviews.freebsd.org/D4260
---
 graphics/gtk-update-icon-cache/Makefile | 13 ++++++-------
 x11-toolkits/gtk20/Makefile             | 11 +++++------
 x11-toolkits/gtk30/Makefile             | 10 +++++-----
 3 files changed, 16 insertions(+), 18 deletions(-)

diff --git a/graphics/gtk-update-icon-cache/Makefile b/graphics/gtk-update-icon-cache/Makefile
index a1a8d95259cd..8def708930c9 100644
--- a/graphics/gtk-update-icon-cache/Makefile
+++ b/graphics/gtk-update-icon-cache/Makefile
@@ -36,17 +36,16 @@ ALL_TARGET=	${PORTNAME}
 PLIST_FILES=	bin/gtk-update-icon-cache
 #		man/man1/gtk-update-icon-cache.1.gz
 
-.include <bsd.port.pre.mk>
-
 post-patch:
 	@${REINPLACE_CMD} -e 's|-DGDK_PIXBUF_DISABLE_DEPRECATED||g' \
 		${WRKSRC}/configure
 
 pre-configure:
-.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
-	@${ECHO_CMD} "${PKGNAME}: Needs cairo with X11 support enabled."
-	@${FALSE}
-.endif
+# .if !exists() evaluates too early before cairo has a chance to be installed
+	@if ! pkg-config --exists cairo-xlib; then \
+		${ECHO_MSG} "${PKGNAME}: Needs cairo with X11 support enabled."; \
+		${FALSE}; \
+	fi
 
 do-install:
 	@${INSTALL_PROGRAM} ${WRKSRC}/gtk/gtk-update-icon-cache \
@@ -54,4 +53,4 @@ do-install:
 #	@${INSTALL_MAN} ${WRKSRC}/docs/reference/gtk/gtk-update-icon-cache.1 \
 #		${STAGEDIR}${PREFIX}/man/man1/
 
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index e2c42bd8c16a..9e5f6d624246 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -47,8 +47,6 @@ CUPS_CONFIGURE_ON=	--enable-cups=auto
 CUPS_CONFIGURE_OFF=	--disable-cups
 DEBUG_CONFIGURE_ON=	--enable-debug=yes
 
-.include <bsd.port.options.mk>
-
 PLIST_SUB+=	LIBGAILVER=18.0.1 LIBGVER=0.2400.28
 
 post-patch:
@@ -58,10 +56,11 @@ post-patch:
 		${WRKSRC}/gtk/Makefile.in
 
 pre-configure:
-.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
-	@${ECHO_CMD} "${PKGNAME}: Needs cairo with X11 support enabled."
-	@${FALSE}
-.endif
+# .if !exists() evaluates too early before cairo has a chance to be installed
+	@if ! pkg-config --exists cairo-xlib; then \
+		${ECHO_MSG} "${PKGNAME}: Needs cairo with X11 support enabled."; \
+		${FALSE}; \
+	fi
 
 post-install:
 	@${MKDIR} ${STAGEDIR}${PREFIX}/lib/gtk-2.0/modules
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index b28f6ff42059..b2fde00a2a7f 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -79,7 +79,6 @@ DEBUG_CONFIGURE_ENABLE=debug
 # GTK+ 3.17 has a beter way
 TYPEAHEAD_DESC=		Re-enable type-a-head functionality in file chooser
 
-# needed for the exists() check, booo
 .include <bsd.port.options.mk>
 
 .if ${PORT_OPTIONS:MTYPEAHEAD}
@@ -94,10 +93,11 @@ post-patch:
 		${WRKSRC}/gtk/Makefile.in
 
 pre-configure:
-.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
-	@${ECHO_CMD} "${PKGNAME}: Needs cairo with X11 support enabled."
-	@${FALSE}
-.endif
+# .if !exists() evaluates too early before cairo has a chance to be installed
+	@if ! pkg-config --exists cairo-xlib; then \
+		${ECHO_MSG} "${PKGNAME}: Needs cairo with X11 support enabled."; \
+		${FALSE}; \
+	fi
 
 pre-build:
 	@${RM} -rf ${WRKSRC}/docs/gtk.info*
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0