From 8640099a715c84fd3226c8555a0271f83958045f Mon Sep 17 00:00:00 2001
From: Rong-En Fan <rafan@FreeBSD.org>
Date: Sat, 14 Jul 2007 17:03:00 +0000
Subject: elfrc is a utility that is able to compile resources (files) to
 object files. It can also generate corresponding C/C++ header files to use
 these resources from within a linked application.

WWW: http://ktown.kde.org/~frerich/elfrc.html

PR:		ports/114555
Submitted by:	Ed Schouten <ed at fxq.nl>
---
 devel/Makefile        |  1 +
 devel/elfrc/Makefile  | 36 ++++++++++++++++++++++++++++++++++++
 devel/elfrc/distinfo  |  3 +++
 devel/elfrc/pkg-descr |  5 +++++
 4 files changed, 45 insertions(+)
 create mode 100644 devel/elfrc/Makefile
 create mode 100644 devel/elfrc/distinfo
 create mode 100644 devel/elfrc/pkg-descr

diff --git a/devel/Makefile b/devel/Makefile
index 17f267fc3ecf..f4414270af20 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -272,6 +272,7 @@
     SUBDIR += eiffelstudio
     SUBDIR += elf
     SUBDIR += elfio
+    SUBDIR += elfrc
     SUBDIR += elfsh
     SUBDIR += elftoaout
     SUBDIR += elib
diff --git a/devel/elfrc/Makefile b/devel/elfrc/Makefile
new file mode 100644
index 000000000000..e86428ea9518
--- /dev/null
+++ b/devel/elfrc/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for:	elfrc
+# Date created:				13 July 2007
+# Whom:					Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	elfrc
+PORTVERSION=	0.7
+CATEGORIES=	devel
+MASTER_SITES=	http://ktown.kde.org/~frerich/
+
+MAINTAINER=	ed@fxq.nl
+COMMENT=	Resource compiler for ELF systems
+
+PLIST_FILES=	bin/elfrc
+PORTDOCS=	README
+
+do-build:
+	@${ECHO} '#define ELFRC_VERSION "${PORTVERSION}"' > ${WRKSRC}/config.h
+	${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/elfrc ${WRKSRC}/elfrc.c
+
+do-install:
+	${INSTALL_PROGRAM} ${WRKSRC}/elfrc ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+	${MKDIR} ${DOCSDIR}
+	${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE=		lack of ELF definitions (STV_DEFAULT) on FreeBSD < 6.0
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/elfrc/distinfo b/devel/elfrc/distinfo
new file mode 100644
index 000000000000..4b9f80b0f436
--- /dev/null
+++ b/devel/elfrc/distinfo
@@ -0,0 +1,3 @@
+MD5 (elfrc-0.7.tar.gz) = 397c26285bd153808d651fd2877e2ed7
+SHA256 (elfrc-0.7.tar.gz) = 4d3a33aed7655040148192b8e9ca9eabb1e64e410341e31ef21a50c5064351b4
+SIZE (elfrc-0.7.tar.gz) = 8433
diff --git a/devel/elfrc/pkg-descr b/devel/elfrc/pkg-descr
new file mode 100644
index 000000000000..99b7d7fe0e17
--- /dev/null
+++ b/devel/elfrc/pkg-descr
@@ -0,0 +1,5 @@
+elfrc is a utility that is able to compile resources (files) to object
+files. It can also generate corresponding C/C++ header files to use
+these resources from within a linked application.
+ 
+WWW: http://ktown.kde.org/~frerich/elfrc.html
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0