From 835d05fd2c1896ac0deb3224422e505b26fc3af9 Mon Sep 17 00:00:00 2001
From: Ruslan Makhmatkhanov <rm@FreeBSD.org>
Date: Fri, 25 Sep 2015 18:35:14 +0000
Subject: Simple and quick FastQ and FastA tool for file reading and
 conversion.

WWW: https://github.com/fstrozzi/Fastool

PR:		203293
Submitted by:	Jason Bacon <jwbacon@tds.net>
---
 biology/Makefile          |  1 +
 biology/fastool/Makefile  | 33 +++++++++++++++++++++++++++++++++
 biology/fastool/distinfo  |  2 ++
 biology/fastool/pkg-descr |  3 +++
 4 files changed, 39 insertions(+)
 create mode 100644 biology/fastool/Makefile
 create mode 100644 biology/fastool/distinfo
 create mode 100644 biology/fastool/pkg-descr

diff --git a/biology/Makefile b/biology/Makefile
index 7572974676a5..f2a488fce7e8 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -20,6 +20,7 @@
     SUBDIR += fasta
     SUBDIR += fasta3
     SUBDIR += fastdnaml
+    SUBDIR += fastool
     SUBDIR += fasttree
     SUBDIR += fastx-toolkit
     SUBDIR += fluctuate
diff --git a/biology/fastool/Makefile b/biology/fastool/Makefile
new file mode 100644
index 000000000000..0f1905040eed
--- /dev/null
+++ b/biology/fastool/Makefile
@@ -0,0 +1,33 @@
+# Created by: Jason Bacon <jwbacon@tds.net>
+# $FreeBSD$
+
+PORTNAME=	fastool
+PORTVERSION=	0.1.4
+CATEGORIES=	biology
+
+MAINTAINER=	jwbacon@tds.net
+COMMENT=	Simple and quick FastQ and FastA tool for file reading and conversion
+
+LICENSE=	BSD2CLAUSE
+
+USE_GITHUB=	yes
+GH_ACCOUNT=	fstrozzi
+GH_PROJECT=	Fastool
+
+WRKSRC=		${WRKDIR}/Fastool-${PORTVERSION}
+
+PLIST_FILES=	bin/fastool
+
+CFLAGS+=	-std=c99
+
+post-patch:
+	${REINPLACE_CMD} \
+		-e 's|CC *=|CC ?=|g' \
+		-e 's|CFLAGS *=|CFLAGS ?=|g' \
+		${WRKSRC}/Makefile
+
+do-install:
+	${INSTALL_PROGRAM} ${WRKSRC}/fastool \
+		${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/fastool/distinfo b/biology/fastool/distinfo
new file mode 100644
index 000000000000..5c9c4b1cd304
--- /dev/null
+++ b/biology/fastool/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fstrozzi-Fastool-0.1.4_GH0.tar.gz) = f86f02fced9479b77d6d27a442b66e66f0c55d40d5ad2ddd91a752de57024540
+SIZE (fstrozzi-Fastool-0.1.4_GH0.tar.gz) = 6346
diff --git a/biology/fastool/pkg-descr b/biology/fastool/pkg-descr
new file mode 100644
index 000000000000..7743c2a7a44f
--- /dev/null
+++ b/biology/fastool/pkg-descr
@@ -0,0 +1,3 @@
+Simple and quick FastQ and FastA tool for file reading and conversion.
+
+WWW: https://github.com/fstrozzi/Fastool
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0