From 78b6d3b86ec2285a52d33c3186629af12ccbe050 Mon Sep 17 00:00:00 2001
From: Kris Kennaway <kris@FreeBSD.org>
Date: Sun, 7 Mar 2004 05:57:31 +0000
Subject: BROKEN on alpha 5.x: Does not compile

---
 games/heroes/Makefile     | 8 +++++++-
 print/kaspaliste/Makefile | 8 +++++++-
 2 files changed, 14 insertions(+), 2 deletions(-)

diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 9b3de82b2048..004a565695e9 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -49,6 +49,12 @@ INFO=		heroes
 CPPFLAGS=	-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
 LDFLAGS=	-L${LOCALBASE}/lib -lsmpeg ${PTHREAD_LIBS}
 
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+BROKEN=		"Does not compile on alpha >=5.x"
+.endif
+
 post-patch:
 	@for dir in ${DATASRC} ${SOUNDSRC} ${MUSICSRC}; do \
 		${FIND} $${dir} -name "Makefile*" | ${XARGS} ${RM}; \
@@ -66,4 +72,4 @@ post-install:
 	${MKDIR} ${DATADIR}/mod
 	${INSTALL_DATA} ${MUSICSRC}/*.xm ${MUSICSRC}/sound.conf ${DATADIR}/mod
 
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/print/kaspaliste/Makefile b/print/kaspaliste/Makefile
index 202bdb090444..fd84ab4b9e05 100644
--- a/print/kaspaliste/Makefile
+++ b/print/kaspaliste/Makefile
@@ -26,4 +26,10 @@ CONFIGURE_ARGS+=	--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}	\
 			--with-pg-includes=${LOCALBASE}/include \
 			--with-pg-libs=${LOCALBASE}/lib
 
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+BROKEN=			"Does not compile on alpha >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0