From 69449f36bacf631bbebea052699ba421c4f1ecc5 Mon Sep 17 00:00:00 2001
From: "Andrey A. Chernov" <ache@FreeBSD.org>
Date: Wed, 7 Apr 1999 20:56:04 +0000
Subject: URI interface

---
 net/p5-URI/Makefile    | 31 +++++++++++++++++++++++++++++++
 net/p5-URI/distinfo    |  1 +
 net/p5-URI/pkg-comment |  1 +
 net/p5-URI/pkg-descr   | 35 +++++++++++++++++++++++++++++++++++
 net/p5-URI/pkg-plist   | 33 +++++++++++++++++++++++++++++++++
 5 files changed, 101 insertions(+)
 create mode 100644 net/p5-URI/Makefile
 create mode 100644 net/p5-URI/distinfo
 create mode 100644 net/p5-URI/pkg-comment
 create mode 100644 net/p5-URI/pkg-descr
 create mode 100644 net/p5-URI/pkg-plist

diff --git a/net/p5-URI/Makefile b/net/p5-URI/Makefile
new file mode 100644
index 000000000000..57deb54a5a21
--- /dev/null
+++ b/net/p5-URI/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for:    p5-URI
+# Version required:                     1.*
+#
+# $Id: Makefile,v 1.11 1998/09/15 21:31:52 asami Exp $
+#
+
+DISTNAME=       URI-1.02
+PKGNAME=        p5-URI-1.02
+CATEGORIES=	security perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=     URI
+
+MAINTAINER=     ache@FreeBSD.ORG
+
+USE_PERL5=      YES
+MAN3=   \
+	URI::WithBase.3 \
+	URI::data.3 \
+	URI::file.3 \
+	URI::Heuristic.3 \
+	URI::ldap.3 \
+	URI::Escape.3 \
+	URI.3 \
+	URI::URL.3
+
+MANPREFIX=	${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+		@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/net/p5-URI/distinfo b/net/p5-URI/distinfo
new file mode 100644
index 000000000000..439bda54936a
--- /dev/null
+++ b/net/p5-URI/distinfo
@@ -0,0 +1 @@
+MD5 (URI-1.02.tar.gz) = c2c3909207bb6d61bb70535f17437990
diff --git a/net/p5-URI/pkg-comment b/net/p5-URI/pkg-comment
new file mode 100644
index 000000000000..ca3a2e73126f
--- /dev/null
+++ b/net/p5-URI/pkg-comment
@@ -0,0 +1 @@
+perl5 interface to Uniform Resource Identifier (URI) references
diff --git a/net/p5-URI/pkg-descr b/net/p5-URI/pkg-descr
new file mode 100644
index 000000000000..d53ccbc27eb3
--- /dev/null
+++ b/net/p5-URI/pkg-descr
@@ -0,0 +1,35 @@
+This package contains the URI.pm module with friends.  The module
+implements the URI class.  Objects of this class represent Uniform
+Resource Identifier (URI) references as specified in RFC 2396.
+
+URI objects can be used to access and manipulate the various
+components that make up these strings.  There are also methods to
+combine URIs in various ways.
+
+The URI class replaces the URI::URL class that used to be distributed
+with libwww-perl.  This package contains an emulation of the old
+URI::URL interface.  The emulated URI::URL implements both the old and
+the new interface.
+
+Some tests require an Internet connection to work and are skipped
+if one is not active.
+
+You need perl5.004 or better to install this package.  You should also
+have the MIME::Base64 module installed.  Installation is otherwise as
+usual:
+
+  perl Makefile.PL
+  make
+  make test
+  make install
+
+Questions about how to use this library should be directed to the
+comp.lang.perl.modules USENET Newsgroup.  Bug reports and suggestions
+for improvements can be sent to the <libwww-perl@ics.uci.edu> mailing
+list.
+
+Copyright 1998-1999 Gisle Aas.
+Copyright 1998 Graham Barr.
+
+This library is free software; you can redistribute it and/or
+modify it under the same terms as Perl itself.
diff --git a/net/p5-URI/pkg-plist b/net/p5-URI/pkg-plist
new file mode 100644
index 000000000000..c544f04b53b8
--- /dev/null
+++ b/net/p5-URI/pkg-plist
@@ -0,0 +1,33 @@
+lib/perl5/site_perl/%%PERL_VER%%/URI/_server.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/WithBase.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_login.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/data.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_generic.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/news.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/Mac.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/Win32.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/OS2.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/FAT.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/Unix.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/nntp.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/http.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/ldap.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/gopher.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/mailto.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_foreign.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/ftp.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/rlogin.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/telnet.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/pop.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/snews.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/Heuristic.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/Escape.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_segment.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/URL.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/https.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_userpass.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_query.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/URI
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0