From 64bab3473c14cb385a1a69b26a180275e54eea1b Mon Sep 17 00:00:00 2001
From: Doug Barton <dougb@FreeBSD.org>
Date: Sun, 27 Nov 2005 01:03:06 +0000
Subject: Fix a long-standing problem that appears when users install openssl
 from ports, and do not use the option to have the port version overwrite the
 base version.

Several folks have mentioned this problem in the past, but a
good workaround (and more importantly, solid testing) were
provided by the submitter.

Submitted by:	Uffe Vedenbrant <uffe@vedenbrant.se>
---
 dns/bind9/Makefile  | 8 +++++++-
 dns/bind94/Makefile | 8 +++++++-
 dns/bind95/Makefile | 8 +++++++-
 dns/bind96/Makefile | 8 +++++++-
 4 files changed, 28 insertions(+), 4 deletions(-)

diff --git a/dns/bind9/Makefile b/dns/bind9/Makefile
index 276a8d1bea48..8d1aff2298e5 100644
--- a/dns/bind9/Makefile
+++ b/dns/bind9/Makefile
@@ -28,11 +28,17 @@ COMMENT=	Completely new version of the BIND DNS suite with updated DNSSEC
 ISCVERSION=	9.3.1
 
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps --with-openssl \
+CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps \
 		--with-randomdev=/dev/random
 
 USE_OPENSSL=	yes
 
+.if defined(WITH_OPENSSL_PORT)
+CONFIGURE_ARGS+=	--with-openssl=/usr/local
+.else
+CONFIGURE_ARGS+=	--with-openssl
+.endif
+
 # ISC staff has informed me that for 9.3.x, threads are always a bad idea.
 # Leave the affirmative option for those that want to experiment.
 .if defined(WITH_BIND9_THREADS)
diff --git a/dns/bind94/Makefile b/dns/bind94/Makefile
index 276a8d1bea48..8d1aff2298e5 100644
--- a/dns/bind94/Makefile
+++ b/dns/bind94/Makefile
@@ -28,11 +28,17 @@ COMMENT=	Completely new version of the BIND DNS suite with updated DNSSEC
 ISCVERSION=	9.3.1
 
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps --with-openssl \
+CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps \
 		--with-randomdev=/dev/random
 
 USE_OPENSSL=	yes
 
+.if defined(WITH_OPENSSL_PORT)
+CONFIGURE_ARGS+=	--with-openssl=/usr/local
+.else
+CONFIGURE_ARGS+=	--with-openssl
+.endif
+
 # ISC staff has informed me that for 9.3.x, threads are always a bad idea.
 # Leave the affirmative option for those that want to experiment.
 .if defined(WITH_BIND9_THREADS)
diff --git a/dns/bind95/Makefile b/dns/bind95/Makefile
index 276a8d1bea48..8d1aff2298e5 100644
--- a/dns/bind95/Makefile
+++ b/dns/bind95/Makefile
@@ -28,11 +28,17 @@ COMMENT=	Completely new version of the BIND DNS suite with updated DNSSEC
 ISCVERSION=	9.3.1
 
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps --with-openssl \
+CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps \
 		--with-randomdev=/dev/random
 
 USE_OPENSSL=	yes
 
+.if defined(WITH_OPENSSL_PORT)
+CONFIGURE_ARGS+=	--with-openssl=/usr/local
+.else
+CONFIGURE_ARGS+=	--with-openssl
+.endif
+
 # ISC staff has informed me that for 9.3.x, threads are always a bad idea.
 # Leave the affirmative option for those that want to experiment.
 .if defined(WITH_BIND9_THREADS)
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index 276a8d1bea48..8d1aff2298e5 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -28,11 +28,17 @@ COMMENT=	Completely new version of the BIND DNS suite with updated DNSSEC
 ISCVERSION=	9.3.1
 
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps --with-openssl \
+CONFIGURE_ARGS=	--localstatedir=/var --disable-linux-caps \
 		--with-randomdev=/dev/random
 
 USE_OPENSSL=	yes
 
+.if defined(WITH_OPENSSL_PORT)
+CONFIGURE_ARGS+=	--with-openssl=/usr/local
+.else
+CONFIGURE_ARGS+=	--with-openssl
+.endif
+
 # ISC staff has informed me that for 9.3.x, threads are always a bad idea.
 # Leave the affirmative option for those that want to experiment.
 .if defined(WITH_BIND9_THREADS)
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0