From 64b404dcf388b51aaa08bf52dec00a21074a8e03 Mon Sep 17 00:00:00 2001
From: Munechika SUMIKAWA <sumikawa@FreeBSD.org>
Date: Wed, 12 Jan 2000 19:16:43 +0000
Subject: Support IPv6

Approved by:	maintainer
---
 lang/ruby/Makefile   | 3 +++
 lang/ruby14/Makefile | 3 +++
 lang/ruby16/Makefile | 3 +++
 3 files changed, 9 insertions(+)

diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 596c57a05291..b7f0cb6340a0 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -19,6 +19,9 @@ MAINTAINER=	yasuf@big.or.jp
 
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS+= --enable-shared
+.if defined(USE_INET6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
 MAN1=		ruby.1
 PLIST_SUB+=	RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
 
diff --git a/lang/ruby14/Makefile b/lang/ruby14/Makefile
index 596c57a05291..b7f0cb6340a0 100644
--- a/lang/ruby14/Makefile
+++ b/lang/ruby14/Makefile
@@ -19,6 +19,9 @@ MAINTAINER=	yasuf@big.or.jp
 
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS+= --enable-shared
+.if defined(USE_INET6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
 MAN1=		ruby.1
 PLIST_SUB+=	RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
 
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 596c57a05291..b7f0cb6340a0 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -19,6 +19,9 @@ MAINTAINER=	yasuf@big.or.jp
 
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS+= --enable-shared
+.if defined(USE_INET6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
 MAN1=		ruby.1
 PLIST_SUB+=	RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
 
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0