From 604432fe139d273b0bdcd99f42b7ac1f42dfcb93 Mon Sep 17 00:00:00 2001
From: Maxim Sobolev <sobomax@FreeBSD.org>
Date: Wed, 20 Sep 2000 07:16:53 +0000
Subject: Add sdl_image - a simple library to load images of various formats as
 SDL surfaces.

---
 graphics/Makefile                 |  1 +
 graphics/sdl_image/Makefile       | 38 ++++++++++++++++++++++++++++++++++++++
 graphics/sdl_image/distinfo       |  1 +
 graphics/sdl_image/files/patch-ab | 11 +++++++++++
 graphics/sdl_image/pkg-comment    |  1 +
 graphics/sdl_image/pkg-descr      | 18 ++++++++++++++++++
 graphics/sdl_image/pkg-plist      |  5 +++++
 7 files changed, 75 insertions(+)
 create mode 100644 graphics/sdl_image/Makefile
 create mode 100644 graphics/sdl_image/distinfo
 create mode 100644 graphics/sdl_image/files/patch-ab
 create mode 100644 graphics/sdl_image/pkg-comment
 create mode 100644 graphics/sdl_image/pkg-descr
 create mode 100644 graphics/sdl_image/pkg-plist

diff --git a/graphics/Makefile b/graphics/Makefile
index 416340c01e3c..c7d43611d2ba 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -158,6 +158,7 @@
     SUBDIR += sane
     SUBDIR += sced
     SUBDIR += scwm-icons
+    SUBDIR += sdl_image
     SUBDIR += sketch
     SUBDIR += smpeg
     SUBDIR += sodipodi
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
new file mode 100644
index 000000000000..f3be4f461490
--- /dev/null
+++ b/graphics/sdl_image/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for:	sdl_image
+# Date created:				20 September 2000
+# Whom:					Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	sdl_image
+PORTVERSION=	1.0.9
+CATEGORIES=	graphics
+MASTER_SITES=	http://www.devolution.com/~slouken/SDL/projects/SDL_image/src/
+DISTNAME=	SDL_image-${PORTVERSION}
+
+MAINTAINER=	sobomax@FreeBSD.org
+
+LIB_DEPENDS=	SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
+		png.4:${PORTSDIR}/graphics/png \
+		tiff.4:${PORTSDIR}/graphics/tiff \
+		jpeg.9:${PORTSDIR}/graphics/jpeg
+
+SDL_CONFIG=	${LOCALBASE}/bin/sdl11-config
+
+USE_LIBTOOL=	yes
+USE_GMAKE=	yes
+INSTALLS_SHLIB=	yes
+CONFIGURE_ENV=	SDL_CONFIG="${SDL_CONFIG}" \
+		CPPFLAGS="-I${X11BASE}/include" \
+		LDFLAGS="-L${LOCALBASE}/lib -lm"
+
+post-extract:
+	@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+		's|-release \$$\(LT_RELEASE\)||g'
+
+post-configure:
+	@${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+		${WRKSRC}/libtool
+
+.include <bsd.port.mk>
diff --git a/graphics/sdl_image/distinfo b/graphics/sdl_image/distinfo
new file mode 100644
index 000000000000..9ea88670d623
--- /dev/null
+++ b/graphics/sdl_image/distinfo
@@ -0,0 +1 @@
+MD5 (SDL_image-1.0.9.tar.gz) = 91d8014aacb35605b510443d9c468173
diff --git a/graphics/sdl_image/files/patch-ab b/graphics/sdl_image/files/patch-ab
new file mode 100644
index 000000000000..120401df90d7
--- /dev/null
+++ b/graphics/sdl_image/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.in	2000/09/20 07:05:33	1.1
++++ Makefile.in	2000/09/20 07:06:00
+@@ -89,7 +89,7 @@
+ 
+ lib_LTLIBRARIES = libSDL_image.la
+ 
+-libSDL_imageincludedir = $(includedir)/SDL
++libSDL_imageincludedir = $(includedir)/SDL11
+ libSDL_imageinclude_HEADERS =  	SDL_image.h
+ 
+ 
diff --git a/graphics/sdl_image/pkg-comment b/graphics/sdl_image/pkg-comment
new file mode 100644
index 000000000000..1d3e8c934f99
--- /dev/null
+++ b/graphics/sdl_image/pkg-comment
@@ -0,0 +1 @@
+A simple library to load images of various formats as SDL surfaces
diff --git a/graphics/sdl_image/pkg-descr b/graphics/sdl_image/pkg-descr
new file mode 100644
index 000000000000..2e038f43be37
--- /dev/null
+++ b/graphics/sdl_image/pkg-descr
@@ -0,0 +1,18 @@
+This is a simple library to load images of various formats as SDL surfaces.
+This library supports BMP, PPM, PCX, GIF, JPEG, PNG, TGA, and TIFF formats.
+
+API:
+#include "SDL_image.h"
+
+	SDL_Surface *IMG_Load(const char *file);
+or
+	SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc);
+or
+	SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc, char *type);
+
+where type is a string specifying the format (i.e. "PNG" or "pcx").
+Note that IMG_Load_RW cannot load TGA images.
+
+An example program 'showimage' is included, with source in showimage.c
+
+WWW: http://www.devolution.com/~slouken/SDL/projects/SDL_image/
diff --git a/graphics/sdl_image/pkg-plist b/graphics/sdl_image/pkg-plist
new file mode 100644
index 000000000000..388db1755053
--- /dev/null
+++ b/graphics/sdl_image/pkg-plist
@@ -0,0 +1,5 @@
+bin/showimage
+include/SDL11/SDL_image.h
+lib/libSDL_image.a
+lib/libSDL_image.so
+lib/libSDL_image.so.9
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0