From 57831d4b5d72578eadf6e9b436bc7cf6e29674f0 Mon Sep 17 00:00:00 2001
From: Roman Bogorodskiy <novel@FreeBSD.org>
Date: Tue, 27 Oct 2015 16:59:14 +0000
Subject: audio/deadbeef: fix GUI option handling

The audio/deadbeef port has a GUI radio option that allows to choose between
GTK2 and GTK3 sub-options. Apparently, choosing sub-options does not directly
affect the parent option, for example, choosing GTK2 doesn't turn the GUI
option. As it's used in PLIST_SUB, it could result in a broken package, e.g.
without gui even if GTK2 is enabled.

Fix that by adding appropriate _IMPLIES for sub-options and manually turn
off the parent option if none of sub-options was enabled.

Bump PORTREVISION so users could get a new package with GTK2 UI as it supposed
to be.

PR:		203974
Approved by:	vg (maintainer)
---
 audio/deadbeef/Makefile | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index 76e68ff622ec..bd9480c1f9e6 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -3,7 +3,7 @@
 
 PORTNAME=	deadbeef
 PORTVERSION=	0.6.2
-PORTREVISION=	7
+PORTREVISION=	8
 CATEGORIES=	audio
 MASTER_SITES=	SF/${PORTNAME}/
 
@@ -78,11 +78,13 @@ GTK2_USE=		gnome=gtk20,glib20
 GTK2_CONFIGURE_OFF=	--disable-gtk2
 GTK2_CONFIGURE_ON=	--enable-gtk2
 GTK2_VARS=		GTK_VER=2
+GTK2_IMPLIES=		GUI
 
 GTK3_USE=		gnome=gtk30
 GTK3_CONFIGURE_OFF=	--disable-gtk3
 GTK3_CONFIGURE_ON=	--enable-gtk3
 GTK3_VARS=		GTK_VER=3
+GTK3_IMPLIES=		GUI
 
 PLIST_SUB+=		GTK_VER=${GTK_VER}
 
@@ -183,6 +185,12 @@ PLTBROWSER_CONFIGURE_OFF=	--disable-pltbrowser
 
 WMA_CONFIGURE_OFF=		--disable-wma
 
+.include <bsd.port.options.mk>
+
+.if !${PORT_OPTIONS:MGTK2} && !${PORT_OPTIONS:MGTK3}
+PORT_OPTIONS:=          ${PORT_OPTIONS:NGUI}
+.endif
+
 post-patch:
 # Do not link to libsupc++ which may be PIC-unsafe (breaks 64-bit arches)
 	@${REINPLACE_CMD} -e 's, -lsupc++,,' \
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0