From 56dc0405c3a8e5581bc3899c93a157fd39bba07f Mon Sep 17 00:00:00 2001
From: Renato Botelho <garga@FreeBSD.org>
Date: Thu, 30 Aug 2007 17:28:27 +0000
Subject: A S-Lang module to plot graphs using grace.

Grace is a popular plotting tool that produces publication quality
plots.  The S-Lang module interacts with grace via pipes.

WWW:	http://www.jedsoft.org/slang/modules/grace/index.html
---
 math/Makefile          |  1 +
 math/slgrace/Makefile  | 29 +++++++++++++++++++++++++++++
 math/slgrace/distinfo  |  3 +++
 math/slgrace/pkg-descr |  6 ++++++
 4 files changed, 39 insertions(+)
 create mode 100644 math/slgrace/Makefile
 create mode 100644 math/slgrace/distinfo
 create mode 100644 math/slgrace/pkg-descr

diff --git a/math/Makefile b/math/Makefile
index e8fc4d173a8d..9d3bfeb60e46 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -346,6 +346,7 @@
     SUBDIR += sdpara
     SUBDIR += ses
     SUBDIR += simd-viterbi
+    SUBDIR += slgrace
     SUBDIR += slsc
     SUBDIR += snns
     SUBDIR += solitaire
diff --git a/math/slgrace/Makefile b/math/slgrace/Makefile
new file mode 100644
index 000000000000..6c2b237a2442
--- /dev/null
+++ b/math/slgrace/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for:	slgrace
+# Date created:		2007-08-30
+# Whom:			Renato Botelho <garga@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	slgrace
+PORTVERSION=	0.2.0
+CATEGORIES=	math devel
+MASTER_SITES=	ftp://space.mit.edu/pub/davis/slang/v${SLANG_VER}/modules/grace/ \
+		ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v${SLANG_VER}/modules/grace/
+
+MAINTAINER=	garga@FreeBSD.org
+COMMENT=	A SLang module to plot graphs with grace
+
+LIB_DEPENDS=	slang.2:${PORTSDIR}/devel/libslang2
+RUN_DEPENDS=	grace:${PORTSDIR}/math/grace
+
+SLANG_VER=	2.1
+
+GNU_CONFIGURE=	yes
+
+PLIST_FILES=	lib/slang/v2/modules/grace-module.so.0.2.0 \
+		lib/slang/v2/modules/grace-module.so \
+		share/slsh/local-packages/help/grace.hlp \
+		share/slsh/local-packages/grace.sl
+
+.include <bsd.port.mk>
diff --git a/math/slgrace/distinfo b/math/slgrace/distinfo
new file mode 100644
index 000000000000..671cbed86990
--- /dev/null
+++ b/math/slgrace/distinfo
@@ -0,0 +1,3 @@
+MD5 (slgrace-0.2.0.tar.gz) = 3807c1d59b40e337ab0e8a166486a6c4
+SHA256 (slgrace-0.2.0.tar.gz) = 33007d6009a3cd04d61042e3b3baa511601d996ca73e2c6f8a6e6577a508e54b
+SIZE (slgrace-0.2.0.tar.gz) = 116048
diff --git a/math/slgrace/pkg-descr b/math/slgrace/pkg-descr
new file mode 100644
index 000000000000..04ba5b4a0822
--- /dev/null
+++ b/math/slgrace/pkg-descr
@@ -0,0 +1,6 @@
+A S-Lang module to plot graphs using grace.
+
+Grace is a popular plotting tool that produces publication quality
+plots.  The S-Lang module interacts with grace via pipes.
+
+WWW:	http://www.jedsoft.org/slang/modules/grace/index.html
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0