From 4d8ddd36e40946883479fd88813aa812118b919d Mon Sep 17 00:00:00 2001
From: Renato Botelho <garga@FreeBSD.org>
Date: Sat, 1 Apr 2006 23:06:24 +0000
Subject: - Rename rc.d scripts, removing "z-". It's not more needed since we
 are using   correct REQUIRE: tag

Approved by:	maintainer
---
 sysutils/bacula-client-devel/Makefile              |  2 +-
 sysutils/bacula-server-devel/Makefile              |  4 ++-
 .../bacula-server-devel/files/bacula-dir.sh.in     | 30 ++++++++++++++++++++++
 sysutils/bacula-server-devel/files/bacula-fd.sh.in | 30 ++++++++++++++++++++++
 sysutils/bacula-server-devel/files/bacula-sd.sh.in | 30 ++++++++++++++++++++++
 .../bacula-server-devel/files/z-bacula-dir.sh.in   | 30 ----------------------
 .../bacula-server-devel/files/z-bacula-fd.sh.in    | 30 ----------------------
 .../bacula-server-devel/files/z-bacula-sd.sh.in    | 30 ----------------------
 8 files changed, 94 insertions(+), 92 deletions(-)
 create mode 100644 sysutils/bacula-server-devel/files/bacula-dir.sh.in
 create mode 100644 sysutils/bacula-server-devel/files/bacula-fd.sh.in
 create mode 100644 sysutils/bacula-server-devel/files/bacula-sd.sh.in
 delete mode 100644 sysutils/bacula-server-devel/files/z-bacula-dir.sh.in
 delete mode 100644 sysutils/bacula-server-devel/files/z-bacula-fd.sh.in
 delete mode 100644 sysutils/bacula-server-devel/files/z-bacula-sd.sh.in

diff --git a/sysutils/bacula-client-devel/Makefile b/sysutils/bacula-client-devel/Makefile
index 48039fae7548..7e72ab789c25 100644
--- a/sysutils/bacula-client-devel/Makefile
+++ b/sysutils/bacula-client-devel/Makefile
@@ -15,6 +15,6 @@ COMMENT=	The network backup solution (client) - DEVELOPMENT Version
 PLIST=		${PKGDIR}/pkg-plist.client
 
 WITH_CLIENT_ONLY=	yes
-USE_RC_SUBR=   z-bacula-fd.sh
+USE_RC_SUBR=   bacula-fd.sh
 
 .include "${MASTERDIR}/Makefile"
diff --git a/sysutils/bacula-server-devel/Makefile b/sysutils/bacula-server-devel/Makefile
index 36459ffa7dea..4f5d0485a622 100644
--- a/sysutils/bacula-server-devel/Makefile
+++ b/sysutils/bacula-server-devel/Makefile
@@ -19,7 +19,7 @@ CONFLICTS=	bacula-server-[0-9]* bacula-client-[0-9]*
 
 UNIQUENAME?=${PORTNAME}${PKGNAMESUFFIX}
 
-USE_RC_SUBR?=	z-bacula-dir.sh z-bacula-sd.sh
+USE_RC_SUBR?=	bacula-dir.sh bacula-sd.sh
 
 # The user/group IDs below are registered, see
 # http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#DADS-UID
@@ -133,10 +133,12 @@ CONFFILES=		sd dir
 CONFIGURE_ARGS+=	--with-mysql=yes
 USE_MYSQL=		yes
 DBTYPE=			mysql
+SUB_LIST+=		REQ_MYSQL=mysql REQ_PGSQL=""
 .elif defined(WITH_POSTGRESQL)
 USE_PGSQL=		yes
 CONFIGURE_ARGS+=	--with-postgresql=yes
 DBTYPE=			postgresql
+SUB_LIST+=		REQ_MYSQL="" REQ_PGSQL=postgresql
 .elif defined(WITH_SQLITE3)
 CONFIGURE_ARGS+=	--with-sqlite3=yes
 LIB_DEPENDS+=		sqlite3:${PORTSDIR}/databases/sqlite3
diff --git a/sysutils/bacula-server-devel/files/bacula-dir.sh.in b/sysutils/bacula-server-devel/files/bacula-dir.sh.in
new file mode 100644
index 000000000000..6212cf2f157a
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/bacula-dir.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-dir.sh.in,v 1.1 2006-04-01 23:06:24 garga Exp $
+#
+# PROVIDE: utility
+# REQUIRE: DAEMON %%REQ_MYSQL%% %%REQ_PGSQL%%
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bacula_dir_enable  (bool):   Set to NO by default.
+#                Set it to YES to enable bacula_dir.
+# bacula_dir_flags (params):   Set params used to start bacula_dir.
+#
+
+. %%RC_SUBR%%
+
+name="bacula_dir"
+rcvar=${name}_enable
+command=%%PREFIX%%/sbin/bacula-dir
+pidfile="${bacula_dir_pidfile}"
+
+load_rc_config $name
+
+: ${bacula_dir_enable="NO"}
+: ${bacula_dir_flags=" -u bacula -g operator -v -c %%PREFIX%%/etc/bacula-dir.conf"}
+: ${bacula_dir_pidfile="/var/run/bacula-dir.9101.pid"}
+
+run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/bacula-fd.sh.in b/sysutils/bacula-server-devel/files/bacula-fd.sh.in
new file mode 100644
index 000000000000..845dd93fce4e
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/bacula-fd.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-fd.sh.in,v 1.1 2006-04-01 23:06:24 garga Exp $
+#
+# PROVIDE: utility
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bacula_fd_enable  (bool):  Set to NO by default.
+#               Set it to YES to enable bacula_fd.
+# bacula_fd_flags (params):  Set params used to start bacula_fd.
+#
+
+. %%RC_SUBR%%
+
+name="bacula_fd"
+rcvar=${name}_enable
+command=/usr/local/sbin/bacula-fd
+pidfile="${bacula_fd_pidfile}"
+
+load_rc_config $name
+
+: ${bacula_fd_enable="NO"}
+: ${bacula_fd_flags=" -u root -g wheel -v -c /usr/local/etc/bacula-fd.conf"}
+: ${bacula_fd_pidfile="/var/run/bacula-fd.9102.pid"}
+
+run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/bacula-sd.sh.in b/sysutils/bacula-server-devel/files/bacula-sd.sh.in
new file mode 100644
index 000000000000..37d1f14ab5f0
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/bacula-sd.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/sysutils/bacula-server-devel/files/Attic/bacula-sd.sh.in,v 1.1 2006-04-01 23:06:24 garga Exp $
+#
+# PROVIDE: utility
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bacula_sd_enable  (bool):  Set to NO by default.
+#               Set it to YES to enable bacula_sd.
+# bacula_sd_flags (params):  Set params used to start bacula_sd.
+#
+
+. %%RC_SUBR%%
+
+name="bacula_sd"
+rcvar=`set_rcvar`
+command=/usr/local/sbin/bacula-sd
+pidfile="${bacula_sd_pidfile}"
+
+load_rc_config $name
+
+: ${bacula_sd_enable="NO"}
+: ${bacula_sd_flags=" -u bacula -g bacula -v -c /usr/local/etc/bacula-sd.conf"}
+: ${bacula_sd_pidfile="/var/run/bacula-sd.9103.pid"}
+
+run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/z-bacula-dir.sh.in b/sysutils/bacula-server-devel/files/z-bacula-dir.sh.in
deleted file mode 100644
index 360153ea6b70..000000000000
--- a/sysutils/bacula-server-devel/files/z-bacula-dir.sh.in
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: utility
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-# bacula_dir_enable  (bool):   Set to NO by default.
-#                Set it to YES to enable bacula_dir.
-# bacula_dir_flags (params):   Set params used to start bacula_dir.
-#
-
-. %%RC_SUBR%%
-
-name="bacula_dir"
-rcvar=${name}_enable
-command=%%PREFIX%%/sbin/bacula-dir
-pidfile="${bacula_dir_pidfile}"
-
-load_rc_config $name
-
-: ${bacula_dir_enable="NO"}
-: ${bacula_dir_flags=" -u bacula -g bacula -v -c %%PREFIX%%/etc/bacula-dir.conf"}
-: ${bacula_dir_pidfile="/var/run/bacula-dir.9101.pid"}
-
-run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/z-bacula-fd.sh.in b/sysutils/bacula-server-devel/files/z-bacula-fd.sh.in
deleted file mode 100644
index 5cf5fcf38f0f..000000000000
--- a/sysutils/bacula-server-devel/files/z-bacula-fd.sh.in
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: utility
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-# bacula_fd_enable  (bool):  Set to NO by default.
-#               Set it to YES to enable bacula_fd.
-# bacula_fd_flags (params):  Set params used to start bacula_fd.
-#
-
-. %%RC_SUBR%%
-
-name="bacula_fd"
-rcvar=${name}_enable
-command=/usr/local/sbin/bacula-fd
-pidfile="${bacula_fd_pidfile}"
-
-load_rc_config $name
-
-: ${bacula_fd_enable="NO"}
-: ${bacula_fd_flags=" -u root -g wheel -v -c /usr/local/etc/bacula-fd.conf"}
-: ${bacula_fd_pidfile="/var/run/bacula-fd.9102.pid"}
-
-run_rc_command "$1"
diff --git a/sysutils/bacula-server-devel/files/z-bacula-sd.sh.in b/sysutils/bacula-server-devel/files/z-bacula-sd.sh.in
deleted file mode 100644
index fc98f30f4f38..000000000000
--- a/sysutils/bacula-server-devel/files/z-bacula-sd.sh.in
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: utility
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-# bacula_sd_enable  (bool):  Set to NO by default.
-#               Set it to YES to enable bacula_sd.
-# bacula_sd_flags (params):  Set params used to start bacula_sd.
-#
-
-. %%RC_SUBR%%
-
-name="bacula_sd"
-rcvar=`set_rcvar`
-command=/usr/local/sbin/bacula-sd
-pidfile="${bacula_sd_pidfile}"
-
-load_rc_config $name
-
-: ${bacula_sd_enable="NO"}
-: ${bacula_sd_flags=" -u bacula -g bacula -v -c /usr/local/etc/bacula-sd.conf"}
-: ${bacula_sd_pidfile="/var/run/bacula-sd.9103.pid"}
-
-run_rc_command "$1"
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0