From 4a2d1042cda3ce9f8ce11f5848527ee17ab341c1 Mon Sep 17 00:00:00 2001
From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
Date: Sat, 7 Jun 2014 09:39:34 +0000
Subject: Add explicit dependency on qt4-gui.

This is similar to r356888, in that PyQt's configure.py builds py-qt4-test
with QtGui's libraries (even though, contrary to qt4-sql, it is not used at
configuration time). Using QtGui defines QT_GUI_LIB, which makes the QtTest
headers pull in QtGui ones. QtGui comes for free indirectly when the API
option is set, but the build fails otherwise:

  c++ -c -O2 -pipe -fno-strict-aliasing -fPIC -O2 -Wall -W -pthread -D_THREAD_SAFE -DNDEBUG -DQT_NO_DEBUG -DQT_TEST_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -I/usr/local/include/python2.7 -I/usr/local/share/qt4/mkspecs/default -I/usr/local/include/qt4/QtTest -I/usr/local/include/qt4/QtGui -I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4 -I/usr/local/include -o sipQtTestQTest.o sipQtTestQTest.cpp
  In file included from /wrkdirs/usr/ports/devel/py-qt4-test/work/PyQt-x11-gpl-4.10.3/sip/QtTest/qtestkeyboard.sip:31:
  /usr/local/include/qt4/QtTest/qtestkeyboard.h:56:10: fatal error: 'QtGui/qapplication.h' file not found

PR:		183706
MFH:		2014Q2
---
 devel/py-qt4-test/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/devel/py-qt4-test/Makefile b/devel/py-qt4-test/Makefile
index d0dd6ff54900..d19ca28c27c7 100644
--- a/devel/py-qt4-test/Makefile
+++ b/devel/py-qt4-test/Makefile
@@ -3,6 +3,7 @@
 
 PORTNAME=	test
 PORTVERSION=	${PYQT4_VERSION}
+PORTREVISION=	1
 PORTEPOCH=	1
 CATEGORIES=	devel python
 MASTER_SITES=	${MASTER_SITES_PYQT4}
@@ -18,7 +19,7 @@ RUN_DEPENDS=	${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-q
 DISTINFO_FILE=	${PYQT4_DISTINFO_FILE}
 HAS_CONFIGURE=	yes
 USE_PYTHON=	yes
-USE_QT4=	moc_build qtestlib qmake_build
+USE_QT4=	moc_build gui qtestlib qmake_build
 
 OPTIONS_DEFINE=	API
 OPTIONS_DEFAULT=API
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0