From 4443168d872e4d4a551497d99bd1830f817ad9c0 Mon Sep 17 00:00:00 2001
From: Tobias Kortkamp <tobik@FreeBSD.org>
Date: Fri, 8 Nov 2019 13:34:26 +0000
Subject: net-im: Add missing USES={gnome,xorg}

---
 net-im/corebird/Makefile                  | 3 ++-
 net-im/cutegram/Makefile                  | 3 ++-
 net-im/farsight2/Makefile                 | 2 +-
 net-im/freetalk/Makefile                  | 3 ++-
 net-im/jggtrans/Makefile                  | 2 +-
 net-im/kopete/Makefile                    | 4 ++--
 net-im/libnice/Makefile                   | 2 +-
 net-im/libpurple/Makefile                 | 3 ++-
 net-im/libtelepathy/Makefile              | 2 +-
 net-im/loudmouth/Makefile                 | 2 +-
 net-im/mcabber/Makefile                   | 3 ++-
 net-im/meanwhile/Makefile                 | 2 +-
 net-im/mu-conference/Makefile             | 2 +-
 net-im/pidgin-bs/Makefile                 | 2 +-
 net-im/pidgin-guifications/Makefile       | 2 +-
 net-im/pidgin-hotkeys/Makefile            | 2 +-
 net-im/pidgin-latex/Makefile              | 2 +-
 net-im/pidgin-libnotify/Makefile          | 2 +-
 net-im/pidgin-osd/Makefile                | 2 +-
 net-im/pidgin-privacy-please/Makefile     | 2 +-
 net-im/pidgin-rocketchat/Makefile         | 2 +-
 net-im/pidgin-skypeweb/Makefile           | 3 ++-
 net-im/pidgin-twitter/Makefile            | 2 +-
 net-im/pidgin-window_merge/Makefile       | 2 +-
 net-im/purple-facebook/Makefile           | 2 +-
 net-im/purple-slack/Makefile              | 2 +-
 net-im/scudcloud/Makefile                 | 2 +-
 net-im/telepathy-haze/Makefile            | 2 +-
 net-im/telepathy-idle/Makefile            | 2 +-
 net-im/telepathy-mission-control/Makefile | 2 +-
 net-im/telepathy-python/Makefile          | 2 +-
 net-im/telepathy-rakia/Makefile           | 2 +-
 net-im/telepathy-sofiasip/Makefile        | 2 +-
 net-im/toxic/Makefile                     | 2 +-
 34 files changed, 41 insertions(+), 35 deletions(-)

diff --git a/net-im/corebird/Makefile b/net-im/corebird/Makefile
index 168279058273..6b1afaa01bfd 100644
--- a/net-im/corebird/Makefile
+++ b/net-im/corebird/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS=	libsoup-2.4.so:devel/libsoup \
 		libjson-glib-1.0.so:devel/json-glib \
 		libgspell-1.so:textproc/gspell
 
-USES=		autoreconf compiler:c++11-lang gmake libtool pkgconfig sqlite
+USES=		autoreconf compiler:c++11-lang gmake gnome libtool pkgconfig \
+		sqlite
 
 USE_GITHUB=	yes
 GH_ACCOUNT=	baedert
diff --git a/net-im/cutegram/Makefile b/net-im/cutegram/Makefile
index 7c3e962d1a52..b7dd96bae069 100644
--- a/net-im/cutegram/Makefile
+++ b/net-im/cutegram/Makefile
@@ -23,7 +23,8 @@ GH_PROJECT=	Cutegram aseman-qt-tools:tools
 GH_TAGNAME=	91bf14b:tools
 GH_SUBDIR=	Cutegram/asemantools:tools
 
-USES=		compiler:c++11-lang qmake:outsource desktop-file-utils qt:5 ssl
+USES=		compiler:c++11-lang desktop-file-utils gnome qmake:outsource \
+		qt:5 ssl
 USE_QT=		qmake_build buildtools_build core declarative sql xml multimedia \
 		widgets dbus webkit quickcontrols graphicaleffects sql-sqlite3
 QMAKE_ARGS=	LIBQTELEGRAM_INCLUDE_PATH="${LOCALBASE}/include/libqtelegram-ae" \
diff --git a/net-im/farsight2/Makefile b/net-im/farsight2/Makefile
index 38774fd73d2d..642b252a078e 100644
--- a/net-im/farsight2/Makefile
+++ b/net-im/farsight2/Makefile
@@ -15,7 +15,7 @@ COMMENT=	Collection of GStreamer modules and libraries for videoconferencing
 LIB_DEPENDS=	libnice.so:net-im/libnice
 RUN_DEPENDS=	libnice-gst010>=0:net-im/libnice-gst010
 
-USES=		gettext libtool gmake pathfix pkgconfig python:2.7
+USES=		gettext gmake gnome libtool pathfix pkgconfig python:2.7
 USE_LDCONFIG=	yes
 USE_GNOME=	glib20
 USE_GSTREAMER=	core good bad python
diff --git a/net-im/freetalk/Makefile b/net-im/freetalk/Makefile
index 8a13eadb1ae4..e9f6f10fa5fb 100644
--- a/net-im/freetalk/Makefile
+++ b/net-im/freetalk/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS=	libloudmouth-1.so:net-im/loudmouth \
 		libguile-2.2.so:lang/guile2 \
 		libgc-threaded.so:devel/boehm-gc-threaded
 
-USES=		autoreconf gettext-runtime localbase makeinfo pkgconfig readline
+USES=		autoreconf gettext-runtime gnome localbase makeinfo pkgconfig \
+		readline
 USE_GNOME=	glib20
 GNU_CONFIGURE=	yes
 
diff --git a/net-im/jggtrans/Makefile b/net-im/jggtrans/Makefile
index 6824aee5f9e5..3f0fce3b36a6 100644
--- a/net-im/jggtrans/Makefile
+++ b/net-im/jggtrans/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS=	libidn.so:dns/libidn \
 		libgadu.so:polish/libgadu
 
 GNU_CONFIGURE=	yes
-USES=		gettext gmake pkgconfig
+USES=		gettext gmake gnome pkgconfig
 USE_GNOME=	glib20
 CPPFLAGS+=	-I${LOCALBASE}/include
 LDFLAGS+=	-L${LOCALBASE}/lib
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index bd669a346674..af10aaf6fb38 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -15,8 +15,8 @@ LIB_DEPENDS=    libidn.so:dns/libidn \
 		libqca-qt5.so:devel/qca \
 		libv4l2.so:multimedia/libv4l
 
-USES=		cmake compiler:c++11-lang desktop-file-utils jpeg kde:5 qt:5 shebangfix \
-		tar:xz
+USES=		cmake compiler:c++11-lang desktop-file-utils gnome jpeg kde:5 \
+		qt:5 shebangfix tar:xz
 USE_GNOME=	libxml2 libxslt
 USE_KDE=	archive auth bookmarks codecs completion config configwidgets \
 		coreaddons crash dbusaddons dnssd ecm emoticons guiaddons i18n \
diff --git a/net-im/libnice/Makefile b/net-im/libnice/Makefile
index 390d3134f601..6d953d9a2ea2 100644
--- a/net-im/libnice/Makefile
+++ b/net-im/libnice/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES=	http://nice.freedesktop.org/releases/
 MAINTAINER=	gnome@FreeBSD.org
 COMMENT=	Library and transmitter that implements ICE-19
 
-USES=		gettext gmake libtool pathfix pkgconfig
+USES=		gettext gmake gnome libtool pathfix pkgconfig
 USE_LDCONFIG=	yes
 USE_GNOME=	glib20 introspection:build
 GNU_CONFIGURE=	yes
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index db5997f5728b..84ca73468845 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -11,7 +11,8 @@ DISTNAME=	pidgin-${PORTVERSION}
 MAINTAINER?=	marcus@FreeBSD.org
 COMMENT?=	Backend library for the Pidgin multi-protocol messaging client
 
-USES+=		cpe gettext gmake libtool localbase pathfix pkgconfig tar:bzip2
+USES+=		cpe gettext gmake gnome libtool localbase pathfix pkgconfig \
+		tar:bzip2
 USE_GNOME?=	gnomeprefix intltool glib20 libxml2
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS?=--disable-gtkui \
diff --git a/net-im/libtelepathy/Makefile b/net-im/libtelepathy/Makefile
index 9948278314af..3afdcb6514fc 100644
--- a/net-im/libtelepathy/Makefile
+++ b/net-im/libtelepathy/Makefile
@@ -14,7 +14,7 @@ COMMENT=	Flexible Communications Framework
 LIB_DEPENDS=	libtelepathy-glib.so:net-im/telepathy-glib \
 		libdbus-glib-1.so:devel/dbus-glib
 
-USES=		gmake libtool pathfix pkgconfig python:2.7,build
+USES=		gmake gnome libtool pathfix pkgconfig python:2.7,build
 USE_LDCONFIG=	yes
 USE_GNOME=	glib20 libxslt:build
 GNU_CONFIGURE=	yes
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index ee58fc341be8..ac793a28cdab 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE=	${WRKSRC}/COPYING
 
 LIB_DEPENDS=	libidn.so:dns/libidn
 
-USES=		gettext gmake libtool pkgconfig tar:bzip2
+USES=		gettext gmake gnome libtool pkgconfig tar:bzip2
 USE_GNOME=	glib20
 GNU_CONFIGURE=	yes
 USE_LDCONFIG=	yes
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index 4aeacce44aa8..5dcb18e91e06 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -18,7 +18,8 @@ LICENSE_FILE=	${WRKSRC}/COPYING
 LIB_DEPENDS=	libloudmouth-1.so:net-im/loudmouth \
 		libcharset.so:converters/libiconv
 
-USES=		gettext iconv:wchar_t libtool localbase ncurses pathfix pkgconfig tar:bzip2
+USES=		gettext gnome iconv:wchar_t libtool localbase ncurses pathfix \
+		pkgconfig tar:bzip2
 USE_GNOME=	glib20
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS=	--disable-hgcset
diff --git a/net-im/meanwhile/Makefile b/net-im/meanwhile/Makefile
index 94258ef53fe3..9d444de6d068 100644
--- a/net-im/meanwhile/Makefile
+++ b/net-im/meanwhile/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES=	SF
 MAINTAINER=	marcus@FreeBSD.org
 COMMENT=	Open Source implementation of the Lotus Sametime protocol
 
-USES=		gmake libtool pathfix pkgconfig
+USES=		gmake gnome libtool pathfix pkgconfig
 USE_GNOME=	glib20
 USE_LDCONFIG=	yes
 GNU_CONFIGURE=	yes
diff --git a/net-im/mu-conference/Makefile b/net-im/mu-conference/Makefile
index 8d414d9627de..1e87ff54f945 100644
--- a/net-im/mu-conference/Makefile
+++ b/net-im/mu-conference/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE=	${WRKSRC}/COPYING
 LIB_DEPENDS=	libexpat.so:textproc/expat2 \
 		libidn.so:dns/libidn
 
-USES=		pkgconfig shebangfix
+USES=		gnome pkgconfig shebangfix
 SHEBANG_FILES=	scripts/roommaker.pl scripts/roomname.pl
 USE_GNOME=	glib20
 USE_RC_SUBR=	${PORTNAME}
diff --git a/net-im/pidgin-bs/Makefile b/net-im/pidgin-bs/Makefile
index 856cd8753c15..2e24d577716b 100644
--- a/net-im/pidgin-bs/Makefile
+++ b/net-im/pidgin-bs/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS=	libpurple.so:net-im/libpurple
 RUN_DEPENDS=	pidgin:net-im/pidgin
 
 GNU_CONFIGURE=	yes
-USES=		gettext gmake libtool pkgconfig tar:bzip2
+USES=		gettext gmake gnome libtool pkgconfig tar:bzip2
 USE_GNOME=	gtk20 intltool
 USE_LDCONFIG=	${PREFIX}/lib/pidgin
 
diff --git a/net-im/pidgin-guifications/Makefile b/net-im/pidgin-guifications/Makefile
index cf0fad0f1bff..188847659ce3 100644
--- a/net-im/pidgin-guifications/Makefile
+++ b/net-im/pidgin-guifications/Makefile
@@ -17,7 +17,7 @@ LICENSE=	GPLv2
 BUILD_DEPENDS=	${LOCALBASE}/include/pidgin/pidgin.h:net-im/pidgin
 RUN_DEPENDS=	pidgin:net-im/pidgin
 
-USES=		gettext gmake libtool pathfix pkgconfig tar:bzip2
+USES=		gettext gmake gnome libtool pathfix pkgconfig tar:bzip2
 USE_GNOME=	gtk20 intltool
 GNU_CONFIGURE=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
diff --git a/net-im/pidgin-hotkeys/Makefile b/net-im/pidgin-hotkeys/Makefile
index bb5e8192fb23..c17e33b1de15 100644
--- a/net-im/pidgin-hotkeys/Makefile
+++ b/net-im/pidgin-hotkeys/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS=	libpurple.so:net-im/libpurple
 BUILD_DEPENDS=	pidgin:net-im/pidgin
 RUN_DEPENDS=	pidgin:net-im/pidgin
 
-USES=		libtool pkgconfig
+USES=		gnome libtool pkgconfig
 USE_GNOME=	gtk20
 GNU_CONFIGURE=	yes
 
diff --git a/net-im/pidgin-latex/Makefile b/net-im/pidgin-latex/Makefile
index eefd05c6f520..7f5c9da7b2e8 100644
--- a/net-im/pidgin-latex/Makefile
+++ b/net-im/pidgin-latex/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS=	pidgin:net-im/pidgin \
 
 WRKSRC=		${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
 
-USES=		gmake pkgconfig tar:bzip2
+USES=		gmake gnome pkgconfig tar:bzip2
 USE_TEX=	latex
 USE_GNOME=	gtk20
 MAKE_ARGS=	CC="${CC}"
diff --git a/net-im/pidgin-libnotify/Makefile b/net-im/pidgin-libnotify/Makefile
index 972de7813766..663ab2d9ed95 100644
--- a/net-im/pidgin-libnotify/Makefile
+++ b/net-im/pidgin-libnotify/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS=	libnotify.so:devel/libnotify \
 		libpurple.so:net-im/libpurple
 
 GNU_CONFIGURE=	yes
-USES=		gmake libtool pkgconfig
+USES=		gmake gnome libtool pkgconfig
 USE_LDCONFIG=	yes
 USE_GNOME=	gtk20 intltool
 
diff --git a/net-im/pidgin-osd/Makefile b/net-im/pidgin-osd/Makefile
index bf0c1ca9380a..eec97d89d522 100644
--- a/net-im/pidgin-osd/Makefile
+++ b/net-im/pidgin-osd/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS=	pidgin:net-im/pidgin \
 RUN_DEPENDS=	pidgin:net-im/pidgin \
 		xosd>=2.2.12:misc/xosd
 
-USES=		gmake libtool pkgconfig tar:bzip2
+USES=		gmake gnome libtool pkgconfig tar:bzip2
 USE_GNOME=	glib20
 GNU_CONFIGURE=	yes
 
diff --git a/net-im/pidgin-privacy-please/Makefile b/net-im/pidgin-privacy-please/Makefile
index b59ca604ced5..2734c192d39a 100644
--- a/net-im/pidgin-privacy-please/Makefile
+++ b/net-im/pidgin-privacy-please/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS=	pidgin:net-im/pidgin
 RUN_DEPENDS=	pidgin:net-im/pidgin
 
 GNU_CONFIGURE=	yes
-USES=		gmake gettext libtool pkgconfig autoreconf
+USES=		autoreconf gettext gmake gnome libtool pkgconfig
 USE_GNOME=	cairo gdkpixbuf2 gtk20 intltool
 USE_LDCONFIG=	yes
 
diff --git a/net-im/pidgin-rocketchat/Makefile b/net-im/pidgin-rocketchat/Makefile
index b69cf59b4415..2b32b5262b6a 100644
--- a/net-im/pidgin-rocketchat/Makefile
+++ b/net-im/pidgin-rocketchat/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS=	libjson-glib-1.0.so:devel/json-glib \
 BUILD_DEPENDS=	${LOCALBASE}/lib/libmarkdown.a:textproc/discount
 RUN_DEPENDS=	pidgin:net-im/pidgin
 
-USES=		gmake pkgconfig zip
+USES=		gmake gnome pkgconfig zip
 USE_GNOME=	glib20
 USE_LDCONFIG=	yes
 
diff --git a/net-im/pidgin-skypeweb/Makefile b/net-im/pidgin-skypeweb/Makefile
index 58b25eb02ee3..aad9becc523e 100644
--- a/net-im/pidgin-skypeweb/Makefile
+++ b/net-im/pidgin-skypeweb/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS=	pidgin:net-im/pidgin
 LIB_DEPENDS=	libjson-glib-1.0.so:devel/json-glib \
 		libpurple.so:net-im/libpurple
 
-USES=		cmake dos2unix gettext-runtime localbase:ldflags pkgconfig
+USES=		cmake dos2unix gettext-runtime gnome localbase:ldflags \
+		pkgconfig
 USE_GITHUB=	yes
 GH_ACCOUNT=	EionRobb
 GH_PROJECT=	skype4pidgin
diff --git a/net-im/pidgin-twitter/Makefile b/net-im/pidgin-twitter/Makefile
index daa805b3a59c..5952a422ab50 100644
--- a/net-im/pidgin-twitter/Makefile
+++ b/net-im/pidgin-twitter/Makefile
@@ -13,7 +13,7 @@ COMMENT=	Pidgin plugin to help twitting via pidgin
 BUILD_DEPENDS=	pidgin:net-im/pidgin
 RUN_DEPENDS=	pidgin:net-im/pidgin
 
-USES=		gmake pkgconfig
+USES=		gmake gnome pkgconfig
 USE_GNOME=	glib20 libxml2
 GNU_CONFIGURE=	yes
 
diff --git a/net-im/pidgin-window_merge/Makefile b/net-im/pidgin-window_merge/Makefile
index 40c82d8438b7..4a714cee9375 100644
--- a/net-im/pidgin-window_merge/Makefile
+++ b/net-im/pidgin-window_merge/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS=	pidgin:net-im/pidgin
 GNU_CONFIGURE=	yes
 CONFIGURE_ARGS=	--disable-static
 
-USES=		autoreconf gmake libtool pkgconfig localbase:ldflags
+USES=		autoreconf gmake gnome libtool localbase:ldflags pkgconfig
 USE_GNOME=	intltool
 
 INSTALL_TARGET=	install-strip
diff --git a/net-im/purple-facebook/Makefile b/net-im/purple-facebook/Makefile
index 3ebcbcab3bd7..2bc92b79f27a 100644
--- a/net-im/purple-facebook/Makefile
+++ b/net-im/purple-facebook/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS=	libpurple.so:net-im/libpurple \
 		libjson-glib-1.0.so:devel/json-glib
 
 GITHASH=	9ff9acf9fa14
-USES=		autoreconf libtool pkgconfig
+USES=		autoreconf gnome libtool pkgconfig
 PLIST_FILES=	lib/purple-2/libfacebook.so
 GNU_CONFIGURE=	yes
 USE_GNOME=	glib20
diff --git a/net-im/purple-slack/Makefile b/net-im/purple-slack/Makefile
index 54cd2ed779be..f71ba4184b31 100644
--- a/net-im/purple-slack/Makefile
+++ b/net-im/purple-slack/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE=	${WRKSRC}/COPYING
 LIB_DEPENDS=	libpurple.so:net-im/libpurple
 BUILD_DEPENDS=	bash:shells/bash
 
-USES=		gmake pkgconfig
+USES=		gmake gnome pkgconfig
 USE_GNOME=	glib20
 USE_LDCONFIG=	yes
 
diff --git a/net-im/scudcloud/Makefile b/net-im/scudcloud/Makefile
index 594792d93981..a6ebc72bfb9e 100644
--- a/net-im/scudcloud/Makefile
+++ b/net-im/scudcloud/Makefile
@@ -28,7 +28,7 @@ INSTALLS_ICONS=	yes
 
 OPTIONS_DEFINE=	HUNSPELL
 
-USES=		python:3.4+
+USES=		gnome python:3.4+
 USE_GITHUB=	yes
 USE_PYTHON=	autoplist distutils optsuffix
 NO_ARCH=	yes
diff --git a/net-im/telepathy-haze/Makefile b/net-im/telepathy-haze/Makefile
index 9b6a60ad5e55..44d564ece6c4 100644
--- a/net-im/telepathy-haze/Makefile
+++ b/net-im/telepathy-haze/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS=	libpurple.so:net-im/libpurple \
 		libidn.so:dns/libidn \
 		libtelepathy-glib.so:net-im/telepathy-glib
 
-USES=		gmake pathfix pkgconfig python:2.7,build
+USES=		gmake gnome pathfix pkgconfig python:2.7,build
 USE_GNOME=	libxslt:build
 CPPFLAGS+=	-I${LOCALBASE}/include
 GNU_CONFIGURE=	yes
diff --git a/net-im/telepathy-idle/Makefile b/net-im/telepathy-idle/Makefile
index 54b108a0b9e0..d123a04adf4d 100644
--- a/net-im/telepathy-idle/Makefile
+++ b/net-im/telepathy-idle/Makefile
@@ -14,7 +14,7 @@ COMMENT=	IRC Connection Manager for Telepathy Framework
 LIB_DEPENDS=	libdbus-glib-1.so:devel/dbus-glib \
 		libtelepathy-glib.so:net-im/telepathy-glib
 
-USES=		gmake libtool pathfix pkgconfig python:2.7,build ssl
+USES=		gmake gnome libtool pathfix pkgconfig python:2.7,build ssl
 USE_GNOME=	glib20 libxslt:build
 GNU_CONFIGURE=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
diff --git a/net-im/telepathy-mission-control/Makefile b/net-im/telepathy-mission-control/Makefile
index 8e1ea1d84f91..18342a758e42 100644
--- a/net-im/telepathy-mission-control/Makefile
+++ b/net-im/telepathy-mission-control/Makefile
@@ -14,7 +14,7 @@ COMMENT=	Telepathy component to apps to abstract details of connection managers
 LIB_DEPENDS=	libtelepathy.so:net-im/libtelepathy \
 		libdbus-glib-1.so:devel/dbus-glib
 
-USES=		gmake libtool pathfix pkgconfig python:2.7,build
+USES=		gmake gnome libtool pathfix pkgconfig python:2.7,build
 USE_GNOME=	glib20 libxslt
 GNU_CONFIGURE=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
diff --git a/net-im/telepathy-python/Makefile b/net-im/telepathy-python/Makefile
index 715abe3b40bd..1143c23cc2d5 100644
--- a/net-im/telepathy-python/Makefile
+++ b/net-im/telepathy-python/Makefile
@@ -14,7 +14,7 @@ COMMENT=	Python bindings for the Telepathy framework
 BUILD_DEPENDS=	${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
 RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
 
-USES=		gmake python:2.7
+USES=		gmake gnome python:2.7
 USE_GNOME=	libxslt:build
 GNU_CONFIGURE=	yes
 CPPFLAGS+=	-I${LOCALBASE}/include
diff --git a/net-im/telepathy-rakia/Makefile b/net-im/telepathy-rakia/Makefile
index ac4c25d531b0..756472a9fdc9 100644
--- a/net-im/telepathy-rakia/Makefile
+++ b/net-im/telepathy-rakia/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS=	libdbus-glib-1.so:devel/dbus-glib \
 		libsofia-sip-ua-glib.so:net/sofia-sip \
 		libtelepathy-glib.so:net-im/telepathy-glib
 
-USES=		gmake pathfix pkgconfig python:2.7,build ssl
+USES=		gmake gnome pathfix pkgconfig python:2.7,build ssl
 USE_GNOME=	glib20 libxslt:build
 GNU_CONFIGURE=	yes
 INSTALL_TARGET=	install-strip
diff --git a/net-im/telepathy-sofiasip/Makefile b/net-im/telepathy-sofiasip/Makefile
index fd3a4e42c933..8b9740449f7a 100644
--- a/net-im/telepathy-sofiasip/Makefile
+++ b/net-im/telepathy-sofiasip/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS=	libsofia-sip-ua.so:net/sofia-sip \
 		libdbus-glib-1.so:devel/dbus-glib
 
 GNU_CONFIGURE=	yes
-USES=		pkgconfig gmake ssl
+USES=		gmake gnome pkgconfig ssl
 USE_GNOME=	glib20
 
 .include <bsd.port.mk>
diff --git a/net-im/toxic/Makefile b/net-im/toxic/Makefile
index d59764ebd591..7e816751f1ea 100644
--- a/net-im/toxic/Makefile
+++ b/net-im/toxic/Makefile
@@ -31,7 +31,7 @@ GH_ACCOUNT=	JFreegman
 OPTIONS_DEFINE=	X11 PYTHON
 OPTIONS_DEFAULT=X11
 
-X11_USES=	gnome
+X11_USES=	gnome xorg
 X11_USE=	GNOME=gdkpixbuf2,glib20 XORG=x11
 X11_MAKE_ARGS_OFF=	DISABLE_X11=1 DISABLE_DESKTOP_NOTIFY=1
 X11_LIB_DEPENDS=libnotify.so:devel/libnotify
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0