From 41a8b2e89f8310ce38d948614a2a15e8f579dadb Mon Sep 17 00:00:00 2001
From: Ying-Chieh Liao <ijliao@FreeBSD.org>
Date: Tue, 16 Jul 2002 06:53:52 +0000
Subject: add mpqc-mpich

PR:		40631
Submitted by:	Nakata Maho <chat95@mbox.kyoto-inet.or.jp>
---
 science/Makefile            |  1 +
 science/mpqc-mpich/Makefile | 25 +++++++++++++++++++++++++
 2 files changed, 26 insertions(+)
 create mode 100644 science/mpqc-mpich/Makefile

diff --git a/science/Makefile b/science/Makefile
index e9ceb2db4f9f..3d8849b72cd4 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -8,6 +8,7 @@
     SUBDIR += libsvm
     SUBDIR += mayavi
     SUBDIR += mpqc
+    SUBDIR += mpqc-mpich
     SUBDIR += oases
     SUBDIR += p5-Chemistry-Elements
     SUBDIR += vis5d+
diff --git a/science/mpqc-mpich/Makefile b/science/mpqc-mpich/Makefile
new file mode 100644
index 000000000000..22f2385a7bb3
--- /dev/null
+++ b/science/mpqc-mpich/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for:	mpqc-mpich
+# Date created:			27 April 2001
+# Whom:				Nakata Maho <chat95@mbox.kyoto-inet.or.jp>
+#
+# $FreeBSD$
+#
+
+MASTERDIR=	${.CURDIR}/../mpqc/
+
+.include "${.CURDIR}/../mpqc/Makefile"
+
+LIB_DEPENDS=	lapack:${PORTSDIR}/math/lapack \
+		atlas:${PORTSDIR}/math/atlas
+BUILD_DEPENDS=	${LOCALBASE}/mpich/lib/libmpich.a:${PORTSDIR}/net/mpich
+
+# MPICH implimentation is not thread safe
+CONFIGURE_ARGS=	--with-libdirs="-L${PREFIX}/lib -L${PREFIX}/mpich/lib" 
+		--with-blas="-lf77blas -latlas" \
+		--with-lapack="-lalapack -lcblas" \
+		--with-coptflags="${CFLAGS}" \
+		--with-cxxoptflags="${CFLAGS}" \
+		--with-f77optflags="${FFLAGS}" \
+		--with-include=-I${PREFIX}/mpich/include \
+		--enable-always-use-mpi \
+		--enable-threads=no
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0