From 3db203668446793877fb0d720515ce31da2df35b Mon Sep 17 00:00:00 2001
From: Will Andrews <will@FreeBSD.org>
Date: Thu, 4 Jan 2001 00:09:56 +0000
Subject: Add p5-Server-FastPL 1.0.2, perl module to eliminate the compile-time
 of big scripts.

PR:		24028
Submitted by:	Anton Berezin <tobez@tobez.org>
---
 devel/Makefile                     |  1 +
 devel/p5-Server-FastPL/Makefile    | 24 ++++++++++++++++++++++++
 devel/p5-Server-FastPL/distinfo    |  1 +
 devel/p5-Server-FastPL/pkg-comment |  1 +
 devel/p5-Server-FastPL/pkg-descr   |  6 ++++++
 devel/p5-Server-FastPL/pkg-plist   |  8 ++++++++
 6 files changed, 41 insertions(+)
 create mode 100644 devel/p5-Server-FastPL/Makefile
 create mode 100644 devel/p5-Server-FastPL/distinfo
 create mode 100644 devel/p5-Server-FastPL/pkg-comment
 create mode 100644 devel/p5-Server-FastPL/pkg-descr
 create mode 100644 devel/p5-Server-FastPL/pkg-plist

diff --git a/devel/Makefile b/devel/Makefile
index 956e13874758..7cd5c5335d46 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -269,6 +269,7 @@
     SUBDIR += p5-ReadLine-Perl
     SUBDIR += p5-Religion
     SUBDIR += p5-Resources
+    SUBDIR += p5-Server-FastPL
     SUBDIR += p5-Set-NestedGroups
     SUBDIR += p5-Set-Object
     SUBDIR += p5-Set-Scalar
diff --git a/devel/p5-Server-FastPL/Makefile b/devel/p5-Server-FastPL/Makefile
new file mode 100644
index 000000000000..ec98f2ab81e1
--- /dev/null
+++ b/devel/p5-Server-FastPL/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for:	devel/p5-Server-FastPL
+# Date created:				03 January 2001
+# Whom:					Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	Server-FastPL
+PORTVERSION=	1.0.2
+CATEGORIES=	devel perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=	Server
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	tobez@tobez.org
+
+USE_PERL5=	yes
+PERL_CONFIGURE=	yes
+
+MAN3=		Server::FastPL.3 Server::FastPL::Client.3 \
+		Server::FastPL::Server.3
+MANPREFIX=	${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Server-FastPL/distinfo b/devel/p5-Server-FastPL/distinfo
new file mode 100644
index 000000000000..75b49ccc9702
--- /dev/null
+++ b/devel/p5-Server-FastPL/distinfo
@@ -0,0 +1 @@
+MD5 (Server-FastPL-1.0.2.tar.gz) = 4d5cfec7939903dd302867b5d9690254
diff --git a/devel/p5-Server-FastPL/pkg-comment b/devel/p5-Server-FastPL/pkg-comment
new file mode 100644
index 000000000000..e940bf36b6ab
--- /dev/null
+++ b/devel/p5-Server-FastPL/pkg-comment
@@ -0,0 +1 @@
+Perl module to eliminate the compile-time of big scripts
diff --git a/devel/p5-Server-FastPL/pkg-descr b/devel/p5-Server-FastPL/pkg-descr
new file mode 100644
index 000000000000..ce150fd710fb
--- /dev/null
+++ b/devel/p5-Server-FastPL/pkg-descr
@@ -0,0 +1,6 @@
+This module was created to avoid the compile time of big scripts that runs a
+lot of times. It works forking your script into MAX_CHILDS childs, and using
+Unix Sockets to run your code. Just like CGI::Fast.
+
+-Anton
+<tobez@tobez.org>
diff --git a/devel/p5-Server-FastPL/pkg-plist b/devel/p5-Server-FastPL/pkg-plist
new file mode 100644
index 000000000000..340e35b3d09b
--- /dev/null
+++ b/devel/p5-Server-FastPL/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Server/FastPL/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Server/FastPL.pm
+lib/perl5/site_perl/%%PERL_VER%%/Server/FastPL/Client.pm
+lib/perl5/site_perl/%%PERL_VER%%/Server/FastPL/Server.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Server/FastPL
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Server/FastPL
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Server 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Server 2>/dev/null || true
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0