From 3da6f55ba8e4b1fcadbf4468204c71a9f8805b26 Mon Sep 17 00:00:00 2001
From: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
Date: Mon, 4 Nov 2002 23:55:30 +0000
Subject: Fix regexp and patches to work with recently added USE_REINPLACE

---
 misc/edonkey-tool-slist/Makefile                   |  4 +---
 misc/edonkey-tool-slist/files/patch-linux_net.c    | 10 ++++++++++
 net-p2p/edonkey-tool-slist/Makefile                |  4 +---
 net-p2p/edonkey-tool-slist/files/patch-linux_net.c | 10 ++++++++++
 4 files changed, 22 insertions(+), 6 deletions(-)
 create mode 100644 misc/edonkey-tool-slist/files/patch-linux_net.c
 create mode 100644 net-p2p/edonkey-tool-slist/files/patch-linux_net.c

diff --git a/misc/edonkey-tool-slist/Makefile b/misc/edonkey-tool-slist/Makefile
index 6b80b296f552..c02e03712821 100644
--- a/misc/edonkey-tool-slist/Makefile
+++ b/misc/edonkey-tool-slist/Makefile
@@ -18,9 +18,7 @@ WRKSRC=	${WRKDIR}/ed2k_slist
 USE_REINPLACE=	yes
 
 post-patch:
-	@${REINPLACE_CMD} -e 's|\r\n|\n|' ${WRKSRC}/*.[ch]
-	@${REINPLACE_CMD} -e 's|(#include <unistd.h>)|\1\n#include\
-		<sys/time.h>|' ${WRKSRC}/linux_net.c
+	@${REINPLACE_CMD} -e 's|
||' ${WRKSRC}/*.[ch]
 
 # I could have written a Makefile but I would rather
 # not waste inodes
diff --git a/misc/edonkey-tool-slist/files/patch-linux_net.c b/misc/edonkey-tool-slist/files/patch-linux_net.c
new file mode 100644
index 000000000000..f1280c9c1e97
--- /dev/null
+++ b/misc/edonkey-tool-slist/files/patch-linux_net.c
@@ -0,0 +1,10 @@
+--- linux_net.c.orig	Mon Nov  4 21:50:07 2002
++++ linux_net.c	Mon Nov  4 21:50:15 2002
+@@ -27,6 +27,7 @@
+ #include <arpa/inet.h>
+ #include <netdb.h>
+ #include <unistd.h>
++#include <sys/time.h>
+ 
+ /* connect with timeout
+ *
diff --git a/net-p2p/edonkey-tool-slist/Makefile b/net-p2p/edonkey-tool-slist/Makefile
index 6b80b296f552..c02e03712821 100644
--- a/net-p2p/edonkey-tool-slist/Makefile
+++ b/net-p2p/edonkey-tool-slist/Makefile
@@ -18,9 +18,7 @@ WRKSRC=	${WRKDIR}/ed2k_slist
 USE_REINPLACE=	yes
 
 post-patch:
-	@${REINPLACE_CMD} -e 's|\r\n|\n|' ${WRKSRC}/*.[ch]
-	@${REINPLACE_CMD} -e 's|(#include <unistd.h>)|\1\n#include\
-		<sys/time.h>|' ${WRKSRC}/linux_net.c
+	@${REINPLACE_CMD} -e 's|
||' ${WRKSRC}/*.[ch]
 
 # I could have written a Makefile but I would rather
 # not waste inodes
diff --git a/net-p2p/edonkey-tool-slist/files/patch-linux_net.c b/net-p2p/edonkey-tool-slist/files/patch-linux_net.c
new file mode 100644
index 000000000000..f1280c9c1e97
--- /dev/null
+++ b/net-p2p/edonkey-tool-slist/files/patch-linux_net.c
@@ -0,0 +1,10 @@
+--- linux_net.c.orig	Mon Nov  4 21:50:07 2002
++++ linux_net.c	Mon Nov  4 21:50:15 2002
+@@ -27,6 +27,7 @@
+ #include <arpa/inet.h>
+ #include <netdb.h>
+ #include <unistd.h>
++#include <sys/time.h>
+ 
+ /* connect with timeout
+ *
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0