From 36f8276f2aa5c0c308adb8d0c62feefd6ac28f9f Mon Sep 17 00:00:00 2001
From: Will Andrews <will@FreeBSD.org>
Date: Sun, 31 Dec 2000 05:42:03 +0000
Subject: Add p5-Text-Query 0.07, a perl module implementing a query process
 framework.

PR:		23968
Submitted by:	Anton Berezin <tobez@tobez.org>
---
 textproc/Makefile                  |  1 +
 textproc/p5-Text-Query/Makefile    | 33 +++++++++++++++++++++++++++++++++
 textproc/p5-Text-Query/distinfo    |  1 +
 textproc/p5-Text-Query/pkg-comment |  1 +
 textproc/p5-Text-Query/pkg-descr   | 15 +++++++++++++++
 textproc/p5-Text-Query/pkg-plist   | 18 ++++++++++++++++++
 6 files changed, 69 insertions(+)
 create mode 100644 textproc/p5-Text-Query/Makefile
 create mode 100644 textproc/p5-Text-Query/distinfo
 create mode 100644 textproc/p5-Text-Query/pkg-comment
 create mode 100644 textproc/p5-Text-Query/pkg-descr
 create mode 100644 textproc/p5-Text-Query/pkg-plist

diff --git a/textproc/Makefile b/textproc/Makefile
index c2e10763f410..df671bc84339 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -83,6 +83,7 @@
     SUBDIR += p5-Text-Flowchart
     SUBDIR += p5-Text-Format
     SUBDIR += p5-Text-Graphics
+    SUBDIR += p5-Text-Query
     SUBDIR += p5-Text-Template
     SUBDIR += p5-Text-Wrapper
     SUBDIR += p5-XML-DOM
diff --git a/textproc/p5-Text-Query/Makefile b/textproc/p5-Text-Query/Makefile
new file mode 100644
index 000000000000..053a32420687
--- /dev/null
+++ b/textproc/p5-Text-Query/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for:	textproc/p5-Text-Query
+# Date created:				31 December 2000
+# Whom:					Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	Text-Query
+PORTVERSION=	0.07
+CATEGORIES=	textproc perl5
+MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=	Text
+PKGNAMEPREFIX=	p5-
+
+MAINTAINER=	tobez@tobez.org
+
+USE_PERL5=	yes
+PERL_CONFIGURE=	yes
+
+MAN3=		Text::Query.3 Text::Query::Build.3 \
+		Text::Query::BuildAdvancedString.3 \
+		Text::Query::BuildSimpleString.3 Text::Query::Optimize.3 \
+		Text::Query::Parse.3 Text::Query::ParseAdvanced.3 \
+		Text::Query::ParseSimple.3 Text::Query::Solve.3 \
+		Text::Query::SolveAdvancedString.3 \
+		Text::Query::SolveSimpleString.3
+MANPREFIX=	${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+	@${PERL} -pi -e 's/factor\(\$$self\)/\&factor(\$$self)/' \
+		${WRKSRC}/lib/Text/Query/ParseAdvanced.pm
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Query/distinfo b/textproc/p5-Text-Query/distinfo
new file mode 100644
index 000000000000..7f39e6db7baf
--- /dev/null
+++ b/textproc/p5-Text-Query/distinfo
@@ -0,0 +1 @@
+MD5 (Text-Query-0.07.tar.gz) = 1452eadb3b2e2da948431655733582a5
diff --git a/textproc/p5-Text-Query/pkg-comment b/textproc/p5-Text-Query/pkg-comment
new file mode 100644
index 000000000000..8c6d0faa4603
--- /dev/null
+++ b/textproc/p5-Text-Query/pkg-comment
@@ -0,0 +1 @@
+Query processing framework
diff --git a/textproc/p5-Text-Query/pkg-descr b/textproc/p5-Text-Query/pkg-descr
new file mode 100644
index 000000000000..9b64b4c274e6
--- /dev/null
+++ b/textproc/p5-Text-Query/pkg-descr
@@ -0,0 +1,15 @@
+This module provides an object that matches a data source against a
+query expression.
+
+Query expressions are compiled into an internal form when a new object
+is created or the `prepare' method is called; they are not recompiled on
+each match.
+
+The class provided by this module uses four packages to process the
+query. The query parser parses the question and calls a query expression
+builder (internal form of the question). The optimizer is then called to
+reduce the complexity of the expression. The solver applies the
+expression on a data source. 
+
+-Anton
+<tobez@tobez.org>
diff --git a/textproc/p5-Text-Query/pkg-plist b/textproc/p5-Text-Query/pkg-plist
new file mode 100644
index 000000000000..d35fe9eb1347
--- /dev/null
+++ b/textproc/p5-Text-Query/pkg-plist
@@ -0,0 +1,18 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Query/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/Advanced.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/Build.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/Parse.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/BuildAdvancedString.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/BuildSimpleString.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/SolveAdvancedString.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/Solve.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/ParseAdvanced.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/SolveSimpleString.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/Optimize.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/Simple.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/ParseSimple.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Query
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Text/Query
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Text 2>/dev/null || true
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0